aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2012-06-18 00:47:13 +0800
committerbf <bf@FreeBSD.org>2012-06-18 00:47:13 +0800
commitf3d2e8944874ad709002563c7fa0f40af0b0739e (patch)
tree0f04476cf8b1a739a497cc537f56a6a5648b5f61 /security
parented72151361fcd78a82c10b15ba79a1f792b5ec2e (diff)
downloadfreebsd-ports-gnome-f3d2e8944874ad709002563c7fa0f40af0b0739e.tar.gz
freebsd-ports-gnome-f3d2e8944874ad709002563c7fa0f40af0b0739e.tar.zst
freebsd-ports-gnome-f3d2e8944874ad709002563c7fa0f40af0b0739e.zip
update to 0.2.3.17-beta
Diffstat (limited to 'security')
-rw-r--r--security/tor-devel/Makefile9
-rw-r--r--security/tor-devel/distinfo4
-rw-r--r--security/tor-devel/files/patch-configure23
3 files changed, 15 insertions, 21 deletions
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index b2ac42687556..8e7bb2002052 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tor
-DISTVERSION= 0.2.3.16-alpha
+DISTVERSION= 0.2.3.17-beta
CATEGORIES= security net ipv6
MASTER_SITES= https://www.torproject.org/dist/ \
ftp://ftp.bit.nl/mirror/tor/ \
@@ -109,6 +109,8 @@ MAKE_JOBS_UNSAFE= yes
(${OSVERSION} >= 900003) ) && !defined(USE_GCC) && empty(CC:T:M*gcc4*) && \
empty(PORT_OPTIONS:MSTATIC_TOR)
CONFIGURE_ARGS+= --enable-gcc-hardening
+.else
+CONFIGURE_ARGS+= --disable-gcc-hardening
.endif
.if ( ${OSVERSION} < 704000 || \
@@ -138,7 +140,7 @@ CONFIGURE_ARGS+= --disable-instrument-downloads
.if ${PORT_OPTIONS:MSTATIC_TOR}
BUILD_DEPENDS += ${LOCALBASE}/lib/event2/libevent.a:${PORTSDIR}/devel/libevent2
CONFIGURE_ARGS+= --enable-static-tor --with-libevent-dir=${LOCALBASE}/lib/event2 \
- --with-zlib-dir=/usr/lib
+ --with-zlib-dir=/usr/lib --disable-linker-hardening
TOR_LIBEVENT_LIBS= ${LOCALBASE}/lib/event2/libevent.a
.if ${PORT_OPTIONS:MBUFFEREVENTS}
TOR_LIBEVENT_LIBS:= ${LOCALBASE}/lib/event2/libevent_openssl.a ${TOR_LIBEVENT_LIBS}
@@ -185,7 +187,8 @@ post-patch:
${WRKSRC}/contrib/Makefile.in
@${REINPLACE_CMD} -e '\|^install-data-am:|s|install-docDATA||' \
${WRKSRC}/doc/Makefile.in
- @${REINPLACE_CMD} -e "s|-ltcmalloc|${LOCALBASE}/lib/libtcmalloc.so|" \
+ @${REINPLACE_CMD} -E -e "s@-ltcmalloc@${LOCALBASE}/lib/libtcmalloc.so@" \
+ -e "s@(-z) (relro|now)@-Wl,\1,\2@g" \
${WRKSRC}/configure
post-configure:
diff --git a/security/tor-devel/distinfo b/security/tor-devel/distinfo
index b94d3eeb1051..f2d186ba7efb 100644
--- a/security/tor-devel/distinfo
+++ b/security/tor-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tor-0.2.3.16-alpha.tar.gz) = 853fed0ce5d37a813c0742d07a5da3cd35164a604f59c1a3cb4b8d657c468d46
-SIZE (tor-0.2.3.16-alpha.tar.gz) = 3135571
+SHA256 (tor-0.2.3.17-beta.tar.gz) = 9106383e537a3e27a1ba9ac6b5a6bb9b88d8a1f7cf8c83f32b0e563f5eb03dd3
+SIZE (tor-0.2.3.17-beta.tar.gz) = 3098483
diff --git a/security/tor-devel/files/patch-configure b/security/tor-devel/files/patch-configure
index e9a7e3dd0fda..fcc1bc234a18 100644
--- a/security/tor-devel/files/patch-configure
+++ b/security/tor-devel/files/patch-configure
@@ -1,15 +1,6 @@
---- configure.orig 2011-11-22 18:30:03.000000000 -0500
-+++ configure 2011-11-25 23:40:34.000000000 -0500
-@@ -3334,7 +3334,7 @@
- # Check whether --enable-linker-hardening was given.
- if test "${enable_linker_hardening+set}" = set; then :
- enableval=$enable_linker_hardening; if test x$enableval = xyes; then
-- LDFLAGS="$LDFLAGS -z relro -z now"
-+ LDFLAGS="$LDFLAGS -Wl,-z,relro -Wl,-z,now"
- fi
- fi
-
-@@ -6286,6 +6286,7 @@
+--- configure.orig 2012-06-15 03:10:31.000000000 -0400
++++ configure 2012-06-17 08:46:34.000000000 -0400
+@@ -6319,6 +6319,7 @@
fi
@@ -17,7 +8,7 @@
trylibeventdir=""
# Check whether --with-libevent-dir was given.
-@@ -6612,6 +6613,7 @@
+@@ -6645,6 +6646,7 @@
LIBS="$tor_saved_LIBS"
LDFLAGS="$tor_saved_LDFLAGS"
CPPFLAGS="$tor_saved_CPPFLAGS"
@@ -25,7 +16,7 @@
-@@ -6674,6 +6676,7 @@
+@@ -6707,6 +6709,7 @@
fi
@@ -33,7 +24,7 @@
if test "$enable_static_libevent" = "yes"; then
if test "$tor_cv_library_libevent_dir" = "(system)"; then
as_fn_error $? "\"You must specify an explicit --with-libevent-dir=x option when using --enable-static-libevent\"" "$LINENO" 5
-@@ -6683,6 +6686,7 @@
+@@ -6716,6 +6719,7 @@
else
TOR_LIBEVENT_LIBS="-levent"
fi
@@ -41,7 +32,7 @@
if test "$enable_bufferevents" = "yes" ; then
if test "$ac_cv_header_event2_bufferevent_ssl_h" != "yes" ; then
-@@ -6761,12 +6765,14 @@
+@@ -6794,12 +6798,14 @@
$as_echo "#define USE_BUFFEREVENTS 1" >>confdefs.h