aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorru <ru@FreeBSD.org>2002-07-22 01:02:04 +0800
committerru <ru@FreeBSD.org>2002-07-22 01:02:04 +0800
commit77e1eaeece0775bdf00fb53166ed46a3785de966 (patch)
tree97eb0d7fdc25538a26c409ed68c0eebdffee7a71 /security
parent4c6d632238386ecd682d308d3778c339b8948e66 (diff)
downloadfreebsd-ports-gnome-77e1eaeece0775bdf00fb53166ed46a3785de966.tar.gz
freebsd-ports-gnome-77e1eaeece0775bdf00fb53166ed46a3785de966.tar.zst
freebsd-ports-gnome-77e1eaeece0775bdf00fb53166ed46a3785de966.zip
Catch up to the new bsd.lib.mk API (these libs are not internal).
Diffstat (limited to 'security')
-rw-r--r--security/pam-pgsql/files/Makefile.bsd6
-rw-r--r--security/pam_pwdfile/files/Makefile.bsd5
2 files changed, 2 insertions, 9 deletions
diff --git a/security/pam-pgsql/files/Makefile.bsd b/security/pam-pgsql/files/Makefile.bsd
index a82da4d750ba..3a6aef7d9c65 100644
--- a/security/pam-pgsql/files/Makefile.bsd
+++ b/security/pam-pgsql/files/Makefile.bsd
@@ -3,16 +3,12 @@
.PATH: ${FILESDIR}
SRCS= pam_pgsql.c pam_get_pass.c pam_std_option.c pam_get_service.c
-LIB= pam_pgsql
-SHLIB_NAME=${LIB}.so
+SHLIB_NAME= pam_pgsql.so
LDADD= -lpam -L${LOCALBASE}/lib -lpq -lmd
CFLAGS+= -Wall -D_GNU_SOURCE -I${LOCALBASE}/include \
-I${LOCALBASE}/include/pgsql
-INTERNALLIB= we don't need no stinking static lib
-NOPROFILE= we don't need no profiling either
-
# Uncomment if you think, the lib should NOT go into /usr/lib directly:
# LIBDIR= ${LOCALBASE}/lib
diff --git a/security/pam_pwdfile/files/Makefile.bsd b/security/pam_pwdfile/files/Makefile.bsd
index 833b69f5e1cf..0a6f5c818254 100644
--- a/security/pam_pwdfile/files/Makefile.bsd
+++ b/security/pam_pwdfile/files/Makefile.bsd
@@ -1,14 +1,11 @@
# inspired from pam-pgsql port :-)
SRCS= pam_pwdfile.c
-LIB= pam_pwdfile
-SHLIB_NAME=${LIB}.so
+SHLIB_NAME= pam_pwdfile.so
LDADD= -lpam -lcrypt
CFLAGS+= -Wall -D_BSD_SOURCE
-INTERNALLIB=
-
LIBDIR= ${LOCALBASE}/lib
.include <bsd.lib.mk>