aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2017-08-06 14:57:44 +0800
committeracm <acm@FreeBSD.org>2017-08-06 14:57:44 +0800
commite992da8eaae5a64e96caedf88df6687f568add1b (patch)
treefcfef589bce8875a806ddee11b227b9098e67907 /security
parent040b7bf0a6f5d52cc504d54d2fe42595e18ee058 (diff)
downloadfreebsd-ports-gnome-e992da8eaae5a64e96caedf88df6687f568add1b.tar.gz
freebsd-ports-gnome-e992da8eaae5a64e96caedf88df6687f568add1b.tar.zst
freebsd-ports-gnome-e992da8eaae5a64e96caedf88df6687f568add1b.zip
- New port: security/openvas9 (metaport)
This is the metaport to install OpenVAS 9 applications and libraries. WWW: http://www.openvas.org
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/openvas9/Makefile32
-rw-r--r--security/openvas9/files/pkg-message.in56
-rw-r--r--security/openvas9/pkg-descr3
4 files changed, 92 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8e2f00cde4bd..4a247ad4d224 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -440,6 +440,7 @@
SUBDIR += openvas8-libraries
SUBDIR += openvas8-manager
SUBDIR += openvas8-scanner
+ SUBDIR += openvas9
SUBDIR += openvas9-cli
SUBDIR += openvas9-libraries
SUBDIR += openvas9-manager
diff --git a/security/openvas9/Makefile b/security/openvas9/Makefile
new file mode 100644
index 000000000000..6cf5edf175fb
--- /dev/null
+++ b/security/openvas9/Makefile
@@ -0,0 +1,32 @@
+# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= openvas9
+PORTVERSION= 9.0
+CATEGORIES= security
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= openvas 8 vulnerability scanner (metaport)
+
+USES= metaport
+
+# Install OpenVAS libraries
+RUN_DEPENDS+= ${LOCALBASE}/lib/libopenvas_base.so:security/openvas${OPENVAS_VER}-libraries
+
+# Install OpenVAS Commnad Line
+RUN_DEPENDS+= ${LOCALBASE}/bin/omp:security/openvas${OPENVAS_VER}-cli
+
+# Install OpenVAS Manager
+RUN_DEPENDS+= ${LOCALBASE}/sbin/openvasmd:security/openvas${OPENVAS_VER}-manager
+
+# Install OpenVAS Scanner
+RUN_DEPENDS+= ${LOCALBASE}/sbin/openvassd:security/openvas${OPENVAS_VER}-scanner
+
+# Install OpenVAS Web Interface
+RUN_DEPENDS+= ${LOCALBASE}/sbin/gsad:security/greenbone-security-assistant${OPENVAS_VER}
+
+SUB_FILES= pkg-message
+OPENVAS_VER= 9
+
+
+.include <bsd.port.mk>
diff --git a/security/openvas9/files/pkg-message.in b/security/openvas9/files/pkg-message.in
new file mode 100644
index 000000000000..18cbdd76b8f0
--- /dev/null
+++ b/security/openvas9/files/pkg-message.in
@@ -0,0 +1,56 @@
+###############################################################################
+
+OpenVAS 9 ports were installed
+
+1) Redis is a dependency of OpenVAS. Please, configure redis-server for
+ listening on socket /tmp/redis.sock. openvassd needs it
+
+2) If you installed security/openvas8-manager port (openvasmd) with PostgrSQL
+ support, please look at:
+
+ %%LOCALBASE%%/share/docs/openvas-scanner/postgres-HOWTO
+
+ It will guide you for configure PostgreSQL as OpenVAS database backend
+ instead of SQLite3
+
+3) The following steps are neccessary before of you can access to OpenVAS web
+ interface (gsad):
+
+ # openvas-mkcert
+ # openvas-mkcert-client -n -i
+ # openvasmd --rebuild --progress
+ # greenbone-nvt-sync
+ # greenbone-scapdata-sync
+ # greenbone-certdata-sync
+ # openvasmd --create-user=admin --role=Admin
+ # openvasmd --user=admin --new-password=yourpassword
+
+4) Add the following lines to /etc/rc.conf
+
+ openvassd_enable="YES"
+ openvasmd_enable="YES"
+ gsad_enable="YES"
+
+5) Start OpenVAS Scanner. It will listen on 127.0.0.1:9391 by default
+
+ # service openvassd restart
+
+6) 5) Start OpenVAS Manager. It will listen on 127.0.0.1:9390 by default
+
+ # service openvasmd restart
+ # openvasmd --rebuild --progress
+
+7) Start OpenVAS web interface. It will listen on http://127.0.0.1:8080 by
+ default
+
+ # service gsad start
+
+8) gsad can export results to PDF. It needs print/texlive-texmf port
+
+ # pkg install texlive-texmf
+
+ It will install 1G of data
+
+9) Enjoy it
+
+###############################################################################
diff --git a/security/openvas9/pkg-descr b/security/openvas9/pkg-descr
new file mode 100644
index 000000000000..2ff075008951
--- /dev/null
+++ b/security/openvas9/pkg-descr
@@ -0,0 +1,3 @@
+This is the metaport to install OpenVAS 9 applications and libraries.
+
+WWW: http://www.openvas.org