aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-05-16 03:15:56 +0800
committerpgj <pgj@FreeBSD.org>2010-05-16 03:15:56 +0800
commit039087f59f6cad5995600b37bf613ea4d8875477 (patch)
treea0b25f7d9c9fd40c4bc5939e3aac32a53850e062 /security
parent9e20eba514d67b24a65aa36e7f98799679cc53a4 (diff)
downloadfreebsd-ports-gnome-039087f59f6cad5995600b37bf613ea4d8875477.tar.gz
freebsd-ports-gnome-039087f59f6cad5995600b37bf613ea4d8875477.tar.zst
freebsd-ports-gnome-039087f59f6cad5995600b37bf613ea4d8875477.zip
- Update to 1.4.1.1
- Import OPTIONS
Diffstat (limited to 'security')
-rw-r--r--security/hs-SHA/Makefile28
-rw-r--r--security/hs-SHA/distinfo6
-rw-r--r--security/hs-SHA/pkg-plist3
3 files changed, 32 insertions, 5 deletions
diff --git a/security/hs-SHA/Makefile b/security/hs-SHA/Makefile
index 235c95484dd0..6ee57fb40da4 100644
--- a/security/hs-SHA/Makefile
+++ b/security/hs-SHA/Makefile
@@ -6,14 +6,38 @@
#
PORTNAME= SHA
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.1.1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
-COMMENT= Haskell Implementations of the SHA suite of message digest functions
+COMMENT= Haskell implementations of the SHA suite of message digest functions
CABAL_SETUP= Setup.hs
+
USE_HACKAGE= binary
+OPTIONS= TEST "Build the SHA test suite" off \
+ EXE "Build a SHA2-384 executable similar to 'md5sum'" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_TEST)
+CONFIGURE_ARGS+= --flags="Test"
+EXECUTABLE+= test_sha
+PLIST_SUB+= MAYBE_TEST=""
+.else
+CONFIGURE_ARGS+= --flags="-Test"
+PLIST_SUB+= MAYBE_TEST="@comment "
+.endif
+
+.if defined(WITH_EXE)
+CONFIGURE_ARGS+= --flags="exe"
+EXECUTABLE+= sha1 sha384
+PLIST_SUB+= MAYBE_EXE=""
+.else
+CONFIGURE_ARGS+= --flags="-exe"
+PLIST_SUB+= MAYBE_EXE="@comment "
+.endif
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/hs-SHA/distinfo b/security/hs-SHA/distinfo
index e521b0c8b7fe..fb70cd2bc6f3 100644
--- a/security/hs-SHA/distinfo
+++ b/security/hs-SHA/distinfo
@@ -1,3 +1,3 @@
-MD5 (SHA-1.4.0.tar.gz) = b89d52db97559b90246a534b1e66af20
-SHA256 (SHA-1.4.0.tar.gz) = 7f08042fddadd8e3795d627a042d1884b33e066ab67d03b6de92551a4ad9fc7d
-SIZE (SHA-1.4.0.tar.gz) = 2711278
+MD5 (SHA-1.4.1.1.tar.gz) = 51ac8cc9248a2eb162bf25a4db1f77ad
+SHA256 (SHA-1.4.1.1.tar.gz) = 8ecdc91679d1aa1d4050e1124cf5af79ae2ece66aee3b907e1078d71bf03169a
+SIZE (SHA-1.4.1.1.tar.gz) = 2713700
diff --git a/security/hs-SHA/pkg-plist b/security/hs-SHA/pkg-plist
index e81c02b03a72..ecba426b1c62 100644
--- a/security/hs-SHA/pkg-plist
+++ b/security/hs-SHA/pkg-plist
@@ -1,4 +1,7 @@
@comment $FreeBSD$
+%%MAYBE_EXE%%bin/sha1
+%%MAYBE_EXE%%bin/sha384
+%%MAYBE_TEST%%bin/test_sha
%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Digest/Pure/SHA.hi
%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a