aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2018-03-10 02:40:05 +0800
committercpm <cpm@FreeBSD.org>2018-03-10 02:40:05 +0800
commit0454e76a6e1b50d62d65fc1cf4068061a7cc4039 (patch)
tree96d4f99910d5e0b3a5e7c51da19411dcfefbf9c6 /security
parent07dd70dfd0e117068af58bf3a60c125144ca34fb (diff)
downloadfreebsd-ports-gnome-0454e76a6e1b50d62d65fc1cf4068061a7cc4039.tar.gz
freebsd-ports-gnome-0454e76a6e1b50d62d65fc1cf4068061a7cc4039.tar.zst
freebsd-ports-gnome-0454e76a6e1b50d62d65fc1cf4068061a7cc4039.zip
- Add udev rules for more devices
- Bump PORTREVISION Approved by: Greg V <greg@unrelenting.technology> (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/u2f-devd/Makefile1
-rw-r--r--security/u2f-devd/files/u2f.conf32
2 files changed, 33 insertions, 0 deletions
diff --git a/security/u2f-devd/Makefile b/security/u2f-devd/Makefile
index f4b138f68cf3..1218a815b36d 100644
--- a/security/u2f-devd/Makefile
+++ b/security/u2f-devd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= u2f-devd
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= #
DISTFILES= #
diff --git a/security/u2f-devd/files/u2f.conf b/security/u2f-devd/files/u2f.conf
index 05a4c8bbba22..283e09cd54b4 100644
--- a/security/u2f-devd/files/u2f.conf
+++ b/security/u2f-devd/files/u2f.conf
@@ -161,3 +161,35 @@ attach 100 {
match "product" "0xf025";
action "chgrp u2f /dev/$device-name; chmod g+rw /dev/$device-name";
};
+
+# Nitrokey FIDO U2F
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x20a0";
+ match "product" "0x4287";
+ action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
+};
+
+attach 100 {
+ match "vendor" "0x20a0";
+ match "product" "0x4287";
+ action "chgrp u2f /dev/$device-name; chmod g+rw /dev/$device-name";
+};
+
+# Google Titan U2F
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x18d1";
+ match "product" "0x5026";
+ action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
+};
+
+attach 100 {
+ match "vendor" "0x18d1";
+ match "product" "0x5026";
+ action "chgrp u2f /dev/$device-name; chmod g+rw /dev/device-name";
+};