aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-01-06 20:52:30 +0800
committermandree <mandree@FreeBSD.org>2013-01-06 20:52:30 +0800
commit05542554ae872b59c429455c6a663c186c026c17 (patch)
tree9a36e05e7f7cfbd009b21f8e7bdbca7b78f56aaf /security
parentdb9444f1f6320648faea6485c5df140dc4291fa7 (diff)
downloadfreebsd-ports-gnome-05542554ae872b59c429455c6a663c186c026c17.tar.gz
freebsd-ports-gnome-05542554ae872b59c429455c6a663c186c026c17.tar.zst
freebsd-ports-gnome-05542554ae872b59c429455c6a663c186c026c17.zip
- Convert to Options NG. Renames GTK option to GTK2 for consistency.
- Strip Makefile header. - Make sure that the port build heeds ${CC}, passing it through MAKE_ARGS. - Replace CC-is-clang specific -Wno-empty-body by unconditional -Wno-error. - Remove LIB_DEPENDS ABI versions.
Diffstat (limited to 'security')
-rw-r--r--security/putty/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/security/putty/Makefile b/security/putty/Makefile
index cd4d6c934bf6..91b947cd216e 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -2,7 +2,7 @@
PORTNAME= putty
PORTVERSION= 0.62
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= http://the.earth.li/~sgtatham/putty/%SUBDIR%/ \
ftp://ftp.chiark.greenend.org.uk/users/sgtatham/putty-latest/
@@ -20,8 +20,8 @@ MAKEFILE= Makefile.gtk
PLIST_FILES= bin/plink bin/pscp bin/psftp bin/puttygen
MAN1= plink.1 pscp.1 psftp.1 puttygen.1
-OPTIONS= GSSAPI "Enable GSSAPI support" on \
- GTK "Enable GTK+ 2 GUI (recommended)" on
+OPTIONS_DEFINE= GSSAPI GTK2
+OPTIONS_DEFAULT=GSSAPI GTK2
CONFLICTS= pssh-[0-9]*
@@ -29,7 +29,7 @@ CONFLICTS= pssh-[0-9]*
CFLAGS+= -DBSD_PTYS -DOMIT_UTMP -DIPV6
-.if !defined(WITHOUT_GTK) && !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MGTK2} && !defined(WITHOUT_X11)
USE_GNOME= gtk20
PLIST_FILES+= bin/pterm bin/putty bin/puttytel
MAN1+= pterm.1 putty.1 puttytel.1
@@ -40,10 +40,10 @@ MAKE_ARGS+= GTK_CONFIG=:
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_GSSAPI)
+.if ${PORT_OPTIONS:MGSSAPI}
_COMPAT= -DSTATIC_GSSAPI
.if ${OSVERSION} >= 900000
-LIB_DEPENDS+= krb5support.0:${PORTSDIR}/security/krb5
+LIB_DEPENDS+= krb5support:${PORTSDIR}/security/krb5
.endif
.else
_COMPAT= -DNO_GSSAPI
@@ -55,18 +55,19 @@ _COMPAT+= -DOMIT_UTMP
XFLAGS= -DDEBUG
.endif
-.if ${CC:T} == clang
-XFLAGS+= -Wno-empty-body
-.endif
+# upstream sets -Werror - there are no issues on 9.1-FreeBSD amd64
+# currently, but override it nonetheless.
+XFLAGS+= -Wno-error
MAKE_ARGS+= COMPAT="${_COMPAT}" \
+ CC="${CC}" \
XFLAGS="${XFLAGS}" \
INSTALL_DATA="${INSTALL_DATA}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}"
post-patch:
@${REINPLACE_CMD} -e 's,prefix=/usr/local,prefix=${PREFIX},;\
- s,make,${GMAKE},' \
+ s,make,${GMAKE},'\
${WRKSRC}/${MAKEFILE}
.include <bsd.port.post.mk>