aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2014-03-01 08:06:29 +0800
committerrene <rene@FreeBSD.org>2014-03-01 08:06:29 +0800
commit076592a92b4a7e010e8a6b2644ae232408c10c3b (patch)
treea82aa9cd34a90c5daecd9ec479f5a85b36141796 /security
parent0282d1525716be347b881ec0b2f6e2f10e232220 (diff)
downloadfreebsd-ports-gnome-076592a92b4a7e010e8a6b2644ae232408c10c3b.tar.gz
freebsd-ports-gnome-076592a92b4a7e010e8a6b2644ae232408c10c3b.tar.zst
freebsd-ports-gnome-076592a92b4a7e010e8a6b2644ae232408c10c3b.zip
PHP 5.2 has reached it end-of-life in the FreeBSD Ports Tree, time
to say goodbye. Upstream unsupported it since 2011-01-06 (see http://php.net/eol.php ) Strip PHP 5.2 out of Mk/bsd.php.mk
Diffstat (limited to 'security')
-rw-r--r--security/Makefile5
-rw-r--r--security/php52-filter/Makefile11
-rw-r--r--security/php52-filter/files/patch-config.m425
-rw-r--r--security/php52-hash/Makefile11
-rw-r--r--security/php52-mcrypt/Makefile11
-rw-r--r--security/php52-mhash/Makefile11
-rw-r--r--security/php52-openssl/Makefile11
7 files changed, 0 insertions, 85 deletions
diff --git a/security/Makefile b/security/Makefile
index 669a89e03dd9..1d1c1c09e6bb 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -691,11 +691,6 @@
SUBDIR += php5-hash
SUBDIR += php5-mcrypt
SUBDIR += php5-openssl
- SUBDIR += php52-filter
- SUBDIR += php52-hash
- SUBDIR += php52-mcrypt
- SUBDIR += php52-mhash
- SUBDIR += php52-openssl
SUBDIR += php53-filter
SUBDIR += php53-hash
SUBDIR += php53-mcrypt
diff --git a/security/php52-filter/Makefile b/security/php52-filter/Makefile
deleted file mode 100644
index 3ccd05532aa0..000000000000
--- a/security/php52-filter/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-# Created by: Alex Keda <admin@lissyara.su>
-# $FreeBSD$
-
-CATEGORIES= security
-
-MASTERDIR= ${.CURDIR}/../../lang/php52
-
-PKGNAMESUFFIX= -filter
-
-NO_STAGE= yes
-.include "${MASTERDIR}/Makefile"
diff --git a/security/php52-filter/files/patch-config.m4 b/security/php52-filter/files/patch-config.m4
deleted file mode 100644
index 7037298bc08f..000000000000
--- a/security/php52-filter/files/patch-config.m4
+++ /dev/null
@@ -1,25 +0,0 @@
---- ext/filter/config.m4.orig 2009-03-06 08:25:45.000000000 +0100
-+++ ext/filter/config.m4 2009-03-06 08:28:10.000000000 +0100
-@@ -19,7 +19,7 @@
- CPPFLAGS=$INCLUDES
- AC_EGREP_CPP(yes,[
- #include <main/php_config.h>
--#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
-+#if defined(HAVE_BUNDLED_PCRE)
- yes
- #endif
- ],[
-@@ -27,11 +27,12 @@
- ],[
- AC_EGREP_CPP(yes,[
- #include <main/php_config.h>
--#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
-+#if defined(HAVE_PCRE)
- yes
- #endif
- ],[
- PHP_PCRE_REGEX=pecl
-+ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
- ],[
- PHP_PCRE_REGEX=no
- ])
diff --git a/security/php52-hash/Makefile b/security/php52-hash/Makefile
deleted file mode 100644
index 186603e6418e..000000000000
--- a/security/php52-hash/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-# Created by: Alex Keda <admin@lissyara.su>
-# $FreeBSD$
-
-CATEGORIES= security
-
-MASTERDIR= ${.CURDIR}/../../lang/php52
-
-PKGNAMESUFFIX= -hash
-
-NO_STAGE= yes
-.include "${MASTERDIR}/Makefile"
diff --git a/security/php52-mcrypt/Makefile b/security/php52-mcrypt/Makefile
deleted file mode 100644
index a97732770b38..000000000000
--- a/security/php52-mcrypt/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-# Created by: Alex Keda <admin@lissyara.su>
-# $FreeBSD$
-
-CATEGORIES= security
-
-MASTERDIR= ${.CURDIR}/../../lang/php52
-
-PKGNAMESUFFIX= -mcrypt
-
-NO_STAGE= yes
-.include "${MASTERDIR}/Makefile"
diff --git a/security/php52-mhash/Makefile b/security/php52-mhash/Makefile
deleted file mode 100644
index 732d3838a20c..000000000000
--- a/security/php52-mhash/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-# Created by: Alex Keda <admin@lissyara.su>
-# $FreeBSD$
-
-CATEGORIES= security
-
-MASTERDIR= ${.CURDIR}/../../lang/php52
-
-PKGNAMESUFFIX= -mhash
-
-NO_STAGE= yes
-.include "${MASTERDIR}/Makefile"
diff --git a/security/php52-openssl/Makefile b/security/php52-openssl/Makefile
deleted file mode 100644
index 56135bae820b..000000000000
--- a/security/php52-openssl/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-# Created by: Alex Keda <admin@lissyara.su>
-# $FreeBSD$
-
-CATEGORIES= security
-
-MASTERDIR= ${.CURDIR}/../../lang/php52
-
-PKGNAMESUFFIX= -openssl
-
-NO_STAGE= yes
-.include "${MASTERDIR}/Makefile"