aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-05-16 16:26:41 +0800
committervs <vs@FreeBSD.org>2004-05-16 16:26:41 +0800
commit13bfbd5b390b9c7689cb27fb237fd7813bf2c02f (patch)
treeb72a4a84eb254d457ca54740402768ed27150bd7 /security
parentc6160dbfa7bf7ee2887e4317764c6a8c7ec6cfbb (diff)
downloadfreebsd-ports-gnome-13bfbd5b390b9c7689cb27fb237fd7813bf2c02f.tar.gz
freebsd-ports-gnome-13bfbd5b390b9c7689cb27fb237fd7813bf2c02f.tar.zst
freebsd-ports-gnome-13bfbd5b390b9c7689cb27fb237fd7813bf2c02f.zip
Unbreak with perl5 from base on 4.x.
Noticed by: pointyhat Perl-helpdesk: mat
Diffstat (limited to 'security')
-rw-r--r--security/p5-Crypt-Anubis/Makefile5
-rw-r--r--security/p5-Crypt-Anubis/files/patch-anubis.c11
2 files changed, 14 insertions, 2 deletions
diff --git a/security/p5-Crypt-Anubis/Makefile b/security/p5-Crypt-Anubis/Makefile
index 8465f5d6bf50..25df7b52a108 100644
--- a/security/p5-Crypt-Anubis/Makefile
+++ b/security/p5-Crypt-Anubis/Makefile
@@ -21,8 +21,9 @@ MAN3= Crypt::Anubis.3
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile"
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw{$$1};$$1/g' ${WRKSRC}/Anubis.pm
.endif
.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Anubis/files/patch-anubis.c b/security/p5-Crypt-Anubis/files/patch-anubis.c
new file mode 100644
index 000000000000..fe281f2af154
--- /dev/null
+++ b/security/p5-Crypt-Anubis/files/patch-anubis.c
@@ -0,0 +1,11 @@
+--- _anubis.c.orig Sun May 16 10:04:36 2004
++++ _anubis.c Sun May 16 10:05:13 2004
+@@ -976,7 +976,7 @@
+ void print_data(char *str, u8 *val, int len);
+ int compare_blocks(u8 *m1, u8 *m2, int len_bits); /* 0=equal, 1=not eq. */
+
+-int main(void)
++int main _((int argc, char** argv, char** env))
+ {
+ struct NESSIEstruct subkeys;
+ u8 key[KEYSIZEB];