aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-10-07 07:08:26 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-10-07 07:08:26 +0800
commit1a02b17a6ee805bbcb4431090dcd2d50d97912cb (patch)
treee5199eb70f17533b13aaf715bf50bf1b2002160a /security
parenta22911cd84f58e54fe6c9ef666a02ac183d40b28 (diff)
downloadfreebsd-ports-gnome-1a02b17a6ee805bbcb4431090dcd2d50d97912cb.tar.gz
freebsd-ports-gnome-1a02b17a6ee805bbcb4431090dcd2d50d97912cb.tar.zst
freebsd-ports-gnome-1a02b17a6ee805bbcb4431090dcd2d50d97912cb.zip
- Add py-oauth2client 1.3
oauth2client is a Python module for client-side oauth2 authentication. It works with Google's oauth2 service by default, and is compatible with any oauth2 service. WWW: https://pypi.python.org/pypi/oauth2client WWW: http://google.github.io/oauth2client/
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-oauth2client/Makefile20
-rw-r--r--security/py-oauth2client/distinfo2
-rw-r--r--security/py-oauth2client/pkg-descr6
4 files changed, 29 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ca0bd8bae358..c45081f4bb89 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -774,6 +774,7 @@
SUBDIR += py-m2crypto
SUBDIR += py-mcrypt
SUBDIR += py-mhash
+ SUBDIR += py-oauth2client
SUBDIR += py-oauthlib
SUBDIR += py-openid
SUBDIR += py-openssl
diff --git a/security/py-oauth2client/Makefile b/security/py-oauth2client/Makefile
new file mode 100644
index 000000000000..cbc09bbc47fb
--- /dev/null
+++ b/security/py-oauth2client/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= oauth2client
+PORTVERSION= 1.3
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= OAuth 2.0 client library
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httplib2>=0.8:${PORTSDIR}/www/py-httplib2
+
+USE_PYTHON= autoplist distutils
+USES= python:2
+
+.include <bsd.port.mk>
diff --git a/security/py-oauth2client/distinfo b/security/py-oauth2client/distinfo
new file mode 100644
index 000000000000..615334457106
--- /dev/null
+++ b/security/py-oauth2client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (oauth2client-1.3.tar.gz) = 668ffe5a9a6df1f5fca50a851da9ce97286dc10f190b05e84763a8cd9716141b
+SIZE (oauth2client-1.3.tar.gz) = 43852
diff --git a/security/py-oauth2client/pkg-descr b/security/py-oauth2client/pkg-descr
new file mode 100644
index 000000000000..421f01fb1ece
--- /dev/null
+++ b/security/py-oauth2client/pkg-descr
@@ -0,0 +1,6 @@
+oauth2client is a Python module for client-side oauth2 authentication. It works
+with Google's oauth2 service by default, and is compatible with any oauth2
+service.
+
+WWW: https://pypi.python.org/pypi/oauth2client
+WWW: http://google.github.io/oauth2client/