aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-25 20:18:13 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-25 20:18:13 +0800
commit1aaebc5276f007768a93aa7da2edf583378e1bd7 (patch)
treed043efc3a278c8083600e4f8c9aa711cf8a3170e /security
parent372f6324819f9d4fc00c53355d3a631d66fda13a (diff)
downloadfreebsd-ports-gnome-1aaebc5276f007768a93aa7da2edf583378e1bd7.tar.gz
freebsd-ports-gnome-1aaebc5276f007768a93aa7da2edf583378e1bd7.tar.zst
freebsd-ports-gnome-1aaebc5276f007768a93aa7da2edf583378e1bd7.zip
Support staging
Diffstat (limited to 'security')
-rw-r--r--security/ratproxy/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/security/ratproxy/Makefile b/security/ratproxy/Makefile
index f65d2e5ccd07..ae1a4ee634da 100644
--- a/security/ratproxy/Makefile
+++ b/security/ratproxy/Makefile
@@ -4,22 +4,25 @@
PORTNAME= ratproxy
PORTVERSION= 1.58
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Semi-automated, largely passive web application security audit tool
+USES= shebangfix
USE_OPENSSL= YES
+
WRKSRC= ${WRKDIR}/${PORTNAME}
+
+SHEBANG_FILES= ratproxy-report.sh
PLIST_FILES= bin/ratproxy \
bin/ratproxy-report.sh
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's#-Wno-pointer-sign##g' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ratproxy ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/ratproxy-report.sh ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ratproxy ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/ratproxy-report.sh ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>