aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2014-10-09 21:18:28 +0800
committerume <ume@FreeBSD.org>2014-10-09 21:18:28 +0800
commit1c6885604921c552975a6b9f8787bfba32f045ad (patch)
tree1e2605c5b5b0592c6077f5979d5d778002803883 /security
parentc674040f8b3d18e5fdf2152db25058cc699edf4a (diff)
downloadfreebsd-ports-gnome-1c6885604921c552975a6b9f8787bfba32f045ad.tar.gz
freebsd-ports-gnome-1c6885604921c552975a6b9f8787bfba32f045ad.tar.zst
freebsd-ports-gnome-1c6885604921c552975a6b9f8787bfba32f045ad.zip
Include RPATH in the libs, again.
It seems that USES=libtool doesn't rewrite ${LIBTOOL} in a configure script to use ${LOCALBASE}/bin/libtool like bsd.autotools.mk did. So, rewrite it explicitly for workaround. PR: 194176 Submitted by: jhujhiti__at__adjectivism.org
Diffstat (limited to 'security')
-rw-r--r--security/cyrus-sasl2-gssapi/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/security/cyrus-sasl2-gssapi/Makefile b/security/cyrus-sasl2-gssapi/Makefile
index 8ffacb90a0de..2b6f9b7f8d1a 100644
--- a/security/cyrus-sasl2-gssapi/Makefile
+++ b/security/cyrus-sasl2-gssapi/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gssapi
PORTVERSION= 2.1.26
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-sasl/ \
http://cyrusimap.org/releases/
@@ -89,6 +89,13 @@ CONFIGURE_ARGS+=--with-openssl=yes
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
.endif
+LIBTOOL= ${LOCALBASE}/bin/libtool
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e "/^LIBTOOL=/s|\$$(top_builddir)/libtool|${LIBTOOL}|g" \
+ ${WRKSRC}/configure
+
do-build:
cd ${WRKSRC}/include && ${MAKE}
cd ${WRKSRC}/plugins && ${MAKE}