aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-06-12 04:58:12 +0800
committerpi <pi@FreeBSD.org>2014-06-12 04:58:12 +0800
commit27429bf9daec3d878a60c9e5031f9bacee212691 (patch)
treefe25fdeca138baa8d80c825bb14bb7f0a8ced2d1 /security
parentfa6f8f47018199acc7c9cd8696d751e701f38789 (diff)
downloadfreebsd-ports-gnome-27429bf9daec3d878a60c9e5031f9bacee212691.tar.gz
freebsd-ports-gnome-27429bf9daec3d878a60c9e5031f9bacee212691.tar.zst
freebsd-ports-gnome-27429bf9daec3d878a60c9e5031f9bacee212691.zip
security/p5-PGP: fix run dependency on security/pgpin
- fix path to pgpin binary PR: ports/190841 Approved by: Muhammad Moinur Rahman <5u623l20@gmail.com> (maintainer) Approved by: mentors (implicit)
Diffstat (limited to 'security')
-rw-r--r--security/p5-PGP/Makefile3
-rw-r--r--security/p5-PGP/files/patch-Pipe.pm20
2 files changed, 22 insertions, 1 deletions
diff --git a/security/p5-PGP/Makefile b/security/p5-PGP/Makefile
index c086933ea6e0..215611a0f9dc 100644
--- a/security/p5-PGP/Makefile
+++ b/security/p5-PGP/Makefile
@@ -3,6 +3,7 @@
PORTNAME= PGP
PORTVERSION= 0.3a
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -10,7 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= 5u623l20@gmail.com
COMMENT= Perl5 module to work with PGP messages
-BUILD_DEPENDS= pgp:${PORTSDIR}/security/pgpin
+RUN_DEPENDS= pgpin:${PORTSDIR}/security/pgpin
PORTSCOUT= skipv:1.0
diff --git a/security/p5-PGP/files/patch-Pipe.pm b/security/p5-PGP/files/patch-Pipe.pm
new file mode 100644
index 000000000000..cec32f04d682
--- /dev/null
+++ b/security/p5-PGP/files/patch-Pipe.pm
@@ -0,0 +1,20 @@
+--- PGP/Pipe.pm.orig 2014-06-10 19:55:03.000000000 +0200
++++ PGP/Pipe.pm 2014-06-10 19:55:17.000000000 +0200
+@@ -55,7 +55,7 @@
+ $pgp = new PGP [$pgppath], [$pgpexec];
+
+ Create the PGP encapsulation object. The standard location for the
+-PGP executable is /usr/local/bin/pgp.
++PGP executable is /usr/local/bin/pgpin.
+
+ =cut
+
+@@ -63,7 +63,7 @@
+ {
+ my $class = shift;
+ my $pgppath = shift || "$ENV{HOME}/.pgp";
+- my $pgpexec = shift || "/usr/local/bin/pgp";
++ my $pgpexec = shift || "/usr/local/bin/pgpin";
+
+ if (! -e "$pgppath/config.txt" &&
+ ! -e "/usr/local/lib/pgp/config.txt" )