aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-06-06 05:22:25 +0800
committermiwi <miwi@FreeBSD.org>2010-06-06 05:22:25 +0800
commit2c54a75a4179e594bad25bfab404512637fcfedc (patch)
tree64096592d5e2ac27d86fa3bbd90e0bc744ff54d1 /security
parent46ae6769e92ecad5b090dc64ba3af69ac43cd6db (diff)
downloadfreebsd-ports-gnome-2c54a75a4179e594bad25bfab404512637fcfedc.tar.gz
freebsd-ports-gnome-2c54a75a4179e594bad25bfab404512637fcfedc.tar.zst
freebsd-ports-gnome-2c54a75a4179e594bad25bfab404512637fcfedc.zip
The update utility is designed to download and save updates and modules
of the Kaspersky Lab's applications into a separate folder. With the help of the utility you can download updates for selected Kaspersky Lab's applications installed either in your network or at a home PC. The utility has a function for saving downloaded updates and autopatches in a local folder, a network folder connected as a disc to the computer file system, or onto a flash-carrier. WWW: http://support.kaspersky.com/updater?level=2 PR: ports/147116 Submitted by: Gvozdikov Veniamin <g.veniamin at googlemail.com>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/retranslator/Makefile49
-rw-r--r--security/retranslator/distinfo3
-rw-r--r--security/retranslator/pkg-descr10
-rw-r--r--security/retranslator/pkg-plist4
5 files changed, 67 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 18849ae074cb..410ae4831036 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -731,6 +731,7 @@
SUBDIR += rats
SUBDIR += rc5pipe
SUBDIR += rdigest
+ SUBDIR += retranslator
SUBDIR += revelation
SUBDIR += rid
SUBDIR += rkhunter
diff --git a/security/retranslator/Makefile b/security/retranslator/Makefile
new file mode 100644
index 000000000000..e08e71530b6e
--- /dev/null
+++ b/security/retranslator/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: retranslator
+# Date created: 2010-05-25
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= retranslator
+PORTVERSION= 5.0.0
+CATEGORIES= security
+MASTER_SITES= http://utils.kaspersky.com/updater/retranslator_5.0.0.7/FreeBSD_6.3/ \
+ http://fbsd.zlonet.ru/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-7
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= The update utility for Kaspersky applications
+
+NO_BUILD= yes
+ONLY_FOR_ARCHS= i386 amd64
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 630000
+LIB_DEPENDS+= m.4:${PORTSDIR}/misc/compat6x
+.endif
+
+do-configure:
+
+.for f in 's,./backup/,/var/db/${PORTNAME}/backup,g' \
+ 's,./bases/,/var/db/${PORTNAME}/bases,g' \
+ 's,./${PORTNAME}.log,/var/log/${PORTNAME}.log,g'
+ @${REINPLACE_CMD} -e ${f} \
+ ${WRKSRC}/${PORTNAME}.conf
+.endfor
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.bin \
+ ${PREFIX}/bin/${PORTNAME}
+
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf \
+ ${PREFIX}/etc/${PORTNAME}.conf.sample
+ @if [ ! -f ${PREFIX}/etc/${PORTNAME}.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/${PORTNAME}.conf.sample ${PREFIX}/etc/${PORTNAME}.conf ; \
+ fi
+
+.include <bsd.port.post.mk>
diff --git a/security/retranslator/distinfo b/security/retranslator/distinfo
new file mode 100644
index 000000000000..0f83ed0920e5
--- /dev/null
+++ b/security/retranslator/distinfo
@@ -0,0 +1,3 @@
+MD5 (retranslator-5.0.0-7.tar.gz) = 263c4afecba530cce614fb7474b44dc2
+SHA256 (retranslator-5.0.0-7.tar.gz) = ad32b535ddf0c13f95cdbba2de0d2d6b157cb6ff62b5a61766a0a93c77f33f97
+SIZE (retranslator-5.0.0-7.tar.gz) = 671996
diff --git a/security/retranslator/pkg-descr b/security/retranslator/pkg-descr
new file mode 100644
index 000000000000..3eada1855d2a
--- /dev/null
+++ b/security/retranslator/pkg-descr
@@ -0,0 +1,10 @@
+The update utility is designed to download and save updates and modules
+of the Kaspersky Lab's applications into a separate folder.
+
+With the help of the utility you can download updates for selected
+Kaspersky Lab's applications installed either in your network or at
+a home PC. The utility has a function for saving downloaded updates
+and autopatches in a local folder, a network folder connected as a
+disc to the computer file system, or onto a flash-carrier.
+
+WWW: http://support.kaspersky.com/updater?level=2
diff --git a/security/retranslator/pkg-plist b/security/retranslator/pkg-plist
new file mode 100644
index 000000000000..d4207e4cd88d
--- /dev/null
+++ b/security/retranslator/pkg-plist
@@ -0,0 +1,4 @@
+bin/retranslator
+@unexec if cmp -s %D/etc/retranslator.conf.sample %D/etc/retranslator.conf; then rm -f %D/etc/retranslator.conf; fi
+etc/retranslator.conf.sample
+@exec if [ ! -f %D/etc/retranslator.conf ] ; then cp -p %D/%F %B/retranslator.conf; fi