aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-07-24 19:36:22 +0800
committerknu <knu@FreeBSD.org>2002-07-24 19:36:22 +0800
commit37e858fdf91399d2c8d152e724c0b3c1778dfdae (patch)
treedbef27e50c667dbb7c8167a4d3bd4fc5b42b3949 /security
parent8e6a1b8ee723e31571ac79ee5e7ad7d032f96fa6 (diff)
downloadfreebsd-ports-gnome-37e858fdf91399d2c8d152e724c0b3c1778dfdae.tar.gz
freebsd-ports-gnome-37e858fdf91399d2c8d152e724c0b3c1778dfdae.tar.zst
freebsd-ports-gnome-37e858fdf91399d2c8d152e724c0b3c1778dfdae.zip
Update to 0.1.2.
Diffstat (limited to 'security')
-rw-r--r--security/ruby-openssl/Makefile7
-rw-r--r--security/ruby-openssl/distinfo2
-rw-r--r--security/ruby-openssl/files/patch-ossl.c20
3 files changed, 22 insertions, 7 deletions
diff --git a/security/ruby-openssl/Makefile b/security/ruby-openssl/Makefile
index 8da949144ac1..91af3d1a622b 100644
--- a/security/ruby-openssl/Makefile
+++ b/security/ruby-openssl/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= openssl
-PORTVERSION= 0.1.1
+PORTVERSION= 0.1.2
CATEGORIES= security ruby
MASTER_SITES= http://freesoftware.fsf.org/download/rubypki/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ossl-${PORTVERSION}
-EXTRACT_SUFX= .tgz
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
@@ -26,10 +25,6 @@ INSTALL_TARGET= site-install
DOCS= ChangeLog README
-post-extract:
- ${FIND} ${WRKSRC} -type d -name CVS | xargs ${RM} -rf
- ${FIND} ${WRKSRC} -type f -name '*~' -delete
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
diff --git a/security/ruby-openssl/distinfo b/security/ruby-openssl/distinfo
index a41656bd09ba..6951c880c9d2 100644
--- a/security/ruby-openssl/distinfo
+++ b/security/ruby-openssl/distinfo
@@ -1 +1 @@
-MD5 (ruby/ossl-0.1.1.tgz) = 0c08e586134c8e26e945d8bb73f6e871
+MD5 (ruby/ossl-0.1.2.tar.gz) = 923a0ccd7a274e6d5bcbc9dcf543e99e
diff --git a/security/ruby-openssl/files/patch-ossl.c b/security/ruby-openssl/files/patch-ossl.c
new file mode 100644
index 000000000000..09867c896fb9
--- /dev/null
+++ b/security/ruby-openssl/files/patch-ossl.c
@@ -0,0 +1,20 @@
+--- ossl.c.orig Tue Jul 23 23:24:54 2002
++++ ossl.c Wed Jul 24 20:30:59 2002
+@@ -26,6 +26,17 @@
+ # include <time.h>
+ #endif
+
++#ifdef HAVE_SYS_TIME_H
++# include <sys/time.h>
++#else
++#ifndef NT
++struct timeval {
++ long tv_sec; /* seconds */
++ long tv_usec; /* and microseconds */
++};
++#endif /* NT */
++#endif
++
+ /*
+ * Check Types
+ */