aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-07-08 17:00:18 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-07-08 17:00:18 +0800
commit3829121da06b8684962202bbf70c97a247d67019 (patch)
tree3c83c9a7eb885e1f8b772f7542bf21ce6806dc36 /security
parentbb40eae60824252b4e69b6742edfba07af0226e5 (diff)
downloadfreebsd-ports-gnome-3829121da06b8684962202bbf70c97a247d67019.tar.gz
freebsd-ports-gnome-3829121da06b8684962202bbf70c97a247d67019.tar.zst
freebsd-ports-gnome-3829121da06b8684962202bbf70c97a247d67019.zip
- Add LICENSE
- Add NO_ARCH - Switch to COPYTREE - Update WWW - Sort plist
Diffstat (limited to 'security')
-rw-r--r--security/dirbuster/Makefile17
-rw-r--r--security/dirbuster/pkg-descr2
-rw-r--r--security/dirbuster/pkg-plist22
3 files changed, 21 insertions, 20 deletions
diff --git a/security/dirbuster/Makefile b/security/dirbuster/Makefile
index e08229060229..1015598a5f66 100644
--- a/security/dirbuster/Makefile
+++ b/security/dirbuster/Makefile
@@ -10,18 +10,20 @@ DISTNAME= DirBuster-1.0-RC1
MAINTAINER= ports@FreeBSD.org
COMMENT= DirBuster allows file and directory brute forcing on web servers
+LICENSE= LGPL21+ CC-BY-SA-3.0
+LICENSE_COMB= multi
+
USES= zip
-USE_JAVA= YES
+USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
+NO_ARCH= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
-.include <bsd.port.pre.mk>
-
post-extract:
- ${RM} ${WRKSRC}/${DISTNAME}.sh
- ${RM} ${WRKSRC}/${DISTNAME}.bat
+ @${RM} ${WRKSRC}/${DISTNAME}.sh
+ @${RM} ${WRKSRC}/${DISTNAME}.bat
pre-install:
@${SED} -e 's:%%PATH%%:${DATADIR}/:' \
@@ -30,8 +32,7 @@ pre-install:
< ${FILESDIR}/${PORTNAME}.sh > ${WRKDIR}/${PORTNAME}
do-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}
- ${CP} -R ${WRKSRC}/* ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/dirbuster/pkg-descr b/security/dirbuster/pkg-descr
index 7d9336571393..fc3ce226ecaa 100644
--- a/security/dirbuster/pkg-descr
+++ b/security/dirbuster/pkg-descr
@@ -4,4 +4,4 @@ is the case now of what looks like a web server in a state of default
installation is actually not, and has pages and applications hidden
within. DirBuster attempts to find these.
-WWW: http://www.owasp.org/index.php/Category:OWASP_DirBuster_Project
+WWW: https://www.owasp.org/index.php/Category:OWASP_DirBuster_Project
diff --git a/security/dirbuster/pkg-plist b/security/dirbuster/pkg-plist
index 68444f0e406d..5fe3878cd826 100644
--- a/security/dirbuster/pkg-plist
+++ b/security/dirbuster/pkg-plist
@@ -1,5 +1,14 @@
bin/dirbuster
-%%DATADIR%%/lib/swing-layout-1.0.3.jar
+%%DATADIR%%/DirBuster-1.0-RC1.jar
+%%DATADIR%%/apache-user-enum-1.0.txt
+%%DATADIR%%/apache-user-enum-2.0.txt
+%%DATADIR%%/directories.jbrofuzz
+%%DATADIR%%/directory-list-1.0.txt
+%%DATADIR%%/directory-list-2.3-medium.txt
+%%DATADIR%%/directory-list-2.3-small.txt
+%%DATADIR%%/directory-list-lowercase-2.3-medium.txt
+%%DATADIR%%/directory-list-lowercase-2.3-small.txt
+%%DATADIR%%/lib/BrowserLauncher2-1_3.jar
%%DATADIR%%/lib/commons-codec-1.3.jar
%%DATADIR%%/lib/commons-httpclient-3.1.jar
%%DATADIR%%/lib/commons-logging-1.1.1.jar
@@ -11,13 +20,4 @@ bin/dirbuster
%%DATADIR%%/lib/jhbasic.jar
%%DATADIR%%/lib/jsearch.jar
%%DATADIR%%/lib/looks-2.2.0.jar
-%%DATADIR%%/lib/BrowserLauncher2-1_3.jar
-%%DATADIR%%/directory-list-lowercase-2.3-small.txt
-%%DATADIR%%/directory-list-lowercase-2.3-medium.txt
-%%DATADIR%%/directory-list-2.3-small.txt
-%%DATADIR%%/directory-list-2.3-medium.txt
-%%DATADIR%%/directory-list-1.0.txt
-%%DATADIR%%/directories.jbrofuzz
-%%DATADIR%%/apache-user-enum-2.0.txt
-%%DATADIR%%/apache-user-enum-1.0.txt
-%%DATADIR%%/DirBuster-1.0-RC1.jar
+%%DATADIR%%/lib/swing-layout-1.0.3.jar