aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-19 00:09:15 +0800
committerpgj <pgj@FreeBSD.org>2012-02-19 00:09:15 +0800
commit3e31fa0a2db7249446f297c414e1712a8c2471d3 (patch)
tree8c17f4e474397b22c5aad21a6ec5e0a71f778080 /security
parent072ab4fc0346a37412c154e4b0c87fbe29f0f97d (diff)
downloadfreebsd-ports-gnome-3e31fa0a2db7249446f297c414e1712a8c2471d3.tar.gz
freebsd-ports-gnome-3e31fa0a2db7249446f297c414e1712a8c2471d3.tar.zst
freebsd-ports-gnome-3e31fa0a2db7249446f297c414e1712a8c2471d3.zip
This library implements the RSA encryption and signature algorithms for
arbitrarily-sized ByteStrings. While the implementations work, they are not necessarily the fastest ones on the planet. Particularly key generation. The algorithms included are based of RFC 3447, or the Public-Key Cryptography Standard for RSA, version 2.1 (a.k.a, PKCS#1 v2.1). WWW: http://hackage.haskell.org/package/RSA Obtained from: FreeBSD Haskell
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/hs-RSA/Makefile41
-rw-r--r--security/hs-RSA/distinfo2
-rw-r--r--security/hs-RSA/pkg-descr8
4 files changed, 52 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 164f866e5d92..453b7aac945c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -185,6 +185,7 @@
SUBDIR += horde-jeta
SUBDIR += hotssh
SUBDIR += hs-Crypto
+ SUBDIR += hs-RSA
SUBDIR += hs-SHA
SUBDIR += hs-clientsession
SUBDIR += hs-cprng-aes
diff --git a/security/hs-RSA/Makefile b/security/hs-RSA/Makefile
new file mode 100644
index 000000000000..7206046dbfec
--- /dev/null
+++ b/security/hs-RSA/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: hs-RSA
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= RSA
+PORTVERSION= 1.0.6.2
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Implementation of RSA, using the padding schemes of PKCS#1 v2.1
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= SHA
+
+OPTIONS= MD5 "Include support for using MD5" on \
+ BINARY "Use the binary package for serialization" on
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
+.include <bsd.port.options.mk>
+
+.if defined(WITH_MD5)
+CONFIGURE_ARGS+= --flags="IncludeMD5"
+USE_CABAL+= pureMD5
+.else
+CONFIGURE_ARGS+= --flags="-IncludeMD5"
+.endif
+
+.if defined(WITH_BINARY)
+CONFIGURE_ARGS+= --flags="UseBinary"
+USE_CABAL+= binary
+.else
+CONFIGURE_ARGS+= --flags="-UseBinary"
+.endif
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-RSA/distinfo b/security/hs-RSA/distinfo
new file mode 100644
index 000000000000..6899a5e0314e
--- /dev/null
+++ b/security/hs-RSA/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/RSA-1.0.6.2.tar.gz) = 93c34f4fd4d99530b54205d93922dc280b83cbbc92a53e6ad9d63cf93edf4b69
+SIZE (cabal/RSA-1.0.6.2.tar.gz) = 11986
diff --git a/security/hs-RSA/pkg-descr b/security/hs-RSA/pkg-descr
new file mode 100644
index 000000000000..52c822236d15
--- /dev/null
+++ b/security/hs-RSA/pkg-descr
@@ -0,0 +1,8 @@
+This library implements the RSA encryption and signature algorithms for
+arbitrarily-sized ByteStrings. While the implementations work, they are
+not necessarily the fastest ones on the planet. Particularly key
+generation. The algorithms included are based of RFC 3447, or the
+Public-Key Cryptography Standard for RSA, version 2.1 (a.k.a, PKCS#1
+v2.1).
+
+WWW: http://hackage.haskell.org/package/RSA