aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-22 00:35:33 +0800
committererwin <erwin@FreeBSD.org>2005-12-22 00:35:33 +0800
commit461b665f1d7ad5f5660253ec0503925f1f2cd4a0 (patch)
tree8208efd6fd5f10297bf97226494827c15d0ab8d6 /security
parent814db2a1e9b90c2a3fbb08e94b7706852b0b30d5 (diff)
downloadfreebsd-ports-gnome-461b665f1d7ad5f5660253ec0503925f1f2cd4a0.tar.gz
freebsd-ports-gnome-461b665f1d7ad5f5660253ec0503925f1f2cd4a0.tar.zst
freebsd-ports-gnome-461b665f1d7ad5f5660253ec0503925f1f2cd4a0.zip
Shark is 64-bit block cipher that accepts a 128-bit key. It was
designed by Vincent Rijmen, Joan Daemen, Bart Preneel, Antoon Bosselaers, and Erik De Win. WWW: http://search.cpan.org/dist/Crypt-Shark PR: ports/90699 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Shark/Makefile24
-rw-r--r--security/p5-Crypt-Shark/distinfo3
-rw-r--r--security/p5-Crypt-Shark/pkg-descr5
-rw-r--r--security/p5-Crypt-Shark/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 2c0510251550..24ae31b2b047 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -341,6 +341,7 @@
SUBDIR += p5-Crypt-SSLeay
SUBDIR += p5-Crypt-Salt
SUBDIR += p5-Crypt-Serpent
+ SUBDIR += p5-Crypt-Shark
SUBDIR += p5-Crypt-SmbHash
SUBDIR += p5-Crypt-Solitaire
SUBDIR += p5-Crypt-TripleDES
diff --git a/security/p5-Crypt-Shark/Makefile b/security/p5-Crypt-Shark/Makefile
new file mode 100644
index 000000000000..8d3548140cb6
--- /dev/null
+++ b/security/p5-Crypt-Shark/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-Shark
+# Date created: 20 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-Shark
+PORTVERSION= 1.0.1
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for Shark block cipher
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Shark.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Shark/distinfo b/security/p5-Crypt-Shark/distinfo
new file mode 100644
index 000000000000..ffb05107347f
--- /dev/null
+++ b/security/p5-Crypt-Shark/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Shark-1.0.1.tar.gz) = ffd5b13f3f7f45da445af354f8013d6d
+SHA256 (Crypt-Shark-1.0.1.tar.gz) = c84de9396446a4f41afaeecffe380ad2bc568fc6e28bc9741647d7e7ef73faf2
+SIZE (Crypt-Shark-1.0.1.tar.gz) = 82403
diff --git a/security/p5-Crypt-Shark/pkg-descr b/security/p5-Crypt-Shark/pkg-descr
new file mode 100644
index 000000000000..869bdb2f6adc
--- /dev/null
+++ b/security/p5-Crypt-Shark/pkg-descr
@@ -0,0 +1,5 @@
+Shark is 64-bit block cipher that accepts a 128-bit key. It was
+designed by Vincent Rijmen, Joan Daemen, Bart Preneel, Antoon
+Bosselaers, and Erik De Win.
+
+WWW: http://search.cpan.org/dist/Crypt-Shark
diff --git a/security/p5-Crypt-Shark/pkg-plist b/security/p5-Crypt-Shark/pkg-plist
new file mode 100644
index 000000000000..67c5e23faff8
--- /dev/null
+++ b/security/p5-Crypt-Shark/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Shark.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Shark/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Shark/Shark.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Shark/Shark.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Shark/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Crypt 2>/dev/null || true