aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-02-20 21:23:50 +0800
committermakc <makc@FreeBSD.org>2014-02-20 21:23:50 +0800
commit50eeb9e1188f1074e249884a755c5e5cd2f4a496 (patch)
tree8e728bbb655c20157b0d325a47fae4dbd626769d /security
parent46b9121f20b170c226e218ae76ad4380743fd05d (diff)
downloadfreebsd-ports-gnome-50eeb9e1188f1074e249884a755c5e5cd2f4a496.tar.gz
freebsd-ports-gnome-50eeb9e1188f1074e249884a755c5e5cd2f4a496.tar.zst
freebsd-ports-gnome-50eeb9e1188f1074e249884a755c5e5cd2f4a496.zip
devel/qca:
- Add stage support - Convert WITH_DEBUG to option - Remove MAINTAINER_MODE - Remove now needless stripping in post-install security/qca-*: - Convert LIB_DEPENDS to new style - Add stage support - Convert WITH_DEBUG to option - Remove now needless stripping in post-install
Diffstat (limited to 'security')
-rw-r--r--security/qca-cyrus-sasl/Makefile19
-rw-r--r--security/qca-gnupg/Makefile17
-rw-r--r--security/qca-ossl/Makefile18
3 files changed, 19 insertions, 35 deletions
diff --git a/security/qca-cyrus-sasl/Makefile b/security/qca-cyrus-sasl/Makefile
index e53dd05b74cc..ccfdd5ba0dd0 100644
--- a/security/qca-cyrus-sasl/Makefile
+++ b/security/qca-cyrus-sasl/Makefile
@@ -9,8 +9,8 @@ MASTER_SITES= http://delta.affinix.com/download/qca/2.0/plugins/
MAINTAINER= kde@FreeBSD.org
COMMENT= QCA Cyrus SASL plugin
-LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca \
- sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS= libqca.so:${PORTSDIR}/devel/qca \
+ libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
USE_BZIP2= yes
USE_QT4= corelib qmake_build moc_build
@@ -19,17 +19,12 @@ QT_NONSTANDARD= yes
CONFIGURE_ARGS+=--plugins-path=${PREFIX}/${QT_PLUGINDIR_REL} \
--with-sasl-inc=${LOCALBASE}/include \
--with-sasl-lib=${LOCALBASE}/lib
+DESTDIRNAME= INSTALL_ROOT
-.if !defined(WITH_DEBUG)
-CONFIGURE_ARGS+=--release --no-separate-debug-info
-PLIST_SUB+= DEBUG="@comment "
-.else
-CONFIGURE_ARGS+=--debug
-PLIST_SUB+= DEBUG=""
-.endif
+OPTIONS_DEFINE= DEBUG
+OPTIONS_SUB= yes
-NO_STAGE= yes
-post-install:
- ${STRIP_CMD} ${PREFIX}/${QT_PLUGINDIR_REL}/crypto/libqca-cyrus-sasl.so
+DEBUG_CONFIGURE_ON= --debug
+DEBUG_CONFIGURE_OFF= --release --no-separate-debug-info
.include <bsd.port.mk>
diff --git a/security/qca-gnupg/Makefile b/security/qca-gnupg/Makefile
index 1b2d5198ffb7..898547c48bfe 100644
--- a/security/qca-gnupg/Makefile
+++ b/security/qca-gnupg/Makefile
@@ -9,24 +9,19 @@ MASTER_SITES= http://delta.affinix.com/download/qca/2.0/plugins/
MAINTAINER= kde@FreeBSD.org
COMMENT= QCA GnuPG plugin
-LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca
+LIB_DEPENDS= libqca.so:${PORTSDIR}/devel/qca
USE_BZIP2= yes
USE_QT4= corelib qmake_build moc_build
HAS_CONFIGURE= yes
QT_NONSTANDARD= yes
CONFIGURE_ARGS+=--plugins-path=${PREFIX}/${QT_PLUGINDIR_REL}
+DESTDIRNAME= INSTALL_ROOT
-.if !defined(WITH_DEBUG)
-CONFIGURE_ARGS+=--release --no-separate-debug-info
-PLIST_SUB+= DEBUG="@comment "
-.else
-CONFIGURE_ARGS+=--debug
-PLIST_SUB+= DEBUG=""
-.endif
+OPTIONS_DEFINE= DEBUG
+OPTIONS_SUB= yes
-NO_STAGE= yes
-post-install:
- ${STRIP_CMD} ${PREFIX}/${QT_PLUGINDIR_REL}/crypto/libqca-gnupg.so
+DEBUG_CONFIGURE_ON= --debug
+DEBUG_CONFIGURE_OFF= --release --no-separate-debug-info
.include <bsd.port.mk>
diff --git a/security/qca-ossl/Makefile b/security/qca-ossl/Makefile
index 64127ec33479..3082da5a4b3e 100644
--- a/security/qca-ossl/Makefile
+++ b/security/qca-ossl/Makefile
@@ -10,28 +10,22 @@ MASTER_SITES= http://delta.affinix.com/download/qca/2.0/plugins/
MAINTAINER= kde@FreeBSD.org
COMMENT= QCA OpenSLL plugin
-LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca
+LIB_DEPENDS= libqca.so:${PORTSDIR}/devel/qca
USE_BZIP2= yes
USE_QT4= corelib qmake_build moc_build
HAS_CONFIGURE= yes
QT_NONSTANDARD= yes
USE_OPENSSL= yes
-
CONFIGURE_ARGS= --plugins-path=${PREFIX}/${QT_PLUGINDIR_REL} \
--with-openssl-inc=${OPENSSLINC} \
--with-openssl-lib=${OPENSSLLIB}
+DESTDIRNAME= INSTALL_ROOT
-.if !defined(WITH_DEBUG)
-CONFIGURE_ARGS+=--release --no-separate-debug-info
-PLIST_SUB+= DEBUG="@comment "
-.else
-CONFIGURE_ARGS+=--debug
-PLIST_SUB+= DEBUG=""
-.endif
+OPTIONS_DEFINE= DEBUG
+OPTIONS_SUB= yes
-NO_STAGE= yes
-post-install:
- ${STRIP_CMD} ${PREFIX}/${QT_PLUGINDIR_REL}/crypto/libqca-ossl.so
+DEBUG_CONFIGURE_ON= --debug
+DEBUG_CONFIGURE_OFF= --release --no-separate-debug-info
.include <bsd.port.mk>