aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2015-08-10 04:21:02 +0800
committerswills <swills@FreeBSD.org>2015-08-10 04:21:02 +0800
commit51ad768e1475470add01875431007e27f4fb1903 (patch)
tree17a8618a79872a0c2c38035c63f3dc9e7d30e5d6 /security
parentbf01d230c946c34084e332e2e595864698b73fb4 (diff)
downloadfreebsd-ports-gnome-51ad768e1475470add01875431007e27f4fb1903.tar.gz
freebsd-ports-gnome-51ad768e1475470add01875431007e27f4fb1903.tar.zst
freebsd-ports-gnome-51ad768e1475470add01875431007e27f4fb1903.zip
secrutiy/rubygem-attr_encrypted: create port
Ruby library which generates attr_accessors that encrypt and decrypt attributes transparently WWW: https://github.com/attr-encrypted/attr_encrypted PR: 201806 Submitted by: Torsten Zühlsdorff <ports@toco-domains.de>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-attr_encrypted/Makefile20
-rw-r--r--security/rubygem-attr_encrypted/distinfo2
-rw-r--r--security/rubygem-attr_encrypted/pkg-descr4
4 files changed, 27 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e85336c5a60d..5662e24553e4 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -912,6 +912,7 @@
SUBDIR += ruby-hmac
SUBDIR += ruby-password
SUBDIR += ruby-tcpwrap
+ SUBDIR += rubygem-attr_encrypted
SUBDIR += rubygem-bcrypt
SUBDIR += rubygem-bcrypt-ruby
SUBDIR += rubygem-doorkeeper
diff --git a/security/rubygem-attr_encrypted/Makefile b/security/rubygem-attr_encrypted/Makefile
new file mode 100644
index 000000000000..a793a16f51ff
--- /dev/null
+++ b/security/rubygem-attr_encrypted/Makefile
@@ -0,0 +1,20 @@
+# Created by: Torsten Zühlsdorff <ports@toco-domains.de>
+# $FreeBSD$
+
+PORTNAME= attr_encrypted
+PORTVERSION= 1.3.4
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Generates attr_accessors that encrypt and decrypt attributes
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-encryptor>=1.3.0:${PORTSDIR}/security/rubygem-encryptor
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST=yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-attr_encrypted/distinfo b/security/rubygem-attr_encrypted/distinfo
new file mode 100644
index 000000000000..d372ffb7f57d
--- /dev/null
+++ b/security/rubygem-attr_encrypted/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/attr_encrypted-1.3.4.gem) = 175d9e2a9193f251419818900be9627069c573141dec823175f38c8a0941a2c2
+SIZE (rubygem/attr_encrypted-1.3.4.gem) = 20992
diff --git a/security/rubygem-attr_encrypted/pkg-descr b/security/rubygem-attr_encrypted/pkg-descr
new file mode 100644
index 000000000000..3104136de392
--- /dev/null
+++ b/security/rubygem-attr_encrypted/pkg-descr
@@ -0,0 +1,4 @@
+Ruby library which generates attr_accessors that encrypt
+and decrypt attributes transparently
+
+WWW: https://github.com/attr-encrypted/attr_encrypted