aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-12 04:54:14 +0800
committerantoine <antoine@FreeBSD.org>2014-09-12 04:54:14 +0800
commit6949532ab78582fdcbe19d8223db318940334b54 (patch)
tree1386d5278cddeeec47ee84c14c83de40ca60ab96 /security
parentdba0d5e26166aa2027f818ecdf6a265f0b73bbfd (diff)
downloadfreebsd-ports-gnome-6949532ab78582fdcbe19d8223db318940334b54.tar.gz
freebsd-ports-gnome-6949532ab78582fdcbe19d8223db318940334b54.tar.zst
freebsd-ports-gnome-6949532ab78582fdcbe19d8223db318940334b54.zip
- Allow staging as a regular user
- Shebangfix
Diffstat (limited to 'security')
-rw-r--r--security/ipfilter2dshield/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/security/ipfilter2dshield/Makefile b/security/ipfilter2dshield/Makefile
index 517f7722e543..fef182a9a830 100644
--- a/security/ipfilter2dshield/Makefile
+++ b/security/ipfilter2dshield/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ipfilter2dshield
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.dshield.org/clients/
DISTNAME= dshield-freebsd.pl
@@ -14,12 +14,14 @@ COMMENT= Official DShield client for ipfilter firewall logs
RUN_DEPENDS= p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ${DISTNAME}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
NO_BUILD= yes
+NO_WRKSUBDIR= yes
do-extract:
@${MKDIR} ${WRKDIR}
@@ -34,6 +36,6 @@ do-install:
@${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${WRKDIR}/${DISTNAME} \
${STAGEDIR}${ETCDIR}/${DISTNAME}.sample
- ${INSTALL} -o ${BINOWN} -g ${BINGRP} -m 760 ${WRKDIR}/${DISTNAME} ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL} -m 760 ${WRKDIR}/${DISTNAME} ${STAGEDIR}${PREFIX}/sbin
.include <bsd.port.mk>