aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-06-23 18:22:35 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-06-23 18:22:35 +0800
commit761318814ac301278bd92a5a11b9929ceb2fd378 (patch)
tree0f711454c72827d7922f3958705750d08bee918b /security
parent342b2aa3150a0dbda23825559aa1af1be540c980 (diff)
downloadfreebsd-ports-gnome-761318814ac301278bd92a5a11b9929ceb2fd378.tar.gz
freebsd-ports-gnome-761318814ac301278bd92a5a11b9929ceb2fd378.tar.zst
freebsd-ports-gnome-761318814ac301278bd92a5a11b9929ceb2fd378.zip
security/py-certbot: Rename from py-letsencrypt and update
- Move security/py-letsencrypt to security/py-certbot - Update security/py-acme to 0.8.1 - Update security/py-certbot to 0.8.1 - Update python dependencies PR: 209584
Diffstat (limited to 'security')
-rw-r--r--security/Makefile2
-rw-r--r--security/py-acme/Makefile4
-rw-r--r--security/py-acme/distinfo5
-rw-r--r--security/py-certbot/Makefile (renamed from security/py-letsencrypt/Makefile)12
-rw-r--r--security/py-certbot/distinfo3
-rw-r--r--security/py-certbot/pkg-descr (renamed from security/py-letsencrypt/pkg-descr)0
-rw-r--r--security/py-certbot/pkg-message (renamed from security/py-letsencrypt/pkg-message)0
-rw-r--r--security/py-letsencrypt/distinfo2
8 files changed, 15 insertions, 13 deletions
diff --git a/security/Makefile b/security/Makefile
index 24c6fc54613d..f4b18d512035 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -827,6 +827,7 @@
SUBDIR += py-bcrypt
SUBDIR += py-borg.localrole
SUBDIR += py-cerealizer
+ SUBDIR += py-certbot
SUBDIR += py-certifi
SUBDIR += py-cpe
SUBDIR += py-cracklib
@@ -849,7 +850,6 @@
SUBDIR += py-keyczar
SUBDIR += py-keyring
SUBDIR += py-keyrings.alt
- SUBDIR += py-letsencrypt
SUBDIR += py-libnacl
SUBDIR += py-m2crypto
SUBDIR += py-mcrypt
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
index 11a763dbd683..c8a1ca533284 100644
--- a/security/py-acme/Makefile
+++ b/security/py-acme/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= acme
-PORTVERSION= 0.5.0
+PORTVERSION= 0.8.1
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0.8:security/py-cryptography \
${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:devel/py-pyrfc3339 \
${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz \
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests \
- ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>=1.0:devel/py-setuptools${PYTHON_SUFFIX} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six \
${PYTHON_PKGNAMEPREFIX}werkzeug>0:www/py-werkzeug
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}funcsigs>0:devel/py-funcsigs \
diff --git a/security/py-acme/distinfo b/security/py-acme/distinfo
index 8281a38c0fc1..8cb0ea46653f 100644
--- a/security/py-acme/distinfo
+++ b/security/py-acme/distinfo
@@ -1,2 +1,3 @@
-SHA256 (acme-0.5.0.tar.gz) = 0605c63c656d33c883a05675f5db9cfb85d503f2771c885031800e0da7631abd
-SIZE (acme-0.5.0.tar.gz) = 84155
+TIMESTAMP = 1466491084
+SHA256 (acme-0.8.1.tar.gz) = d3ea4acf280bf6253ad7d641cb0970f230a19805acfed809e7a8ddcf62157d9f
+SIZE (acme-0.8.1.tar.gz) = 84610
diff --git a/security/py-letsencrypt/Makefile b/security/py-certbot/Makefile
index bb005d8e7718..006b04c84e9a 100644
--- a/security/py-letsencrypt/Makefile
+++ b/security/py-certbot/Makefile
@@ -1,8 +1,8 @@
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
# $FreeBSD$
-PORTNAME= letsencrypt
-PORTVERSION= 0.5.0
+PORTNAME= certbot
+PORTVERSION= 0.8.1
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
@@ -18,13 +18,13 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme==${PKGVERSION}:security/py-acme \
${PYTHON_PKGNAMEPREFIX}configargparse>=0.9.3:devel/py-configargparse \
${PYTHON_PKGNAMEPREFIX}configobj>0:devel/py-configobj \
${PYTHON_PKGNAMEPREFIX}cryptography>=0.7:security/py-cryptography \
- ${PYTHON_PKGNAMEPREFIX}parsedatetime>0:devel/py-parsedatetime \
- ${PYTHON_PKGNAMEPREFIX}psutil>=2.1.0:sysutils/py-psutil \
+ ${PYTHON_PKGNAMEPREFIX}parsedatetime>=1.3:devel/py-parsedatetime \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=2.2.1:sysutils/py-psutil \
${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl \
${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:devel/py-pyrfc3339 \
${PYTHON_PKGNAMEPREFIX}python2-pythondialog>=3.2.2r1:devel/py-python2-pythondialog \
${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz \
- ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:devel/py-setuptools${PYTHON_SUFFIX} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>=1.0:devel/py-setuptools${PYTHON_SUFFIX} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six \
${PYTHON_PKGNAMEPREFIX}zope.component>0:devel/py-zope.component \
${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface \
@@ -39,7 +39,7 @@ post-patch:
${REINPLACE_CMD} \
-e 's|/etc/|${LOCALBASE}/etc/|' \
-e 's|/var/lib|/var/db|' \
- ${WRKSRC}/letsencrypt/constants.py
+ ${WRKSRC}/${PORTNAME}/constants.py
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/security/py-certbot/distinfo b/security/py-certbot/distinfo
new file mode 100644
index 000000000000..72833ffd2cdb
--- /dev/null
+++ b/security/py-certbot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1466491228
+SHA256 (certbot-0.8.1.tar.gz) = 6ca8df3d310ced6687d38aac17c0fb8c1b2ec7a3bea156a254e4cc2a1c132771
+SIZE (certbot-0.8.1.tar.gz) = 204649
diff --git a/security/py-letsencrypt/pkg-descr b/security/py-certbot/pkg-descr
index 13d798b2797b..13d798b2797b 100644
--- a/security/py-letsencrypt/pkg-descr
+++ b/security/py-certbot/pkg-descr
diff --git a/security/py-letsencrypt/pkg-message b/security/py-certbot/pkg-message
index 97eef7bdc5da..97eef7bdc5da 100644
--- a/security/py-letsencrypt/pkg-message
+++ b/security/py-certbot/pkg-message
diff --git a/security/py-letsencrypt/distinfo b/security/py-letsencrypt/distinfo
deleted file mode 100644
index 57b2780b37c9..000000000000
--- a/security/py-letsencrypt/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (letsencrypt-0.5.0.tar.gz) = e38a2b70b82be79bc195307652244a3e012ec73d897d4dbd3f80cf698496d15a
-SIZE (letsencrypt-0.5.0.tar.gz) = 193077