aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2000-01-18 04:07:39 +0800
committernectar <nectar@FreeBSD.org>2000-01-18 04:07:39 +0800
commit77adf273aefdc7319f8053cdbc469f864c26af25 (patch)
tree785a063d7a0edc2969ec90a059f47af0129b9886 /security
parent81894e8f415a20b1d1ac2eae94fc7d50585ffea1 (diff)
downloadfreebsd-ports-gnome-77adf273aefdc7319f8053cdbc469f864c26af25.tar.gz
freebsd-ports-gnome-77adf273aefdc7319f8053cdbc469f864c26af25.tar.zst
freebsd-ports-gnome-77adf273aefdc7319f8053cdbc469f864c26af25.zip
. fix packing list for cases with/without X, with/without KRB4
. restore HEIMDAL_HOME for PREFIX handling
Diffstat (limited to 'security')
-rw-r--r--security/heimdal/Makefile42
-rw-r--r--security/heimdal/pkg-plist14
-rw-r--r--security/heimdal/pkg-plist.krb46
-rw-r--r--security/heimdal/pkg-plist.x116
4 files changed, 53 insertions, 15 deletions
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index 74909d9a7921..d09acca7b933 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= nectar@FreeBSD.ORG
RESTRICTED= "Crypto; export-controlled"
MAN1= ftp.1 kdestroy.1 kgetcred.1 kinit.1 klist.1 kpasswd.1 \
- kx.1 rxtelnet.1 rxterm.1 telnet.1 tenletxr.1
+ telnet.1
MAN3= editline.3 krb5_425_conv_principal.3 kafs.3 \
krb5_build_principal.3 krb5_free_principal.3 \
krb5_openlog.3 krb5_parse_name.3 \
@@ -26,7 +26,7 @@ MAN3= editline.3 krb5_425_conv_principal.3 kafs.3 \
krb5_warn.3
MAN5= ftpusers.5 krb5.conf.5
MAN8= ftpd.8 hprop.8 hpropd.8 kdc.8 kpasswdd.8 kstash.8 \
- ktutil.8 kxd.8 push.8 telnetd.8
+ ktutil.8 push.8 telnetd.8
USE_LIBTOOL= YES
CONFIGURE_ARGS= --prefix=${PREFIX} --enable-shared
@@ -35,7 +35,45 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --enable-shared
CONFIGURE_ARGS+= --without-krb4
.endif
+.if defined(HEIMDAL_HOME)
+PREFIX= ${HEIMDAL_HOME}
+.endif
+
+.if exists(${X11BASE}/lib/libX11.a) && !defined(NO_X11)
+USE_XLIB= yes
+.endif
+
+.if defined(USE_XLIB)
+MAN1+= kx.1 rxtelnet.1 rxterm.1 tenletxr.1
+MAN8+= kxd.8
+CONFIGURE_ARGS+= --with-x
+.else
+CONFIGURE_ARGS+= --without-x
+.endif
+
+.if exists(/usr/lib/libkrb.a) && !defined(NO_KRB4)
+WITH_KRB4= yes
+.endif
+
+.if defined(WITH_KRB4)
+CONFIGURE_ARGS+= --with-krb4
+.else
+CONFIGURE_ARGS+= --without-krb4
+.endif
+
+PLIST:= ${WRKDIR}/PLIST
+
+pre-install:
+ @${CP} ${PKGDIR}/PLIST ${PLIST}
+.if defined(WITH_KRB4)
+ @${CAT} ${PKGDIR}/PLIST.KRB4 >> ${PLIST}
+.endif
+.if defined(USE_XLIB)
+ @${CAT} ${PKGDIR}/PLIST.X11 >> ${PLIST}
+.endif
+
post-install:
+ install-info ${PREFIX}/info/heimdal.info ${PREFIX}/info/dir
${SETENV} OBJFORMAT="${PORTOBJFORMAT}" ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
diff --git a/security/heimdal/pkg-plist b/security/heimdal/pkg-plist
index 10abc08676e4..1415c55ae100 100644
--- a/security/heimdal/pkg-plist
+++ b/security/heimdal/pkg-plist
@@ -1,4 +1,3 @@
-bin/afslog
bin/compile_et
bin/des
bin/ftp
@@ -8,20 +7,14 @@ bin/kgetcred
bin/kinit
bin/klist
bin/kpasswd
-bin/kx
bin/login
bin/otp
bin/otpprint
-bin/pagsh
bin/pfrom
bin/rsh
-bin/rxtelnet
-bin/rxterm
bin/string2key
bin/telnet
-bin/tenletxr
bin/verify_krb5_conf
-bin/xnlock
include/asn1.h
include/asn1_err.h
include/base64.h
@@ -62,8 +55,7 @@ include/sl.h
include/ss/ss.h
@unexec install-info --delete %D/info/heimdal.info %D/info/dir
info/heimdal.info
-@exec install-info %D/info/bash.info %D/info/dir
-lib/lib45.a
+@exec install-info %D/info/heimdal.info %D/info/dir
lib/libasn1.a
lib/libasn1.so
lib/libasn1.so.1
@@ -86,9 +78,6 @@ lib/libkadm5clnt.so.4
lib/libkadm5srv.a
lib/libkadm5srv.so
lib/libkadm5srv.so.5
-lib/libkafs.a
-lib/libkafs.so
-lib/libkafs.so.1
lib/libkrb5.a
lib/libkrb5.so
lib/libkrb5.so.7
@@ -112,7 +101,6 @@ libexec/ipropd-slave
libexec/kadmind
libexec/kdc
libexec/kpasswdd
-libexec/kxd
libexec/popper
libexec/push
libexec/rshd
diff --git a/security/heimdal/pkg-plist.krb4 b/security/heimdal/pkg-plist.krb4
new file mode 100644
index 000000000000..bb661472f0eb
--- /dev/null
+++ b/security/heimdal/pkg-plist.krb4
@@ -0,0 +1,6 @@
+bin/afslog
+bin/pagsh
+lib/lib45.a
+lib/libkafs.a
+lib/libkafs.so
+lib/libkafs.so.1
diff --git a/security/heimdal/pkg-plist.x11 b/security/heimdal/pkg-plist.x11
new file mode 100644
index 000000000000..3d39266b871a
--- /dev/null
+++ b/security/heimdal/pkg-plist.x11
@@ -0,0 +1,6 @@
+bin/kx
+bin/rxtelnet
+bin/rxterm
+bin/tenletxr
+bin/xnlock
+libexec/kxd