aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-11-13 22:42:30 +0800
committermakc <makc@FreeBSD.org>2014-11-13 22:42:30 +0800
commit8116ef746390b2bc9e7ed87d4d7228d40827015a (patch)
tree7bf9caf1a9ec34f2c8c8538e8bfd37247231ef6f /security
parent1996a165481036bbeaea5d090137d5fc8ef2e6a9 (diff)
downloadfreebsd-ports-gnome-8116ef746390b2bc9e7ed87d4d7228d40827015a.tar.gz
freebsd-ports-gnome-8116ef746390b2bc9e7ed87d4d7228d40827015a.tar.zst
freebsd-ports-gnome-8116ef746390b2bc9e7ed87d4d7228d40827015a.zip
security/pinentry:
- Update to 0.9.0 - Remove pinentry-gtk port (GTK+ 1 support is discontinued upstream) - Ignore Qt 4 frontend on 10 and greater, it fails to build with clang/libc++
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pinentry-gtk/Makefile17
-rw-r--r--security/pinentry/Makefile34
-rw-r--r--security/pinentry/distinfo4
-rw-r--r--security/pinentry/pkg-plist1
5 files changed, 20 insertions, 37 deletions
diff --git a/security/Makefile b/security/Makefile
index 9f4bc6627ff5..a21e2f63340c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -716,7 +716,6 @@
SUBDIR += pidgin-otr
SUBDIR += pinentry
SUBDIR += pinentry-curses
- SUBDIR += pinentry-gtk
SUBDIR += pinentry-gtk2
SUBDIR += pinentry-qt4
SUBDIR += pkcrack
diff --git a/security/pinentry-gtk/Makefile b/security/pinentry-gtk/Makefile
deleted file mode 100644
index c2468de127f5..000000000000
--- a/security/pinentry-gtk/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# Created by: Michael Nottebrock <lofi@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= pinentry
-PORTREVISION= 1
-
-COMMENT= GTK version of the gnupg password dialog
-
-CONFLICTS_INSTALL= pinentry-[0-9]* pinentry-curses-* \
- pinentry-gtk2-* pinentry-qt-* pinentry-qt4-*
-
-PINENTRY_SLAVE= -gtk
-PORT_OPTIONS+= GTK
-
-MASTERDIR= ${.CURDIR}/../pinentry
-
-.include "${MASTERDIR}/Makefile"
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index 992a4dd72375..7241ae32e9a0 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= pinentry
-PORTVERSION= 0.8.3
-PORTREVISION?= 3
+PORTVERSION= 0.9.0
+PORTREVISION?= 0
CATEGORIES= security
MASTER_SITES= GNUPG/pinentry
@@ -17,7 +17,6 @@ CONFLICTS_INSTALL?= pinentry-[a-z]*
USES= iconv gmake pkgconfig tar:bzip2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--disable-pinentry-qt
INFO= pinentry
CFLAGS+= -I${LOCALBASE}/include
@@ -25,11 +24,10 @@ LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(PINENTRY_SLAVE)
OPTIONS_MULTI= FRONTEND
-OPTIONS_MULTI_FRONTEND= NCURSES GTK GTK2 QT4
-OPTIONS_DEFAULT= ${OPTIONS_MULTI_FRONTEND}
+OPTIONS_MULTI_FRONTEND= NCURSES GTK2 QT4
+OPTIONS_DEFAULT= ${PINENTRY_DEFAULT}
NCURSES_DESC= Curses frontend
-GTK_DESC= Gtk+ 1 frontend
GTK2_DESC= Gtk+ 2 frontend
QT4_DESC= Qt 4 frontend
.else
@@ -38,8 +36,19 @@ PKGNAMESUFFIX= ${PINENTRY_SLAVE}
.include <bsd.port.options.mk>
+.if !defined(PINENTRY_SLAVE)
+. if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+PINENTRY_DEFAULT= ${OPTIONS_MULTI_FRONTEND:NQT4}
+QT4_DESC= Qt 4 frontend (broken)
+. else
+PINENTRY_DEFAULT= ${OPTIONS_MULTI_FRONTEND}
+. endif
+.endif
+
.if ${PORT_OPTIONS:MQT4}
-USE_GCC= any
+. if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+IGNORE= with Qt 4 frontend does not compile with libc++
+. endif
USE_QT4= gui moc_build
PLIST_SUB+= WITH_QT4=""
MOC4= ${LOCALBASE}/bin/moc-qt4
@@ -48,14 +57,6 @@ CONFIGURE_ARGS+=--disable-pinentry-qt4
PLIST_SUB+= WITH_QT4="@comment "
.endif
-.if ${PORT_OPTIONS:MGTK}
-USE_GNOME+= gtk12
-PLIST_SUB+= WITH_GTK=""
-.else
-CONFIGURE_ARGS+=--disable-pinentry-gtk
-PLIST_SUB+= WITH_GTK="@comment "
-.endif
-
.if ${PORT_OPTIONS:MGTK2}
USE_GNOME+= gtk20
PLIST_SUB+= WITH_GTK2=""
@@ -76,7 +77,8 @@ pre-configure:
.if ${PORT_OPTIONS:MQT4}
cd ${WRKSRC}/qt4 && \
${MOC4} pinentrydialog.h > pinentrydialog.moc && \
- ${MOC4} qsecurelineedit.h > qsecurelineedit.moc
+ ${MOC4} qsecurelineedit.h > qsecurelineedit.moc && \
+ ${MOC4} pinentryconfirm.h > pinentryconfirm.moc
.endif
.include <bsd.port.mk>
diff --git a/security/pinentry/distinfo b/security/pinentry/distinfo
index da2aa6463a74..e847ada53526 100644
--- a/security/pinentry/distinfo
+++ b/security/pinentry/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pinentry-0.8.3.tar.bz2) = 568b0b09b50b2388a4f94d704d5bcb28718ecd4654ed1acc43ab1f97d921a0ad
-SIZE (pinentry-0.8.3.tar.bz2) = 430753
+SHA256 (pinentry-0.9.0.tar.bz2) = 90045a07ab8e1a8e1ecf5d19b51691f195525e579fa5d71d7e92c120b05490ab
+SIZE (pinentry-0.9.0.tar.bz2) = 464272
diff --git a/security/pinentry/pkg-plist b/security/pinentry/pkg-plist
index 57e21f10b913..a3127e074ce0 100644
--- a/security/pinentry/pkg-plist
+++ b/security/pinentry/pkg-plist
@@ -1,5 +1,4 @@
bin/pinentry
%%WITH_NCURSES%%bin/pinentry-curses
-%%WITH_GTK%%bin/pinentry-gtk
%%WITH_GTK2%%bin/pinentry-gtk-2
%%WITH_QT4%%bin/pinentry-qt4