aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-27 17:07:10 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-27 17:07:10 +0800
commit882c81c1ffc07d3deec6fbcfa9cc9f4e0224a702 (patch)
tree6e6eb5cb0afb18d21a031ccc81a0b9952e1c9d2f /security
parentdfb8615143d91674ae546a1e969422055932c2b7 (diff)
downloadfreebsd-ports-gnome-882c81c1ffc07d3deec6fbcfa9cc9f4e0224a702.tar.gz
freebsd-ports-gnome-882c81c1ffc07d3deec6fbcfa9cc9f4e0224a702.tar.zst
freebsd-ports-gnome-882c81c1ffc07d3deec6fbcfa9cc9f4e0224a702.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'security')
-rw-r--r--security/pxytest/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/security/pxytest/Makefile b/security/pxytest/Makefile
index c727b94d2362..3f70aac19364 100644
--- a/security/pxytest/Makefile
+++ b/security/pxytest/Makefile
@@ -16,21 +16,16 @@ EXTRACT_AFTER_ARGS= > ${WRKDIR}/${PORTNAME}
NO_WRKSUBDIR= yes
-USES= perl5
+USES= perl5 shebangfix
-MAN1= pxytest.1
-PLIST_FILES= bin/pxytest
-
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e \
- 's:^#!.*:#!${PERL}:' ${WRKSRC}/${PORTNAME}
+PLIST_FILES= bin/pxytest man/man1/pxytest.1.gz
+SHEBANG_FILES= pxytest
do-build:
@cd ${WRKSRC} && pod2man ${PORTNAME} > ${PORTNAME}.1
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>