aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2018-01-24 04:13:52 +0800
committerpi <pi@FreeBSD.org>2018-01-24 04:13:52 +0800
commit8fac59a983d246b1b058dc4383ff77a533783eb3 (patch)
tree94f0199424465da4c10e68c468d2f99beba24699 /security
parent95148807ab2c3d3ac760dda3babe3eb0230477d6 (diff)
downloadfreebsd-ports-gnome-8fac59a983d246b1b058dc4383ff77a533783eb3.tar.gz
freebsd-ports-gnome-8fac59a983d246b1b058dc4383ff77a533783eb3.tar.zst
freebsd-ports-gnome-8fac59a983d246b1b058dc4383ff77a533783eb3.zip
security/py-fail2ban: update 0.10.1 -> 0.10.2
- many fixes from upstream for bugs in the 0.10.x version - automatic upgrade of python code to python3, if that is used PR: 225317 Submitted by: theis@gmx.at (maintainer) Changes: https://github.com/fail2ban/fail2ban/blob/0.10.2/ChangeLog
Diffstat (limited to 'security')
-rw-r--r--security/py-fail2ban/Makefile14
-rw-r--r--security/py-fail2ban/distinfo6
-rw-r--r--security/py-fail2ban/files/patch-config_action.d_pf.conf20
3 files changed, 14 insertions, 26 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index 221a5b99b8af..aec19797620b 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= fail2ban
-PORTVERSION= 0.10.1
-PORTREVISION= 1
+PORTVERSION= 0.10.2
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -48,6 +47,11 @@ MAN_FILES= ${WRKSRC}/man/fail2ban-client.1 \
FAIL2BAN_DBDIR= /var/db/${PORTNAME}
+PY2TO3_CMD= ${LOCALBASE}/bin/2to3-${PYTHON_VER}
+PY2TO3_ARG= --no-diffs --write --nobackups --fix=all
+
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's,/etc/fail2ban,${ETCDIR},g' ${FILES}
@${REINPLACE_CMD} -e 's,paths-debian.conf,paths-freebsd.conf,g' \
@@ -57,6 +61,10 @@ post-patch:
@${REINPLACE_CMD} -e 's,jail.conf(5),fail2ban-jail.conf(5),g' \
${MAN_FILES}
+. if ${PYTHON_MAJOR_VER} >= 3
+ (cd ${WRKSRC}/ && ${PY2TO3_CMD} ${PY2TO3_ARG} bin/* fail2ban)
+. endif
+
post-install:
@${MKDIR} ${STAGEDIR}${FAIL2BAN_DBDIR} ${STAGEDIR}/var/run/fail2ban
.for file in fail2ban-client fail2ban-regex fail2ban-server fail2ban
@@ -71,4 +79,4 @@ post-install-DOCS-on:
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/py-fail2ban/distinfo b/security/py-fail2ban/distinfo
index e4ee9d70a386..30a185f58cde 100644
--- a/security/py-fail2ban/distinfo
+++ b/security/py-fail2ban/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1508093600
-SHA256 (fail2ban-fail2ban-0.10.1_GH0.tar.gz) = 19bac652e50f35b3b58ea010c2b89b91b945365d37dbf17467e0dc345c058465
-SIZE (fail2ban-fail2ban-0.10.1_GH0.tar.gz) = 465156
+TIMESTAMP = 1516358804
+SHA256 (fail2ban-fail2ban-0.10.2_GH0.tar.gz) = 1c1a969137c56f7e8b90e5f14d78b80214d34d67209787bfddc8d5804ceb29cc
+SIZE (fail2ban-fail2ban-0.10.2_GH0.tar.gz) = 474624
diff --git a/security/py-fail2ban/files/patch-config_action.d_pf.conf b/security/py-fail2ban/files/patch-config_action.d_pf.conf
deleted file mode 100644
index e9ae34df9009..000000000000
--- a/security/py-fail2ban/files/patch-config_action.d_pf.conf
+++ /dev/null
@@ -1,20 +0,0 @@
---- config/action.d/pf.conf.orig 2017-10-12 11:46:46 UTC
-+++ config/action.d/pf.conf
-@@ -18,8 +18,8 @@
- # also, these rulesets are loaded into (nested) anchors
- # to enable them, add
- # anchor f2b {
--# name1
--# name2
-+# anchor name1
-+# anchor name2
- # ...
- # }
- # to your main pf ruleset, where "namei" are the names of the jails
-@@ -110,5 +110,5 @@ allports = any
- # Option: multiport
- # Notes.: addition to block access only to specific ports
- # Usage.: use in jail config: "banaction = pf[actiontype=<multiport>]"
--multiport = any port <port>
-+multiport = any port {<port>}
-