aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-08-17 22:20:40 +0800
committermat <mat@FreeBSD.org>2015-08-17 22:20:40 +0800
commit92a3a7b1bca5423036bca4932e5384d3e51591bd (patch)
tree16be3a9188cf2781563095e15839c170074dd7a7 /security
parented2992b93f898f5612b3952782ac7d9206ed029a (diff)
downloadfreebsd-ports-gnome-92a3a7b1bca5423036bca4932e5384d3e51591bd.tar.gz
freebsd-ports-gnome-92a3a7b1bca5423036bca4932e5384d3e51591bd.tar.zst
freebsd-ports-gnome-92a3a7b1bca5423036bca4932e5384d3e51591bd.zip
Remove UNIQUENAME and LATEST_LINK.
UNIQUENAME was never unique, it was only used by USE_LDCONFIG and now, we won't have conflicts there. Use PKGBASE instead of LATEST_LINK in PKGLATESTFILE, the *only* consumer is pkg-devel, and it works just fine without LATEST_LINK as pkg-devel has the correct PKGNAME anyway. Now that UNIQUENAME is gone, OPTIONSFILE is too. (it's been called OPTIONS_FILE now.) Reviewed by: antoine, bapt Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3336
Diffstat (limited to 'security')
-rw-r--r--security/botan110/Makefile2
-rw-r--r--security/gag/Makefile2
-rw-r--r--security/krb5-111/Makefile1
-rw-r--r--security/krb5-112/Makefile1
-rw-r--r--security/krb5-appl/Makefile1
-rw-r--r--security/proftpd-mod_clamav/Makefile1
-rw-r--r--security/py-itsdangerous/Makefile1
-rw-r--r--security/py-keyring/Makefile2
-rw-r--r--security/rubygem-net-ssh/Makefile1
-rw-r--r--security/shibboleth2-sp/Makefile2
10 files changed, 0 insertions, 14 deletions
diff --git a/security/botan110/Makefile b/security/botan110/Makefile
index f697f5327299..a21bf0ca341b 100644
--- a/security/botan110/Makefile
+++ b/security/botan110/Makefile
@@ -14,8 +14,6 @@ COMMENT= Portable, easy to use, and efficient C++ crypto library
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/doc/license.txt
-LATEST_LINK= botan${PKGNAMESUFFIX}
-
OPTIONS_DEFINE= SSL GMP ECC DOCS
OPTIONS_DEFAULT= SSL GMP ECC
ECC_DESC= ECC support
diff --git a/security/gag/Makefile b/security/gag/Makefile
index 8a0c62b1cdba..1b0a5d34c3b0 100644
--- a/security/gag/Makefile
+++ b/security/gag/Makefile
@@ -11,8 +11,6 @@ EXTRACT_SUFX= .tar
MAINTAINER= ports@FreeBSD.org
COMMENT= Stacheldraht (DOS attack) agent detector
-LATEST_LINK= gag-sickenscan
-
ALL_TARGET= gag
PORTDOCS= README
diff --git a/security/krb5-111/Makefile b/security/krb5-111/Makefile
index 49228edc313e..a3c6d02c7237 100644
--- a/security/krb5-111/Makefile
+++ b/security/krb5-111/Makefile
@@ -25,7 +25,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
CONFLICTS= heimdal-[0-9]* srp-[0-9]* krb5-[0-9]* krb5-maint-112-*
-LATEST_LINK= ${PORTNAME}-111
KERBEROSV_URL= http://web.mit.edu/kerberos/
USES= cpe gettext gmake perl5 gssapi:bootstrap,mit
USE_PERL5= build
diff --git a/security/krb5-112/Makefile b/security/krb5-112/Makefile
index ed222b40e111..f4a3a3b8cd39 100644
--- a/security/krb5-112/Makefile
+++ b/security/krb5-112/Makefile
@@ -22,7 +22,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
CONFLICTS= heimdal-[0-9]* srp-[0-9]* krb5-[0-9]* krb5-maint-111-*
-LATEST_LINK= ${PORTNAME}-112
KERBEROSV_URL= http://web.mit.edu/kerberos/
USE_PERL5= build
USE_LDCONFIG= yes
diff --git a/security/krb5-appl/Makefile b/security/krb5-appl/Makefile
index f79ac94277f7..08e48588f438 100644
--- a/security/krb5-appl/Makefile
+++ b/security/krb5-appl/Makefile
@@ -18,7 +18,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
CONFLICTS= krb4-[0-9]* krb5-1.[0-7].* heimdal-[0-9]* srp-[0-9]*
-LATEST_LINK= ${PORTNAME}-1
KERBEROSV_URL= http://web.mit.edu/kerberos/
USE_OPENSSL= yes
USES= gmake perl5 gssapi:mit
diff --git a/security/proftpd-mod_clamav/Makefile b/security/proftpd-mod_clamav/Makefile
index 5f37ea2fa358..3dfd166b6e69 100644
--- a/security/proftpd-mod_clamav/Makefile
+++ b/security/proftpd-mod_clamav/Makefile
@@ -14,7 +14,6 @@ LICENSE= GPLv2
DESCR= ${.CURDIR}/pkg-descr
-LATEST_LINK= ${PKGNAMEPREFIX}-${PORTNAME}
MASTERDIR= ${.CURDIR}/../../ftp/proftpd
GH_TAGNAME= v${DISTVERSION}
diff --git a/security/py-itsdangerous/Makefile b/security/py-itsdangerous/Makefile
index 985cc51367bd..f5b305351c83 100644
--- a/security/py-itsdangerous/Makefile
+++ b/security/py-itsdangerous/Makefile
@@ -15,7 +15,6 @@ LICENSE= BSD3CLAUSE
USES= python
USE_PYTHON= distutils autoplist
-OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
OPTIONS_DEFINE= JSON
JSON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>=3.0:${PORTSDIR}/devel/py-simplejson
diff --git a/security/py-keyring/Makefile b/security/py-keyring/Makefile
index 03c0e98c7711..a02842f859f9 100644
--- a/security/py-keyring/Makefile
+++ b/security/py-keyring/Makefile
@@ -15,8 +15,6 @@ LICENSE= PSFL
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:${PORTSDIR}/devel/py-pytest-runner
-LATEST_LINK= py-${PORTNAME}
-
USES= python zip
USE_PYTHON= distutils autoplist
diff --git a/security/rubygem-net-ssh/Makefile b/security/rubygem-net-ssh/Makefile
index d5de98a302a5..099cb74b279d 100644
--- a/security/rubygem-net-ssh/Makefile
+++ b/security/rubygem-net-ssh/Makefile
@@ -15,7 +15,6 @@ LICENSE= MIT
OPTIONS_DEFINE= PROMPT_PASSPHRASES
OPTIONS_DEFAULT=PROMPT_PASSPHRASES
-OPTIONSFILE?= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
PROMPT_PASSPHRASES_DESC= Prompt for passphrases on keys
PORTSCOUT= skipv:2.10.0
diff --git a/security/shibboleth2-sp/Makefile b/security/shibboleth2-sp/Makefile
index 1db80afd9e79..922134bf4a9b 100644
--- a/security/shibboleth2-sp/Makefile
+++ b/security/shibboleth2-sp/Makefile
@@ -19,8 +19,6 @@ MAKE_ENV= NOKEYGEN=YES
USE_LDCONFIG= yes
USE_RC_SUBR= shibboleth-sp
-LATEST_LINK= shibboleth2-sp
-
USERS= shibd
GROUPS= shibd