aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2018-05-02 21:35:18 +0800
committerskreuzer <skreuzer@FreeBSD.org>2018-05-02 21:35:18 +0800
commit9b921430aada737023e16b4beeeef11e13bd131c (patch)
treeb32451e61e68f18e50adc48f0de28af2ce071ac4 /security
parent4c92932a8fe96f987862048203934dd7465c4cba (diff)
downloadfreebsd-ports-gnome-9b921430aada737023e16b4beeeef11e13bd131c.tar.gz
freebsd-ports-gnome-9b921430aada737023e16b4beeeef11e13bd131c.tar.zst
freebsd-ports-gnome-9b921430aada737023e16b4beeeef11e13bd131c.zip
Update to version 1.26
Define LICENSE
Diffstat (limited to 'security')
-rw-r--r--security/p5-Crypt-TEA/Makefile6
-rw-r--r--security/p5-Crypt-TEA/distinfo5
-rw-r--r--security/p5-Crypt-TEA/files/patch-TEA.xs15
3 files changed, 7 insertions, 19 deletions
diff --git a/security/p5-Crypt-TEA/Makefile b/security/p5-Crypt-TEA/Makefile
index d145b76b3e8b..7efce0299f5f 100644
--- a/security/p5-Crypt-TEA/Makefile
+++ b/security/p5-Crypt-TEA/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= Crypt-TEA
-PORTVERSION= 1.25
-PORTREVISION= 1
+PORTVERSION= 1.26
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,6 +10,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl extension to Tiny Encryption Algorithm
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
USES= perl5
USE_PERL5= configure
diff --git a/security/p5-Crypt-TEA/distinfo b/security/p5-Crypt-TEA/distinfo
index 9adca9f2e0e7..f51251812788 100644
--- a/security/p5-Crypt-TEA/distinfo
+++ b/security/p5-Crypt-TEA/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Crypt-TEA-1.25.tar.gz) = fb89a96a160bcf6fe489a4624b52476ede0c10188a22ad746309c1607ba9dbd3
-SIZE (Crypt-TEA-1.25.tar.gz) = 7786
+TIMESTAMP = 1525266951
+SHA256 (Crypt-TEA-1.26.tar.gz) = 771b3e0202126789e5b2d5b98814d03671c2b88cfe89041ba2a48a24da6fa5a5
+SIZE (Crypt-TEA-1.26.tar.gz) = 8325
diff --git a/security/p5-Crypt-TEA/files/patch-TEA.xs b/security/p5-Crypt-TEA/files/patch-TEA.xs
deleted file mode 100644
index a84a24f0c68c..000000000000
--- a/security/p5-Crypt-TEA/files/patch-TEA.xs
+++ /dev/null
@@ -1,15 +0,0 @@
---- TEA.xs.orig 2001-05-21 17:32:59 UTC
-+++ TEA.xs
-@@ -55,9 +55,11 @@ tea_crypt(self, input, output, decrypt)
- output = sv_newmortal();
- outlen = 8;
-
-- if (SvREADONLY(output) || !SvUPGRADE(output, SVt_PV))
-+ if (SvREADONLY(output))
- croak("cannot use output as lvalue");
-
-+ SvUPGRADE(output, SVt_PV);
-+
- tea_crypt(self,
- (unsigned char *)input,
- (unsigned char *)SvGROW(output, outlen),