aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2018-04-16 20:06:03 +0800
committerlev <lev@FreeBSD.org>2018-04-16 20:06:03 +0800
commit9cef60636abcdef3eb67d36ddf8483a4652edaae (patch)
tree65ea828ba951c6aaf0ba88e24aad333b791ff038 /security
parent959ecba6c9eb3cef05b4578c23b5e5b67731060f (diff)
downloadfreebsd-ports-gnome-9cef60636abcdef3eb67d36ddf8483a4652edaae.tar.gz
freebsd-ports-gnome-9cef60636abcdef3eb67d36ddf8483a4652edaae.tar.zst
freebsd-ports-gnome-9cef60636abcdef3eb67d36ddf8483a4652edaae.zip
Update to latest release 1.0.
Reset maintainer to myself (maintainer approved). PR: 227494 Submitted by: lev Approved by: mschout@gkg.net
Diffstat (limited to 'security')
-rw-r--r--security/pam_pwdfile/Makefile15
-rw-r--r--security/pam_pwdfile/distinfo5
-rw-r--r--security/pam_pwdfile/files/patch-bigcrypt.c11
-rw-r--r--security/pam_pwdfile/files/patch-md5.c20
-rw-r--r--security/pam_pwdfile/files/patch-pam_pwdfile.c33
5 files changed, 65 insertions, 19 deletions
diff --git a/security/pam_pwdfile/Makefile b/security/pam_pwdfile/Makefile
index bb2f85e022b8..b2ca087cdaeb 100644
--- a/security/pam_pwdfile/Makefile
+++ b/security/pam_pwdfile/Makefile
@@ -2,25 +2,28 @@
# $FreeBSD$
PORTNAME= pam_pwdfile
-PORTVERSION= 0.99
-PORTREVISION= 1
+PORTVERSION= 1.0
CATEGORIES= security
-MASTER_SITES= http://cpbotha.net/files/pam_pwdfile/
-MAINTAINER= mschout@gkg.net
+MAINTAINER= lev@FreeBSD.org
COMMENT= Pam module for authenticating with flat passwd files
+USE_GITHUB= yes
+GH_ACCOUNT= tiwe-de
+GH_PROJECT= libpam-pwdfile
+GH_TAGNAME= v${PORTVERSION}
+
USES= uidfix
MAKEFILE= ${FILESDIR}/Makefile.bsd
PLIST_FILES= lib/pam_pwdfile.so
-PORTDOCS= README INSTALL changelog
+PORTDOCS= README INSTALL
CFLAGS+= -I${WRKSRC}
OPTIONS_DEFINE= DOCS
post-patch:
- ${REINPLACE_CMD} -e 's|#include <features.h>||g' ${WRKSRC}/pam_pwdfile.c
+# ${REINPLACE_CMD} -e 's|#include <features.h>||g' ${WRKSRC}/pam_pwdfile.c
${CP} ${FILESDIR}/_pam_macros.h ${WRKSRC}
post-install:
diff --git a/security/pam_pwdfile/distinfo b/security/pam_pwdfile/distinfo
index 9e39e6e5a86f..98c12b615610 100644
--- a/security/pam_pwdfile/distinfo
+++ b/security/pam_pwdfile/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pam_pwdfile-0.99.tar.gz) = 973420f203976ac98508bb253b33a23d189cfbaf72143670964470e84085688e
-SIZE (pam_pwdfile-0.99.tar.gz) = 16994
+TIMESTAMP = 1523618004
+SHA256 (tiwe-de-libpam-pwdfile-1.0-v1.0_GH0.tar.gz) = 5b8db1397cff9cadfd1bb96f53c134b787ab0e6a0fbedb71040541d340313ba2
+SIZE (tiwe-de-libpam-pwdfile-1.0-v1.0_GH0.tar.gz) = 13418
diff --git a/security/pam_pwdfile/files/patch-bigcrypt.c b/security/pam_pwdfile/files/patch-bigcrypt.c
deleted file mode 100644
index c609f8988173..000000000000
--- a/security/pam_pwdfile/files/patch-bigcrypt.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- bigcrypt.c.orig 2009-09-04 18:37:28.000000000 -0500
-+++ bigcrypt.c 2009-09-04 18:37:30.000000000 -0500
-@@ -25,7 +25,7 @@
- */
-
- #include <string.h>
--#include <security/_pam_macros.h>
-+#include "_pam_macros.h"
-
- char *crypt(const char *key, const char *salt);
- char *bigcrypt(const char *key, const char *salt);
diff --git a/security/pam_pwdfile/files/patch-md5.c b/security/pam_pwdfile/files/patch-md5.c
new file mode 100644
index 000000000000..91fd576ad619
--- /dev/null
+++ b/security/pam_pwdfile/files/patch-md5.c
@@ -0,0 +1,20 @@
+--- md5.c.orig 2018-04-13 14:15:16.302782000 +0300
++++ md5.c 2018-04-13 14:25:07.662155000 +0300
+@@ -17,7 +17,7 @@
+ */
+
+ #include <string.h>
+-#include <byteswap.h>
++#include <sys/endian.h>
+ #include "md5.h"
+
+ #ifndef HIGHFIRST
+@@ -25,7 +25,7 @@
+ #else
+ static void byteReverse(unsigned char *buf, unsigned longs) {
+ for (; longs; --longs, buf +=4)
+- *((uint32_t *) buf) = bswap_32(*((uint32_t *) buf));
++ *((uint32_t *) buf) = bswap32(*((uint32_t *) buf));
+ }
+ #endif
+
diff --git a/security/pam_pwdfile/files/patch-pam_pwdfile.c b/security/pam_pwdfile/files/patch-pam_pwdfile.c
new file mode 100644
index 000000000000..911ea6fa4992
--- /dev/null
+++ b/security/pam_pwdfile/files/patch-pam_pwdfile.c
@@ -0,0 +1,33 @@
+--- pam_pwdfile.c.orig 2018-04-13 14:25:49.414568000 +0300
++++ pam_pwdfile.c 2018-04-13 14:42:33.040919000 +0300
+@@ -38,18 +38,7 @@
+ * OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#ifdef USE_CRYPT_R
+-#define _GNU_SOURCE
+-#include <crypt.h>
+-#else
+-#ifndef _XOPEN_SOURCE
+-#define _XOPEN_SOURCE 700
+-#endif
+-#ifndef _BSD_SOURCE
+-#define _BSD_SOURCE
+-#endif
+-#endif
+-
++#include <stdint.h>
+ #include <syslog.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -66,7 +55,9 @@
+
+ #define PAM_SM_AUTH
+ #include <security/pam_modules.h>
+-#include <security/pam_ext.h>
++/* #include <security/pam_ext.h> */
++
++#define pam_syslog(H, C, ...) syslog(C, __VA_ARGS__)
+
+ #include "md5.h"
+ #include "bigcrypt.h"