aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-03-15 01:35:44 +0800
committeryuri <yuri@FreeBSD.org>2018-03-15 01:35:44 +0800
commita02446cd4f8ebc2e2836425896342fdc791e1680 (patch)
treec796edf9ac142cb170dcc62dfbf1bcb5e6cad206 /security
parent5641eeb009eb717ae1ace58dec3a5545eb7deb1f (diff)
downloadfreebsd-ports-gnome-a02446cd4f8ebc2e2836425896342fdc791e1680.tar.gz
freebsd-ports-gnome-a02446cd4f8ebc2e2836425896342fdc791e1680.tar.zst
freebsd-ports-gnome-a02446cd4f8ebc2e2836425896342fdc791e1680.zip
security/2fa: Unbreak by adding GOCACHE=off
Using ${MAKE_ENV} helped many other Go ports, but not this one. Now added GOCACHE=off that turns the cache off. Approved by: portmgr (port compliance, infrastructure)
Diffstat (limited to 'security')
-rw-r--r--security/2fa/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/2fa/Makefile b/security/2fa/Makefile
index 8346462b39a8..5705a4df154a 100644
--- a/security/2fa/Makefile
+++ b/security/2fa/Makefile
@@ -23,10 +23,10 @@ PLIST_FILES= bin/2fa
PORTDOCS= README.md
do-build:
- @cd ${WRKSRC}/${GH_SUBDIR} && ${SETENV} GOPATH=${WRKSRC} go build -o ${PORTNAME}
+ @cd ${WRKSRC}/${GH_SUBDIR} && ${SETENV} ${MAKE_ENV} GOCACHE=off GOPATH=${WRKSRC} go build -o ${PORTNAME}
do-test:
- @cd ${WRKSRC}/${GH_SUBDIR} && ${SETENV} GOPATH=${WRKSRC} go test
+ @cd ${WRKSRC}/${GH_SUBDIR} && ${SETENV} ${MAKE_ENV} GOCACHE=off GOPATH=${WRKSRC} go test
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin