aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-19 05:56:07 +0800
committererwin <erwin@FreeBSD.org>2005-12-19 05:56:07 +0800
commita18d10c721beb5484fb2d8541df97ab4655f07b7 (patch)
tree27d47899a5bc17f29a0e1fdfc5262b7339414113 /security
parent7374dffbf4b6a4910b8f0968b65b60324e9dbbe9 (diff)
downloadfreebsd-ports-gnome-a18d10c721beb5484fb2d8541df97ab4655f07b7.tar.gz
freebsd-ports-gnome-a18d10c721beb5484fb2d8541df97ab4655f07b7.tar.zst
freebsd-ports-gnome-a18d10c721beb5484fb2d8541df97ab4655f07b7.zip
Crypt::Caesar - Decrypt rot-N strings
WWW: http://search.cpan.org/dist/Caesar PR: ports/90612 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Caesar/Makefile24
-rw-r--r--security/p5-Crypt-Caesar/distinfo3
-rw-r--r--security/p5-Crypt-Caesar/pkg-descr3
-rw-r--r--security/p5-Crypt-Caesar/pkg-plist5
5 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 158d1d6774db..ecb4add9a8a6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -289,6 +289,7 @@
SUBDIR += p5-Crypt-CBC
SUBDIR += p5-Crypt-CBCeasy
SUBDIR += p5-Crypt-CFB
+ SUBDIR += p5-Crypt-Caesar
SUBDIR += p5-Crypt-CipherSaber
SUBDIR += p5-Crypt-Cracklib
SUBDIR += p5-Crypt-Cryptix
diff --git a/security/p5-Crypt-Caesar/Makefile b/security/p5-Crypt-Caesar/Makefile
new file mode 100644
index 000000000000..b313821e23cd
--- /dev/null
+++ b/security/p5-Crypt-Caesar/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-Caesar
+# Date created: 18 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-Caesar
+PORTVERSION= 0.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for decrypting rot-N strings
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Caesar.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Caesar/distinfo b/security/p5-Crypt-Caesar/distinfo
new file mode 100644
index 000000000000..200ecf5e1491
--- /dev/null
+++ b/security/p5-Crypt-Caesar/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Caesar-0.01.tar.gz) = f0a7773261b15920312d763a31c630d7
+SHA256 (Crypt-Caesar-0.01.tar.gz) = 010735fbcc572292e66b72a547de74317f659935a75aaf198e3df612e45a7d0f
+SIZE (Crypt-Caesar-0.01.tar.gz) = 1974
diff --git a/security/p5-Crypt-Caesar/pkg-descr b/security/p5-Crypt-Caesar/pkg-descr
new file mode 100644
index 000000000000..5aa5caf611a9
--- /dev/null
+++ b/security/p5-Crypt-Caesar/pkg-descr
@@ -0,0 +1,3 @@
+Crypt::Caesar - Decrypt rot-N strings
+
+WWW: http://search.cpan.org/dist/Caesar
diff --git a/security/p5-Crypt-Caesar/pkg-plist b/security/p5-Crypt-Caesar/pkg-plist
new file mode 100644
index 000000000000..47c3a559bd07
--- /dev/null
+++ b/security/p5-Crypt-Caesar/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/Caesar.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Caesar/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Caesar/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true