aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-09-11 04:26:36 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-09-11 04:26:36 +0800
commitb3e760a64ec50a91fbeb9ae834578f068c39c489 (patch)
treea9be033a0b0d6ce71f79f594de09451d2b03fadb /security
parent9f61b34dbf412ab81ac25968fd6b66c09e5e9dde (diff)
downloadfreebsd-ports-gnome-b3e760a64ec50a91fbeb9ae834578f068c39c489.tar.gz
freebsd-ports-gnome-b3e760a64ec50a91fbeb9ae834578f068c39c489.tar.zst
freebsd-ports-gnome-b3e760a64ec50a91fbeb9ae834578f068c39c489.zip
Add py-google-auth-httplib2 0.0.3
This library provides an httplib2 transport for google-auth. WWW: https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-google-auth-httplib2/Makefile24
-rw-r--r--security/py-google-auth-httplib2/distinfo3
-rw-r--r--security/py-google-auth-httplib2/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4fc5a203b11f..4930e1021c3b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -953,6 +953,7 @@
SUBDIR += py-gnupg
SUBDIR += py-gnutls
SUBDIR += py-google-auth
+ SUBDIR += py-google-auth-httplib2
SUBDIR += py-gpgme
SUBDIR += py-gpsoauth
SUBDIR += py-gssapi
diff --git a/security/py-google-auth-httplib2/Makefile b/security/py-google-auth-httplib2/Makefile
new file mode 100644
index 000000000000..4cb4d6236d07
--- /dev/null
+++ b/security/py-google-auth-httplib2/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= google-auth-httplib2
+PORTVERSION= 0.0.3
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Google Authentication Library: httplib2 transport
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-auth>=0:security/py-google-auth@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httplib2>=0.9.1:www/py-httplib2@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-google-auth-httplib2/distinfo b/security/py-google-auth-httplib2/distinfo
new file mode 100644
index 000000000000..c8247f42ef48
--- /dev/null
+++ b/security/py-google-auth-httplib2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536608059
+SHA256 (google-auth-httplib2-0.0.3.tar.gz) = 098fade613c25b4527b2c08fa42d11f3c2037dda8995d86de0745228e965d445
+SIZE (google-auth-httplib2-0.0.3.tar.gz) = 9957
diff --git a/security/py-google-auth-httplib2/pkg-descr b/security/py-google-auth-httplib2/pkg-descr
new file mode 100644
index 000000000000..587ee3c54c19
--- /dev/null
+++ b/security/py-google-auth-httplib2/pkg-descr
@@ -0,0 +1,3 @@
+This library provides an httplib2 transport for google-auth.
+
+WWW: https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2