aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2017-07-19 13:40:13 +0800
committeracm <acm@FreeBSD.org>2017-07-19 13:40:13 +0800
commitb7dd61ca35603d5c6049ec1bcd82d01a744e7184 (patch)
treefad8040526c7e30a06c5f26dbe19e4f5909d13e8 /security
parent4065f8f7b67e5df5bf413ab51113abab77d58cee (diff)
downloadfreebsd-ports-gnome-b7dd61ca35603d5c6049ec1bcd82d01a744e7184.tar.gz
freebsd-ports-gnome-b7dd61ca35603d5c6049ec1bcd82d01a744e7184.tar.zst
freebsd-ports-gnome-b7dd61ca35603d5c6049ec1bcd82d01a744e7184.zip
- New port: security/veracrypt
VeraCrypt is a free open source disk encryption software for Windows, Mac OSX, FreeBSD and Linux. Brought to you by IDRIX (https://www.idrix.fr) and based on TrueCrypt 7.1a. VeraCrypt main features: - Creates a virtual encrypted disk within a file and mounts it as a real disk. - Encrypts an entire partition or storage device such as USB flash drive or hard drive. - Encrypts a partition or drive where Windows is installed (pre-boot authentication). - Encryption is automatic, real-time(on-the-fly) and transparent. - Parallelization and pipelining allow data to be read and written as fast as if the drive was not encrypted. - Encryption can be hardware-accelerated on modern processors. - Provides plausible deniability, in case an adversary forces you to reveal the password: Hidden volume (steganography) and hidden operating system. - More information about the features of VeraCrypt may be found in the documentation WWW: http://www.veracrypt.fr
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/veracrypt/Makefile42
-rw-r--r--security/veracrypt/distinfo3
-rw-r--r--security/veracrypt/files/pkg-message.in18
-rw-r--r--security/veracrypt/pkg-descr21
-rw-r--r--security/veracrypt/pkg-plist166
6 files changed, 251 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 0abb253f1e62..f937320e1e1d 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1209,6 +1209,7 @@
SUBDIR += unicornscan
SUBDIR += unssh
SUBDIR += vault
+ SUBDIR += veracrypt
SUBDIR += vinetto
SUBDIR += vlock
SUBDIR += vm-to-tor
diff --git a/security/veracrypt/Makefile b/security/veracrypt/Makefile
new file mode 100644
index 000000000000..378d74cbfcc5
--- /dev/null
+++ b/security/veracrypt/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= veracrypt
+PORTVERSION= 1.21
+CATEGORIES= security
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME:S/v/V/:S/c/C/}%20${PORTVERSION}/
+DISTNAME= ${PORTNAME:S/v/V/:S/c/C/}_${PORTVERSION}_Source
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Open-source disk encryption software based on Truecrypt
+
+LICENSE_FILE= ${DOCSDIR}/LICENSE
+
+BUILD_DEPENDS= yasm:devel/yasm
+RUN_DEPENDS= ${LOCALBASE}/bin/sudo:security/sudo
+
+USES= desktop-file-utils fuse gmake iconv pkgconfig tar:bz2
+USE_WX= 3.0+
+NO_WRKSUBDIR= yes
+BUILD_WRKSRC= ${WRKSRC}/src
+ALL_TARGET= #
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|g' ${WRKSRC}/src/Makefile
+ ${REINPLACE_CMD} -e 's|/usr/bin|${PREFIX}/bin|g' -e \
+ 's|Icon=veracrypt|Icon=VeraCrypt-16x16|g' ${WRKSRC}/src/Setup/FreeBSD/veracrypt.desktop
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/Main/veracrypt ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/src/Setup/FreeBSD/veracrypt.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ cd ${WRKSRC}/src/Resources/Icons && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/pixmaps "-name *\.xpm"
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/License.txt ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/html
+
+.include <bsd.port.mk>
diff --git a/security/veracrypt/distinfo b/security/veracrypt/distinfo
new file mode 100644
index 000000000000..1fe1982a1987
--- /dev/null
+++ b/security/veracrypt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1500244540
+SHA256 (VeraCrypt_1.21_Source.tar.bz2) = 44717d24b8deff2db9dd0365572063e38bbe4a59438a8c3c07675b5eed370358
+SIZE (VeraCrypt_1.21_Source.tar.bz2) = 22841960
diff --git a/security/veracrypt/files/pkg-message.in b/security/veracrypt/files/pkg-message.in
new file mode 100644
index 000000000000..e801c11fa125
--- /dev/null
+++ b/security/veracrypt/files/pkg-message.in
@@ -0,0 +1,18 @@
+###############################################################################
+
+Veracrypt was installed
+
+1) Veracrypt needs security/sudo port to mount disk volumes. You must modify
+ %%PREFIX%%/etc/sudoers file to add Veracrypt user(s). Don't use root user
+
+2) Please ensure that the fusefs kmod is loaded prior to use:
+
+$ kldload fuse
+
+If you want load fuse.ko on boot time, please add the following to /boot/loader.conf
+
+fuse_load="YES"
+
+3) Enjoy it
+
+###############################################################################
diff --git a/security/veracrypt/pkg-descr b/security/veracrypt/pkg-descr
new file mode 100644
index 000000000000..7bd8566d59df
--- /dev/null
+++ b/security/veracrypt/pkg-descr
@@ -0,0 +1,21 @@
+VeraCrypt is a free open source disk encryption software for Windows, Mac OSX,
+FreeBSD and Linux. Brought to you by IDRIX (https://www.idrix.fr) and based on
+TrueCrypt 7.1a.
+
+VeraCrypt main features:
+
+- Creates a virtual encrypted disk within a file and mounts it as a real disk.
+- Encrypts an entire partition or storage device such as USB flash drive or
+ hard drive.
+- Encrypts a partition or drive where Windows is installed (pre-boot
+ authentication).
+- Encryption is automatic, real-time(on-the-fly) and transparent.
+- Parallelization and pipelining allow data to be read and written as fast as
+ if the drive was not encrypted.
+- Encryption can be hardware-accelerated on modern processors.
+- Provides plausible deniability, in case an adversary forces you to reveal the
+ password: Hidden volume (steganography) and hidden operating system.
+- More information about the features of VeraCrypt may be found in the
+ documentation
+
+WWW: http://www.veracrypt.fr
diff --git a/security/veracrypt/pkg-plist b/security/veracrypt/pkg-plist
new file mode 100644
index 000000000000..8e00ca9e045a
--- /dev/null
+++ b/security/veracrypt/pkg-plist
@@ -0,0 +1,166 @@
+bin/veracrypt
+share/applications/veracrypt.desktop
+%%PORTDOCS%%%%DOCSDIR%%/License.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/AES.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Acknowledgements.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Additional Security Requirements and Precautions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Authenticity and Integrity.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Authors.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_001.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_002.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_003.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_004.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_005.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_007.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_008.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_009.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_010.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_011.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_012.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_013.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_014.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_015.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_016.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_017.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_018.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_019.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_020.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_021.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_022.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_023.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_024.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/Beginner's Tutorial_Image_034.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Camellia.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Cascades.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Changing Passwords and Keyfiles.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Choosing Passwords and Keyfiles.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Command Line Usage.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Contact.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Contributed Resources.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Converting TrueCrypt volumes and partitions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Converting TrueCrypt volumes and partitions_truecrypt_convertion.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Creating New Volumes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Data Leaks.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Default Mount Parameters.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Default Mount Parameters_VeraCrypt_password_using_default_parameters.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Defragmenting.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Digital Signatures.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Disclaimers.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Documentation.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Donation.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Donation_VeraCrypt_Bitcoin.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Donation_donate_CHF.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/Donation_donate_Dollars.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/Donation_donate_Euros.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/Donation_donate_GBP.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/Donation_donate_YEN.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/Encryption Algorithms.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Encryption Scheme.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FAQ.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Favorite Volumes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Hardware Acceleration.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Hash Algorithms.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Header Key Derivation.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Hibernation File.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Hidden Operating System.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Hidden Volume.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Home_VeraCrypt_Default_Mount_Parameters.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Home_VeraCrypt_menu_Default_Mount_Parameters.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Home_facebook_veracrypt.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Home_reddit.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Home_tibitDonateButton.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Home_utilities-file-archiver-3.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Hot Keys.html
+%%PORTDOCS%%%%DOCSDIR%%/html/How to Back Up Securely.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Incompatibilities.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Issues and Limitations.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Journaling File Systems.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Keyfiles in VeraCrypt.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Keyfiles in VeraCrypt_Image_040.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/Keyfiles.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Kuznyechik.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Language Packs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Legal Information.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Main Program Window.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Malware.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Memory Dump Files.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Miscellaneous.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Modes of Operation.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Mounting VeraCrypt Volumes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Multi-User Environment.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Notation.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Paging File.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Parallelization.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Personal Iterations Multiplier (PIM).html
+%%PORTDOCS%%%%DOCSDIR%%/html/Personal Iterations Multiplier (PIM)_VeraCrypt_ChangePIM_Step1.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Personal Iterations Multiplier (PIM)_VeraCrypt_ChangePIM_Step2.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Personal Iterations Multiplier (PIM)_VeraCrypt_ChangePIM_System_Step1.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Personal Iterations Multiplier (PIM)_VeraCrypt_ChangePIM_System_Step2.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Personal Iterations Multiplier (PIM)_VeraCrypt_UsePIM_Step1.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Personal Iterations Multiplier (PIM)_VeraCrypt_UsePIM_Step2.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Physical Security.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Pipelining.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Plausible Deniability.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Portable Mode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Preface.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Program Menu.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Protection of Hidden Volumes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Protection of Hidden Volumes_Image_027.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Protection of Hidden Volumes_Image_028.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Protection of Hidden Volumes_Image_029.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Protection of Hidden Volumes_Image_030.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Protection of Hidden Volumes_Image_031.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/RIPEMD-160.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Random Number Generator.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Reallocated Sectors.html
+%%PORTDOCS%%%%DOCSDIR%%/html/References.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Release Notes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Removable Medium Volume.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Removing Encryption.html
+%%PORTDOCS%%%%DOCSDIR%%/html/SHA-256.html
+%%PORTDOCS%%%%DOCSDIR%%/html/SHA-512.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Security Model.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Security Requirements and Precautions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Security Requirements for Hidden Volumes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Security Tokens & Smart Cards.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Serpent.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Sharing over Network.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Source Code.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Standard Compliance.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Streebog.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Supported Operating Systems.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Supported Systems for System Encryption.html
+%%PORTDOCS%%%%DOCSDIR%%/html/System Encryption.html
+%%PORTDOCS%%%%DOCSDIR%%/html/System Favorite Volumes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Technical Details.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Trim Operation.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Troubleshooting.html
+%%PORTDOCS%%%%DOCSDIR%%/html/TrueCrypt Support.html
+%%PORTDOCS%%%%DOCSDIR%%/html/TrueCrypt Support_truecrypt_mode_gui.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Twofish.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Unencrypted Data in RAM.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Uninstalling VeraCrypt.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Using VeraCrypt Without Administrator Privileges.html
+%%PORTDOCS%%%%DOCSDIR%%/html/VeraCrypt Background Task.html
+%%PORTDOCS%%%%DOCSDIR%%/html/VeraCrypt Hidden Operating System.html
+%%PORTDOCS%%%%DOCSDIR%%/html/VeraCrypt License.html
+%%PORTDOCS%%%%DOCSDIR%%/html/VeraCrypt Rescue Disk.html
+%%PORTDOCS%%%%DOCSDIR%%/html/VeraCrypt System Files.html
+%%PORTDOCS%%%%DOCSDIR%%/html/VeraCrypt Volume Format Specification.html
+%%PORTDOCS%%%%DOCSDIR%%/html/VeraCrypt Volume.html
+%%PORTDOCS%%%%DOCSDIR%%/html/VeraCrypt128x128.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Volume Clones.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Wear-Leveling.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Whirlpool.html
+%%PORTDOCS%%%%DOCSDIR%%/html/arrow_right.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/bank_30x30.png
+%%PORTDOCS%%%%DOCSDIR%%/html/flattr-badge-large.png
+%%PORTDOCS%%%%DOCSDIR%%/html/gf2_mul.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/styles.css
+%%PORTDOCS%%%%DOCSDIR%%/html/twitter_veracrypt.PNG
+share/pixmaps/VeraCrypt-128x128.xpm
+share/pixmaps/VeraCrypt-16x16.xpm
+share/pixmaps/VeraCrypt-256x256.xpm
+share/pixmaps/VeraCrypt-48x48.xpm