aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-03-14 23:00:57 +0800
committerijliao <ijliao@FreeBSD.org>2002-03-14 23:00:57 +0800
commitb96beaf5cf2476258f640ef0ee83aa30675f1154 (patch)
tree269811579cc86da43c458a610280556644cdc1d9 /security
parent62087f90e818552e2529bbd9dac12cf8dbcde2a8 (diff)
downloadfreebsd-ports-gnome-b96beaf5cf2476258f640ef0ee83aa30675f1154.tar.gz
freebsd-ports-gnome-b96beaf5cf2476258f640ef0ee83aa30675f1154.tar.zst
freebsd-ports-gnome-b96beaf5cf2476258f640ef0ee83aa30675f1154.zip
add p5-Crypt-DES_EDE3 0.01
Perl5 interface to a implementing 3-DES EDE encryption and decryption PR: 35891 Submitted by: jesper
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-DES_EDE3/Makefile25
-rw-r--r--security/p5-Crypt-DES_EDE3/distinfo1
-rw-r--r--security/p5-Crypt-DES_EDE3/pkg-comment1
-rw-r--r--security/p5-Crypt-DES_EDE3/pkg-descr6
-rw-r--r--security/p5-Crypt-DES_EDE3/pkg-plist1
6 files changed, 35 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c5131fe1442f..83826634cf65 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -126,6 +126,7 @@
SUBDIR += p5-Crypt-Cracklib
SUBDIR += p5-Crypt-Cryptix
SUBDIR += p5-Crypt-DES
+ SUBDIR += p5-Crypt-DES_EDE3
SUBDIR += p5-Crypt-DH
SUBDIR += p5-Crypt-DSA
SUBDIR += p5-Crypt-ECB
diff --git a/security/p5-Crypt-DES_EDE3/Makefile b/security/p5-Crypt-DES_EDE3/Makefile
new file mode 100644
index 000000000000..624cc61dc220
--- /dev/null
+++ b/security/p5-Crypt-DES_EDE3/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Crypt-DES_EDE3
+# Date created: 2002/03/14
+# Whom: jesper
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-DES_EDE3
+PORTVERSION= 0.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jesper@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Crypt::DES_EDE3.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-DES_EDE3/distinfo b/security/p5-Crypt-DES_EDE3/distinfo
new file mode 100644
index 000000000000..2ca34c69b29b
--- /dev/null
+++ b/security/p5-Crypt-DES_EDE3/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-DES_EDE3-0.01.tar.gz) = fde1995efa0735407a5f7c4a4c8147bc
diff --git a/security/p5-Crypt-DES_EDE3/pkg-comment b/security/p5-Crypt-DES_EDE3/pkg-comment
new file mode 100644
index 000000000000..37f565322504
--- /dev/null
+++ b/security/p5-Crypt-DES_EDE3/pkg-comment
@@ -0,0 +1 @@
+Perl5 interface to a implementing 3-DES EDE encryption and decryption
diff --git a/security/p5-Crypt-DES_EDE3/pkg-descr b/security/p5-Crypt-DES_EDE3/pkg-descr
new file mode 100644
index 000000000000..a64bda3ccc89
--- /dev/null
+++ b/security/p5-Crypt-DES_EDE3/pkg-descr
@@ -0,0 +1,6 @@
+Crypt::DES_EDE3 implements DES-EDE3 encryption. This is triple-DES
+encryption where an encrypt operation is encrypt-decrypt-encrypt, and
+decrypt is decrypt-encrypt-decrypt. This implementation uses Crypt::DES
+to do its dirty DES work, and simply provides a wrapper around that
+module: setting up the individual DES ciphers, initializing the keys,
+and performing the encryption/decryption steps
diff --git a/security/p5-Crypt-DES_EDE3/pkg-plist b/security/p5-Crypt-DES_EDE3/pkg-plist
new file mode 100644
index 000000000000..79686ec84530
--- /dev/null
+++ b/security/p5-Crypt-DES_EDE3/pkg-plist
@@ -0,0 +1 @@
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/DES_EDE3.pm