aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-06 04:19:04 +0800
committertijl <tijl@FreeBSD.org>2014-09-06 04:19:04 +0800
commitd6ffd3401b4cd60286128fb12188e4a5033bab5a (patch)
treeea15ab5b3e2280f7e186e57146c80b654f7b0c04 /security
parentd7441e1548c6f85e0e7dd46c9b17a5e67908270e (diff)
downloadfreebsd-ports-gnome-d6ffd3401b4cd60286128fb12188e4a5033bab5a.tar.gz
freebsd-ports-gnome-d6ffd3401b4cd60286128fb12188e4a5033bab5a.tar.zst
freebsd-ports-gnome-d6ffd3401b4cd60286128fb12188e4a5033bab5a.zip
security/cracklib:
- Add USES=libtool and bump dependent ports - Add INSTALL_TARGET=install-strip - Convert to USES=python - Use MAKE_CMD - Create manpage link in post-install instead of using @exec
Diffstat (limited to 'security')
-rw-r--r--security/apg/Makefile2
-rw-r--r--security/cracklib/Makefile22
-rw-r--r--security/libpwquality/Makefile1
-rw-r--r--security/p5-Crypt-Cracklib/Makefile2
-rw-r--r--security/pecl-crack/Makefile2
-rw-r--r--security/py-cracklib/Makefile1
-rw-r--r--security/revelation/Makefile2
-rw-r--r--security/ruby-password/Makefile2
8 files changed, 17 insertions, 17 deletions
diff --git a/security/apg/Makefile b/security/apg/Makefile
index 38b11cc70aa4..bac5109162a3 100644
--- a/security/apg/Makefile
+++ b/security/apg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apg
PORTVERSION= 2.3.0b
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://www.adel.nursat.kz/apg/download/
MASTER_SITE_SUBDIR= UNIX/misc
diff --git a/security/cracklib/Makefile b/security/cracklib/Makefile
index 47b1b90a185e..692b43260155 100644
--- a/security/cracklib/Makefile
+++ b/security/cracklib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cracklib
PORTVERSION= 2.9.0
+PORTREVISION= 1
CATEGORIES= security
.if defined(PYTHON_SLAVEPORT)
CATEGORIES+= python
@@ -18,15 +19,15 @@ LICENSE= LGPL21
DICTPATH= ${PREFIX}/libdata/${PORTNAME}
DICTFILE= ${DICTPATH}/pw_dict
GNU_CONFIGURE= yes
-CONFIGURE_ARGS=--with-default-dict=${DICTPATH}
+CONFIGURE_ARGS= --with-default-dict=${DICTPATH}
+INSTALL_TARGET= install-strip
+USES= gettext libtool
USE_LDCONFIG= yes
-USES= gettext
.if defined(PYTHON_SLAVEPORT)
-USE_PYTHON= yes
+USES+= python
CONFIGURE_ARGS+=--with-python
PLIST_FILES= %%PYTHON_SITELIBDIR%%/_cracklib.a \
- %%PYTHON_SITELIBDIR%%/_cracklib.la \
%%PYTHON_SITELIBDIR%%/_cracklib.so \
%%PYTHON_SITELIBDIR%%/cracklib.py \
%%PYTHON_SITELIBDIR%%/cracklib.pyc \
@@ -52,12 +53,14 @@ PLIST_DIRS= libdata/cracklib \
PLIST_FILES= include/crack.h \
include/packer.h \
lib/libcrack.a \
- lib/libcrack.la \
lib/libcrack.so \
- lib/libcrack.so.11 \
+ lib/libcrack.so.2 \
+ lib/libcrack.so.2.9.0 \
libdata/cracklib/pw_dict.hwm \
libdata/cracklib/pw_dict.pwd \
libdata/cracklib/pw_dict.pwi \
+ man/man3/FascistCheck.3.gz \
+ man/man3/cracklib.3.gz \
sbin/cracklib-check \
sbin/cracklib-format \
sbin/cracklib-packer \
@@ -104,19 +107,16 @@ PLIST_FILES= include/crack.h \
.if defined(PYTHON_SLAVEPORT)
pre-build:
- cd ${WRKSRC}/lib && ${MAKE} libcrack.la
+ cd ${WRKSRC}/lib && ${MAKE_CMD} libcrack.la
regression-test: extract
@(cd ${BUILD_WKRSRC}; \
${PYTHON_CMD} -c \
"from test_${PORTNAME} import run; run(use_dictpath=\"${DICTFILE}\")")
.else
-PLIST_FILES+= man/man3/${PORTNAME}.3.gz \
- @exec\ ln\ -s\ man/man3/${PORTNAME}.3.gz\ man/man3/FascistCheck.3.gz \
- @unexec\ rm\ man/man3/FascistCheck.3.gz
-
post-install:
${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.3 ${STAGEDIR}${MAN3PREFIX}/man/man3/
+ ${LN} -s ${PORTNAME}.3 ${STAGEDIR}${MAN3PREFIX}/man/man3/FascistCheck.3
@${MKDIR} ${STAGEDIR}${DICTPATH}
${INSTALL_DATA} ${FILESDIR}/pw_dict* ${STAGEDIR}${DICTPATH}/
.endif
diff --git a/security/libpwquality/Makefile b/security/libpwquality/Makefile
index 39f0c35fa08c..27a4d606592d 100644
--- a/security/libpwquality/Makefile
+++ b/security/libpwquality/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libpwquality
PORTVERSION= 1.2.4
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://fedorahosted.org/releases/l/i/libpwquality/
diff --git a/security/p5-Crypt-Cracklib/Makefile b/security/p5-Crypt-Cracklib/Makefile
index 26c1ba363e8c..b1765020ef4b 100644
--- a/security/p5-Crypt-Cracklib/Makefile
+++ b/security/p5-Crypt-Cracklib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Crypt-Cracklib
PORTVERSION= 1.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/security/pecl-crack/Makefile b/security/pecl-crack/Makefile
index 1b45e0487f51..0642eb6d4bd6 100644
--- a/security/pecl-crack/Makefile
+++ b/security/pecl-crack/Makefile
@@ -3,7 +3,7 @@
PORTNAME= crack
PORTVERSION= 0.4.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security www
MASTER_SITES= http://www.osuweb.net/~ahaning/
PKGNAMEPREFIX= pecl-
diff --git a/security/py-cracklib/Makefile b/security/py-cracklib/Makefile
index 776a460269e0..2bd53a4d41aa 100644
--- a/security/py-cracklib/Makefile
+++ b/security/py-cracklib/Makefile
@@ -14,7 +14,6 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
PYTHON_SLAVEPORT= yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
"{s#__version__ = '[^']*'#__version__ = '${PORTVERSION}'#;}" \
diff --git a/security/revelation/Makefile b/security/revelation/Makefile
index db9bfc3d5f01..1df303465297 100644
--- a/security/revelation/Makefile
+++ b/security/revelation/Makefile
@@ -3,7 +3,7 @@
PORTNAME= revelation
PORTVERSION= 0.4.14
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security gnome
MASTER_SITES= http://cdn.bitbucket.org/erikg/revelation/downloads/
diff --git a/security/ruby-password/Makefile b/security/ruby-password/Makefile
index 81a78a7ed2b8..cd783200ec9a 100644
--- a/security/ruby-password/Makefile
+++ b/security/ruby-password/Makefile
@@ -3,7 +3,7 @@
PORTNAME= password
PORTVERSION= 0.5.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security ruby
MASTER_SITES= http://www.caliban.org/files/ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}