aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-01-06 19:29:44 +0800
committermandree <mandree@FreeBSD.org>2013-01-06 19:29:44 +0800
commitdb9444f1f6320648faea6485c5df140dc4291fa7 (patch)
treecbf331a58c93ee9d31e8a1ae6b639cf52d766d4b /security
parent8587124364e2be1596b232fc88a7d424922c3528 (diff)
downloadfreebsd-ports-gnome-db9444f1f6320648faea6485c5df140dc4291fa7.tar.gz
freebsd-ports-gnome-db9444f1f6320648faea6485c5df140dc4291fa7.tar.zst
freebsd-ports-gnome-db9444f1f6320648faea6485c5df140dc4291fa7.zip
- Convert to OptionsNG
- Strip Makefile header - Drop LIB_DEPENDS ABI versions
Diffstat (limited to 'security')
-rw-r--r--security/openvpn/Makefile30
-rw-r--r--security/openvpn20/Makefile17
2 files changed, 24 insertions, 23 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index 64446289cd06..516ccf0e902a 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: openvpn
-# Date created: 2002-06-23
-# Whom: Matthias Andree <matthias.andree@gmx.de>
-#
+# Created by: Matthias Andree <matthias.andree@gmx.de>
# $FreeBSD$
-#
PORTNAME= openvpn
DISTVERSION= 2.2.2
@@ -25,7 +21,14 @@ USE_OPENSSL= yes
USE_XZ= yes
CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}/lib \
--with-lzo-headers=${LOCALBASE}/include
-.if !defined(NOPORTDOCS)
+
+OPTIONS_DEFINE= PW_SAVE PKCS11
+PW_SAVE_DESC= Interactive passwords may be read from a file
+PKCS11_DESC= Use security/pkcs11-helper
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
INSTALL_TARGET= install
.else
INSTALL_TARGET= install-exec install-man
@@ -34,9 +37,6 @@ INSTALL_TARGET= install-exec install-man
INSTALL_TARGET+= mandir=${MANPREFIX}/man
MAN8= openvpn.8
-OPTIONS= PW_SAVE "Interactive passwords may be read from a file" off \
- PKCS11 "Use security/pkcs11-helper" off
-
USE_RC_SUBR= openvpn
USE_LDCONFIG= ${PREFIX}/lib
@@ -49,14 +49,16 @@ SUB_LIST+= OSVERSION=${OSVERSION}
CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
.endif
-LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
+LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
-.if defined(WITH_PW_SAVE)
+.if ${PORT_OPTIONS:MPW_SAVE}
CONFIGURE_ARGS+= --enable-password-save
+.else
+CONFIGURE_ARGS+= --disable-password-save
.endif
-.if defined(WITH_PKCS11)
-LIB_DEPENDS+= pkcs11-helper.1:${PORTSDIR}/security/pkcs11-helper
+.if ${PORT_OPTIONS:MPKCS11}
+LIB_DEPENDS+= pkcs11-helper:${PORTSDIR}/security/pkcs11-helper
.else
CONFIGURE_ARGS+= --disable-pkcs11
.endif
@@ -94,7 +96,7 @@ post-install:
${MKDIR} ${PREFIX}/lib
${INSTALL_PROGRAM} ${WRKSRC}/plugin/down-root/openvpn-down-root.so ${PREFIX}/lib/
${INSTALL_PROGRAM} ${WRKSRC}/plugin/auth-pam/openvpn-auth-pam.so ${PREFIX}/lib/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/plugin/down-root/README ${DOCSDIR}/README.openvpn-down-root
${INSTALL_DATA} ${WRKSRC}/plugin/auth-pam/README ${DOCSDIR}/README.openvpn-auth-pam
diff --git a/security/openvpn20/Makefile b/security/openvpn20/Makefile
index a4c39409e007..9a75381a1b8d 100644
--- a/security/openvpn20/Makefile
+++ b/security/openvpn20/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: openvpn
-# Date created: 2002-06-23
-# Whom: Matthias Andree <matthias.andree@gmx.de>
-#
+# Created by: Matthias Andree <matthias.andree@gmx.de>
# $FreeBSD$
-#
PORTNAME= openvpn
PORTVERSION= 2.0.9
@@ -26,12 +22,13 @@ CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}/lib \
MAN8= openvpn.8
-OPTIONS= PW_SAVE "Interactive passwords may be read from a file" off
+OPTIONS_DEFINE= PW_SAVE
+PW_SAVE_DESC= Interactive passwords may be read from a file
USE_RC_SUBR= openvpn
USE_LDCONFIG= ${PREFIX}/lib
-LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
+LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
SUB_FILES= pkg-message
SUB_LIST+= OSVERSION=${OSVERSION}
@@ -58,8 +55,10 @@ pre-fetch:
@${ECHO} ""
.endif
-.if defined(WITH_PW_SAVE)
+.if ${PORT_OPTIONS:MPW_SAVE}
CONFIGURE_ARGS+= --enable-password-save
+.else
+CONFIGURE_ARGS+= --disable-password-save
.endif
post-patch:
@@ -79,7 +78,7 @@ post-install:
${MKDIR} ${PREFIX}/lib
${INSTALL_PROGRAM} ${WRKSRC}/plugin/down-root/openvpn-down-root.so ${PREFIX}/lib
${INSTALL_PROGRAM} ${WRKSRC}/plugin/auth-pam/openvpn-auth-pam.so ${PREFIX}/lib
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/plugin/down-root/README ${DOCSDIR}/README.openvpn-down-root
${INSTALL_DATA} ${WRKSRC}/plugin/auth-pam/README ${DOCSDIR}/README.openvpn-auth-pam