aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-09-19 01:49:31 +0800
committerkris <kris@FreeBSD.org>2004-09-19 01:49:31 +0800
commite6af723b427131278badc3dc020fee3cfef66d18 (patch)
treedc1bf7a770ac357f185dc978d61310d4d01b4bc4 /security
parent8d05912892b859574e72655b0987937be881b688 (diff)
downloadfreebsd-ports-gnome-e6af723b427131278badc3dc020fee3cfef66d18.tar.gz
freebsd-ports-gnome-e6af723b427131278badc3dc020fee3cfef66d18.tar.zst
freebsd-ports-gnome-e6af723b427131278badc3dc020fee3cfef66d18.zip
BROKEN on 5.x: Does not compile
Approved by: portmgr (self)
Diffstat (limited to 'security')
-rw-r--r--security/fwbuilder-devel/Makefile8
-rw-r--r--security/fwbuilder/Makefile8
-rw-r--r--security/fwbuilder2/Makefile8
-rw-r--r--security/hashish/Makefile8
4 files changed, 28 insertions, 4 deletions
diff --git a/security/fwbuilder-devel/Makefile b/security/fwbuilder-devel/Makefile
index 0fc04800c70e..eda41e616c1d 100644
--- a/security/fwbuilder-devel/Makefile
+++ b/security/fwbuilder-devel/Makefile
@@ -32,4 +32,10 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
MAN1= fwbuilder.1 fwblookup.1 fwbedit.1 fwb_ipt.1 fwb_ipf.1 fwb_ipfw.1 fwb_pf.1 \
fwb_install.1 fwb_compile_all.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index 0fc04800c70e..eda41e616c1d 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -32,4 +32,10 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
MAN1= fwbuilder.1 fwblookup.1 fwbedit.1 fwb_ipt.1 fwb_ipf.1 fwb_ipfw.1 fwb_pf.1 \
fwb_install.1 fwb_compile_all.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/fwbuilder2/Makefile b/security/fwbuilder2/Makefile
index 0fc04800c70e..eda41e616c1d 100644
--- a/security/fwbuilder2/Makefile
+++ b/security/fwbuilder2/Makefile
@@ -32,4 +32,10 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
MAN1= fwbuilder.1 fwblookup.1 fwbedit.1 fwb_ipt.1 fwb_ipf.1 fwb_ipfw.1 fwb_pf.1 \
fwb_install.1 fwb_compile_all.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/hashish/Makefile b/security/hashish/Makefile
index cbfeb9de6300..c25e3b0bb1b0 100644
--- a/security/hashish/Makefile
+++ b/security/hashish/Makefile
@@ -35,4 +35,10 @@ CONFIGURE_ENV+= WX_CONFIG="${X11BASE}/bin/wxgtk2-2.4-config"
USE_GMAKE= yes
PLIST_FILES= bin/hashish
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>