aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbrix <brix@FreeBSD.org>2008-06-02 04:58:23 +0800
committerbrix <brix@FreeBSD.org>2008-06-02 04:58:23 +0800
commitf4da2787c9d619443d0f7d9ed4207e559a5558ee (patch)
tree64592ba1c7b263744b0f0cb2c9dad36a6a75c8c5 /security
parent81c90447cc896ef2f2328d8721901a427c453462 (diff)
downloadfreebsd-ports-gnome-f4da2787c9d619443d0f7d9ed4207e559a5558ee.tar.gz
freebsd-ports-gnome-f4da2787c9d619443d0f7d9ed4207e559a5558ee.tar.zst
freebsd-ports-gnome-f4da2787c9d619443d0f7d9ed4207e559a5558ee.zip
Eksblowfish is a variant of the Blowfish cipher, modified to make the
key setup very expensive. ("Eks" stands for "expensive key schedule".) This doesn't make it significantly cryptographically stronger, but is intended to hinder brute-force attacks. It also makes it unsuitable for any application requiring key agility. It was designed by Niels Provos and David Mazieres for password hashing in OpenBSD. Eksblowfish is a parameterised (family-keyed) cipher. It takes a cost parameter that controls how expensive the key scheduling is. It also takes a family key, known as the "salt". Cost and salt parameters together define a cipher family. Within each family, a key determines an encryption function in the usual way. This distribution also includes an implementation of "bcrypt", the Unix crypt() password hashing algorithm based on Eksblowfish. WWW: http://search.cpan.org/dist/Crypt-Eksblowfish/ Approved by: erwin (mentor)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Eksblowfish/Makefile26
-rw-r--r--security/p5-Crypt-Eksblowfish/distinfo3
-rw-r--r--security/p5-Crypt-Eksblowfish/pkg-descr18
-rw-r--r--security/p5-Crypt-Eksblowfish/pkg-plist12
5 files changed, 60 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 098865e5b024..5a61892b2f26 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -379,6 +379,7 @@
SUBDIR += p5-Crypt-DSA
SUBDIR += p5-Crypt-Dining
SUBDIR += p5-Crypt-ECB
+ SUBDIR += p5-Crypt-Eksblowfish
SUBDIR += p5-Crypt-Enigma
SUBDIR += p5-Crypt-GCrypt
SUBDIR += p5-Crypt-GOST
diff --git a/security/p5-Crypt-Eksblowfish/Makefile b/security/p5-Crypt-Eksblowfish/Makefile
new file mode 100644
index 000000000000..db3ca58c2ad2
--- /dev/null
+++ b/security/p5-Crypt-Eksblowfish/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Crypt-Eksblowfish
+# Date created: 01 Jun 2008
+# Whom: brix@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Eksblowfish
+PORTVERSION= 0.005
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= brix@FreeBSD.org
+COMMENT= Perl module for the Eksblowfish block cipher
+
+PERL_MODBUILD= yes
+
+MAN3= Crypt::Eksblowfish.3 \
+ Crypt::Eksblowfish::Bcrypt.3 \
+ Crypt::Eksblowfish::Blowfish.3 \
+ Crypt::Eksblowfish::Family.3 \
+ Crypt::Eksblowfish::Subkeyed.3 \
+ Crypt::Eksblowfish::Uklblowfish.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Eksblowfish/distinfo b/security/p5-Crypt-Eksblowfish/distinfo
new file mode 100644
index 000000000000..021de87d7339
--- /dev/null
+++ b/security/p5-Crypt-Eksblowfish/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Eksblowfish-0.005.tar.gz) = 4cec32e29dc5a8e17f71c2bb93aaace7
+SHA256 (Crypt-Eksblowfish-0.005.tar.gz) = 7ac8cdd3e6a9534d22199261b6c9ea725ce6b0d9256d187b9ffb3a71eb28ddc7
+SIZE (Crypt-Eksblowfish-0.005.tar.gz) = 28303
diff --git a/security/p5-Crypt-Eksblowfish/pkg-descr b/security/p5-Crypt-Eksblowfish/pkg-descr
new file mode 100644
index 000000000000..120bc1d190a0
--- /dev/null
+++ b/security/p5-Crypt-Eksblowfish/pkg-descr
@@ -0,0 +1,18 @@
+Eksblowfish is a variant of the Blowfish cipher, modified to make the
+key setup very expensive. ("Eks" stands for "expensive key
+schedule".) This doesn't make it significantly cryptographically
+stronger, but is intended to hinder brute-force attacks. It also
+makes it unsuitable for any application requiring key agility. It was
+designed by Niels Provos and David Mazieres for password hashing in
+OpenBSD.
+
+Eksblowfish is a parameterised (family-keyed) cipher. It takes a cost
+parameter that controls how expensive the key scheduling is. It also
+takes a family key, known as the "salt". Cost and salt parameters
+together define a cipher family. Within each family, a key determines
+an encryption function in the usual way.
+
+This distribution also includes an implementation of "bcrypt", the
+Unix crypt() password hashing algorithm based on Eksblowfish.
+
+WWW: http://search.cpan.org/dist/Crypt-Eksblowfish/
diff --git a/security/p5-Crypt-Eksblowfish/pkg-plist b/security/p5-Crypt-Eksblowfish/pkg-plist
new file mode 100644
index 000000000000..6f57cd5c3b86
--- /dev/null
+++ b/security/p5-Crypt-Eksblowfish/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Eksblowfish.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Eksblowfish/Bcrypt.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Eksblowfish/Blowfish.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Eksblowfish/Family.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Eksblowfish/Subkeyed.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Eksblowfish/Uklblowfish.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Eksblowfish/Eksblowfish.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Eksblowfish/Eksblowfish.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Eksblowfish
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Eksblowfish
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt