aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2018-04-30 23:43:16 +0800
committerbrnrd <brnrd@FreeBSD.org>2018-04-30 23:43:16 +0800
commitfe5c46db75942ab2e63bc49f640f3e4bca18df9e (patch)
treebabc5affd1400420cab4e30d65d24593459e81f9 /security
parentb54bc795c13c57c6a297006a7d02c309670ca265 (diff)
downloadfreebsd-ports-gnome-fe5c46db75942ab2e63bc49f640f3e4bca18df9e.tar.gz
freebsd-ports-gnome-fe5c46db75942ab2e63bc49f640f3e4bca18df9e.tar.zst
freebsd-ports-gnome-fe5c46db75942ab2e63bc49f640f3e4bca18df9e.zip
www/nextcloud: PHP-flavorize
- Create flavors for all PHP versions - Use releases dir (not pre-) PR: 227510 Approved by: mat Differential Revision: https://reviews.freebsd.org/D15235
Diffstat (limited to 'security')
-rw-r--r--security/nextcloud-passman/Makefile5
-rw-r--r--security/nextcloud-twofactor_totp/Makefile5
-rw-r--r--security/nextcloud-twofactor_u2f/Makefile5
3 files changed, 9 insertions, 6 deletions
diff --git a/security/nextcloud-passman/Makefile b/security/nextcloud-passman/Makefile
index 082f0a796d7f..c5afbe015874 100644
--- a/security/nextcloud-passman/Makefile
+++ b/security/nextcloud-passman/Makefile
@@ -7,6 +7,7 @@ PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://releases.passman.cc/
PKGNAMEPREFIX= nextcloud-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= brnrd@freebsd.org
@@ -15,11 +16,11 @@ COMMENT= Full featured password manager for Nextcloud
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= nextcloud>=9:www/nextcloud
+RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=9:www/nextcloud@${PHP_FLAVOR}
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= php
+USES= php:flavors
NO_BUILD= yes
NO_ARCH= yes
diff --git a/security/nextcloud-twofactor_totp/Makefile b/security/nextcloud-twofactor_totp/Makefile
index 30ad80acead0..9b9e739de3de 100644
--- a/security/nextcloud-twofactor_totp/Makefile
+++ b/security/nextcloud-twofactor_totp/Makefile
@@ -7,6 +7,7 @@ PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://github.com/${PKGNAMEPREFIX:S/-//}/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
PKGNAMEPREFIX= nextcloud-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
DISTNAME= ${PORTNAME}
DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}/${DISTNAME}-${DISTVERSIONPREFIX}${PORTVERSION}
@@ -16,9 +17,9 @@ COMMENT= TOTP multi-factor auth app for Nextcloud
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= nextcloud>=13:www/nextcloud
+RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=13:www/nextcloud@${PHP_FLAVOR}
-USES= php
+USES= php:flavors
NO_BUILD= yes
NO_ARCH= yes
diff --git a/security/nextcloud-twofactor_u2f/Makefile b/security/nextcloud-twofactor_u2f/Makefile
index dbc60e33808d..771d447c5583 100644
--- a/security/nextcloud-twofactor_u2f/Makefile
+++ b/security/nextcloud-twofactor_u2f/Makefile
@@ -7,6 +7,7 @@ PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://github.com/${PKGNAMEPREFIX:S/-//}/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
PKGNAMEPREFIX= nextcloud-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
DISTNAME= ${PORTNAME}
DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}/${DISTNAME}-${DISTVERSIONPREFIX}${PORTVERSION}
@@ -16,9 +17,9 @@ COMMENT= U2F multi-factor auth app for Nextcloud
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= nextcloud>=13.0.1:www/nextcloud
+RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=13.0.1:www/nextcloud@${PHP_FLAVOR}
-USES= php
+USES= php:flavors
NO_BUILD= yes
NO_ARCH= yes