aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-09-08 19:33:55 +0800
committertobik <tobik@FreeBSD.org>2018-09-08 19:33:55 +0800
commit5030a53256d379e6d6b2d3e6bd6f1a87bbd039b5 (patch)
treed2a2862e284f577e816f39ab4d7c82037e7bada8 /security
parent4c42dbce30d53d46d58e2a2ba2d90aba3d1dfb56 (diff)
downloadfreebsd-ports-gnome-5030a53256d379e6d6b2d3e6bd6f1a87bbd039b5.tar.gz
freebsd-ports-gnome-5030a53256d379e6d6b2d3e6bd6f1a87bbd039b5.tar.zst
freebsd-ports-gnome-5030a53256d379e6d6b2d3e6bd6f1a87bbd039b5.zip
security/testssl.sh: Update to 3.0rc1
Diffstat (limited to 'security')
-rw-r--r--security/testssl.sh/Makefile3
-rw-r--r--security/testssl.sh/distinfo6
-rw-r--r--security/testssl.sh/files/patch-testssl.sh12
-rw-r--r--security/testssl.sh/pkg-plist10
4 files changed, 15 insertions, 16 deletions
diff --git a/security/testssl.sh/Makefile b/security/testssl.sh/Makefile
index a25ccffa44d6..5996799e3a77 100644
--- a/security/testssl.sh/Makefile
+++ b/security/testssl.sh/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= testssl.sh
-DISTVERSIONPREFIX= v
-DISTVERSION= 2.9.5-5
+DISTVERSION= 3.0rc1
CATEGORIES= security
MAINTAINER= tobik@FreeBSD.org
diff --git a/security/testssl.sh/distinfo b/security/testssl.sh/distinfo
index ea3d466f55ab..624cc7a3f709 100644
--- a/security/testssl.sh/distinfo
+++ b/security/testssl.sh/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1523782340
-SHA256 (drwetter-testssl.sh-v2.9.5-5_GH0.tar.gz) = 836a7b45455c95f17c4d7eec9468028a7fc6b613fd4b3c8e8e125b7b8206b89d
-SIZE (drwetter-testssl.sh-v2.9.5-5_GH0.tar.gz) = 8955523
+TIMESTAMP = 1536404389
+SHA256 (drwetter-testssl.sh-3.0rc1_GH0.tar.gz) = 3991f8e3a94dbc75a2e4beaf98ed8dbccade33bfb0b5b75aa0c8a1ec06edef82
+SIZE (drwetter-testssl.sh-3.0rc1_GH0.tar.gz) = 9011839
diff --git a/security/testssl.sh/files/patch-testssl.sh b/security/testssl.sh/files/patch-testssl.sh
index f22cbcc0ea7f..800c59ddbeb4 100644
--- a/security/testssl.sh/files/patch-testssl.sh
+++ b/security/testssl.sh/files/patch-testssl.sh
@@ -1,12 +1,12 @@
---- testssl.sh.orig 2018-03-17 15:02:25 UTC
+--- testssl.sh.orig 2018-09-08 11:00:02 UTC
+++ testssl.sh
-@@ -175,6 +175,9 @@ TERM_CURRPOS=0
- ## CONFIGURATION PART ##
- # following variables make use of $ENV, e.g. OPENSSL=<myprivate_path_to_openssl> ./testssl.sh <host>
- # 0 means (normally) true here. Some of the variables are also accessible with a command line switch, see --help
+@@ -188,6 +188,9 @@ TERM_CURRPOS=0
+ ########### Defining (and presetting) variables which can be changed
+ #
+ # Following variables make use of $ENV and can be used like "OPENSSL=<myprivate_path_to_openssl> ./testssl.sh <URI>"
+if [[ -z "$OPENSSL" ]] ; then
+ OPENSSL=PREFIX/openssl-unsafe/bin/openssl
+fi
declare -x OPENSSL OPENSSL_TIMEOUT
+ PHONE_OUT=${PHONE_OUT:-false} # Whether testssl can retrieve CRLs and OCSP
FAST_SOCKET=${FAST_SOCKET:-false} # EXPERIMENTAL feature to accelerate sockets -- DO NOT USE it for production
- COLOR=${COLOR:-2} # 2: Full color, 1: b/w+positioning, 0: no ESC at all
diff --git a/security/testssl.sh/pkg-plist b/security/testssl.sh/pkg-plist
index 8b110de46c9c..08760fb0c2be 100644
--- a/security/testssl.sh/pkg-plist
+++ b/security/testssl.sh/pkg-plist
@@ -1,16 +1,15 @@
bin/testssl.sh
man/man1/testssl.1.gz
%%DATADIR%%/etc/Apple.pem
+%%DATADIR%%/etc/Linux.pem
+%%DATADIR%%/etc/Microsoft.pem
+%%DATADIR%%/etc/Mozilla.pem
+%%DATADIR%%/etc/README.md
%%DATADIR%%/etc/ca_hashes.txt
%%DATADIR%%/etc/cipher-mapping.txt
-%%DATADIR%%/etc/client_simulation.txt
%%DATADIR%%/etc/client-simulation.txt
%%DATADIR%%/etc/common-primes.txt
%%DATADIR%%/etc/curves.txt
-%%DATADIR%%/etc/Linux.pem
-%%DATADIR%%/etc/Microsoft.pem
-%%DATADIR%%/etc/Mozilla.pem
-%%DATADIR%%/etc/README.md
%%DATADIR%%/etc/tls_data.txt
%%DATADIR%%/utils/00_unittest_baseline.sh
%%DATADIR%%/utils/ccs-injection.bash
@@ -21,6 +20,7 @@ man/man1/testssl.1.gz
%%DATADIR%%/utils/gmap2testssl.sh
%%DATADIR%%/utils/heartbleed.bash
%%DATADIR%%/utils/make-openssl.sh
+%%DATADIR%%/utils/make-openssl111.sh
%%DATADIR%%/utils/parse_client_ciphers.pl
%%DATADIR%%/utils/prototype.ssl2proto-check.bash
%%DATADIR%%/utils/prototype.tls-protocol-checker.bash