aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
committerflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
commit02ba370ac4348e20c88c9698d4e91f3fe34868c8 (patch)
treeab399d9912d8f00891d9d8508edf96aa3ef0bc0b /security
parentab79042bad4c4010d43e6983f39a47e3575126a5 (diff)
downloadfreebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.gz
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.zst
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.zip
Fix installation of ports that rely on cp -n for installing files. r245960
changed cp to exit with a non-zero exit code if the file exists and is not overwritten thus causing ports to fail installing when e.g. trying to cp .default -> .conf files that already exist. We just ignore the error and continue, as we used to. Reported by: jaset Approved by: portmgr (bapt)
Diffstat (limited to 'security')
-rw-r--r--security/sancp/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/sancp/Makefile b/security/sancp/Makefile
index 2ae5f630fe08..8774aaf48bfe 100644
--- a/security/sancp/Makefile
+++ b/security/sancp/Makefile
@@ -31,7 +31,7 @@ post-extract:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/sancp ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/etc/sancp/sancp.conf ${PREFIX}/etc/sancp.conf-dist
- @${CP} -n ${PREFIX}/etc/sancp.conf-dist ${PREFIX}/etc/sancp.conf
+ @${CP} -n ${PREFIX}/etc/sancp.conf-dist ${PREFIX}/etc/sancp.conf || ${TRUE}
.if !defined(NOPORTDOCS)
@${INSTALL} -d ${DOCSDIR}/