aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2007-06-05 03:51:34 +0800
committersobomax <sobomax@FreeBSD.org>2007-06-05 03:51:34 +0800
commit06cf69e11ac67f91744ce5d75ceefcb0215aad16 (patch)
treecd37fdea3d5cbaa3cc84d71f33a14d2c378c1632 /security
parent4e3f2cfe0577064eb9e89c1fe2574e0d7c5f9b87 (diff)
downloadfreebsd-ports-gnome-06cf69e11ac67f91744ce5d75ceefcb0215aad16.tar.gz
freebsd-ports-gnome-06cf69e11ac67f91744ce5d75ceefcb0215aad16.tar.zst
freebsd-ports-gnome-06cf69e11ac67f91744ce5d75ceefcb0215aad16.zip
Add pvt 20070406, tool to convert a RSA key in PEM format into a PVK
file and vice versa.
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pvt/Makefile25
-rw-r--r--security/pvt/distinfo3
-rw-r--r--security/pvt/files/patch-Makefile23
-rw-r--r--security/pvt/pkg-descr4
-rw-r--r--security/pvt/pkg-plist3
6 files changed, 59 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 46979dd695ea..597cba3401e7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -581,6 +581,7 @@
SUBDIR += pscan
SUBDIR += pure-sfv
SUBDIR += putty
+ SUBDIR += pvt
SUBDIR += pwauth
SUBDIR += pwman
SUBDIR += pxytest
diff --git a/security/pvt/Makefile b/security/pvt/Makefile
new file mode 100644
index 000000000000..e14cc40f7f58
--- /dev/null
+++ b/security/pvt/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: pvk
+# Date created: 6 June 2007
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pvk
+PORTVERSION= 20070406
+CATEGORIES= security
+MASTER_SITES= http://www.drh-consultancy.demon.co.uk/
+DISTNAME= pvksrc
+EXTRACT_SUFX= .tgz.bin
+
+MAINTAINER= sobomax@FreeBSD.org
+COMMENT= Tool to convert a RSA key in PEM format into a PVK file and vice versa
+
+WRKSRC= ${WRKDIR}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pvk ${PREFIX}/bin
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/pvt/distinfo b/security/pvt/distinfo
new file mode 100644
index 000000000000..6acb1706a914
--- /dev/null
+++ b/security/pvt/distinfo
@@ -0,0 +1,3 @@
+MD5 (pvksrc.tgz.bin) = fd1e386a9611cf7f3dcf9a28fdf21b5c
+SHA256 (pvksrc.tgz.bin) = 181d83f4f44ba01ecc4d9d115152cc01e42d837aad9f5127201594dba12a1fa0
+SIZE (pvksrc.tgz.bin) = 7463
diff --git a/security/pvt/files/patch-Makefile b/security/pvt/files/patch-Makefile
new file mode 100644
index 000000000000..0d257caf4784
--- /dev/null
+++ b/security/pvt/files/patch-Makefile
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- Makefile.orig
++++ Makefile
+@@ -4,7 +4,7 @@
+ SSLINC=/usr/local/ssl/include
+ SSLLIB=/usr/local/ssl/lib
+
+-CFLAGS=-Wall -I$(SSLINC)
++CFLAGS+=-Wall
+
+ all: pvk
+
+@@ -13,7 +13,7 @@
+ $(OBJS): pvk.h
+
+ pvk: $(OBJS) pvk.o pvk.h
+- $(CC) $(CFLAGS) -o pvk pvk.o $(OBJS) -L$(SSLLIB) -lcrypto
++ $(CC) $(CFLAGS) -o pvk pvk.o $(OBJS) -lcrypto
+
+ errors:
+ perl $(TOP)/util/mkerr.pl -nostatic -conf pvk.ec -write *.c
diff --git a/security/pvt/pkg-descr b/security/pvt/pkg-descr
new file mode 100644
index 000000000000..d75172619d24
--- /dev/null
+++ b/security/pvt/pkg-descr
@@ -0,0 +1,4 @@
+Conversion tool that will convert a standard RSA key in OpenSSL PEM format
+into a PVK file and vice versa.
+
+WWW: http://www.drh-consultancy.demon.co.uk/pvk.html
diff --git a/security/pvt/pkg-plist b/security/pvt/pkg-plist
new file mode 100644
index 000000000000..a0d7e97e4d2f
--- /dev/null
+++ b/security/pvt/pkg-plist
@@ -0,0 +1,3 @@
+bin/pvk
+share/doc/pvk/README
+@dirrm share/doc/pvk