aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-08-13 05:26:07 +0800
committerpav <pav@FreeBSD.org>2006-08-13 05:26:07 +0800
commit0fb4e0be9cb278c482b3b6ee45526ad6e608d24b (patch)
tree933d7ab392f1bdb3ad195f43701cbbc2d292de7a /security
parent5ae5115f65a8d2a0c2399d4886f8e5ab55059597 (diff)
downloadfreebsd-ports-gnome-0fb4e0be9cb278c482b3b6ee45526ad6e608d24b.tar.gz
freebsd-ports-gnome-0fb4e0be9cb278c482b3b6ee45526ad6e608d24b.tar.zst
freebsd-ports-gnome-0fb4e0be9cb278c482b3b6ee45526ad6e608d24b.zip
- Fix build on 4.X
- Respect CC and CFLAGS PR: ports/101750 Submitted by: Babak Farrokhi <babak@farrokhi.net> (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/lsh/Makefile2
-rw-r--r--security/lsh/files/patch-nettle-openssl.c10
2 files changed, 12 insertions, 0 deletions
diff --git a/security/lsh/Makefile b/security/lsh/Makefile
index c40c1cd3d38b..83c1b38ecc2b 100644
--- a/security/lsh/Makefile
+++ b/security/lsh/Makefile
@@ -23,7 +23,9 @@ LIB_DEPENDS+= oop:${PORTSDIR}/devel/liboop
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_GCC= 3.4+
INSTALL_TARGET= install
+CONFIGURE_ENV= PREFIX="${PREFIX}" CC="${CC}" CFLAGS="${CFLAGS}"
CONFIGURE_ARGS+= --with-include-path=${LOCALBASE}/include
CONFIGURE_ARGS+= --with-lib-path=${LOCALBASE}/lib
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
diff --git a/security/lsh/files/patch-nettle-openssl.c b/security/lsh/files/patch-nettle-openssl.c
new file mode 100644
index 000000000000..9c31a80bda0b
--- /dev/null
+++ b/security/lsh/files/patch-nettle-openssl.c
@@ -0,0 +1,10 @@
+--- src/nettle/examples/nettle-openssl.c.orig Thu Aug 10 13:24:43 2006
++++ src/nettle/examples/nettle-openssl.c Thu Aug 10 13:24:53 2006
+@@ -36,6 +36,7 @@
+ #define OPENSSL_DISABLE_OLD_DES_SUPPORT
+
+ #include <assert.h>
++#include <stddef.h>
+
+ #include <openssl/aes.h>
+ #include <openssl/blowfish.h>