aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-11 12:09:29 +0800
committermarino <marino@FreeBSD.org>2016-09-11 12:09:29 +0800
commit1227da01fb0573b8f35f1605242e5cf206816f17 (patch)
tree8f205b8d858d499e569e6b4cc29ebf7c8aa18a57 /security
parent58b7b4d3e4d5cd2e391407df8e9988bc97603e88 (diff)
downloadfreebsd-ports-gnome-1227da01fb0573b8f35f1605242e5cf206816f17.tar.gz
freebsd-ports-gnome-1227da01fb0573b8f35f1605242e5cf206816f17.tar.zst
freebsd-ports-gnome-1227da01fb0573b8f35f1605242e5cf206816f17.zip
security/pad: Add SSL flags and honor them
While here, convert to USES+=tar Approved by: SSL blanket
Diffstat (limited to 'security')
-rw-r--r--security/pad/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/security/pad/Makefile b/security/pad/Makefile
index c1a20cdf5a4c..e58ace3c0192 100644
--- a/security/pad/Makefile
+++ b/security/pad/Makefile
@@ -7,17 +7,23 @@ PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://keyserver.kjsl.com/~jharris/distfiles/
-EXTRACT_SUFX= .tgz
MAINTAINER= jharris@widomaker.com
COMMENT= Command-line utility to encrypt files
+USES= tar:tgz ssl
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
PLIST_FILES= bin/pad man/man1/pad.1.gz
PORTDOCS= COPYING README ChangeLog
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|\(-lcrypto\)|${LDFLAGS} \1|g" \
+ ${WRKSRC}/Makefile.in
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pad ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/pad.1 ${STAGEDIR}${MANPREFIX}/man/man1