aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-01-21 21:20:31 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:27:22 +0800
commit145a7ab4240db2efcc2eac6ffb89a8c20e28e868 (patch)
tree24716004e334e2714c00dd4917b624e3cb249e73 /security
parent522905ac12f8d68b72347ce9ae67247fd50fc95e (diff)
downloadfreebsd-ports-gnome-145a7ab4240db2efcc2eac6ffb89a8c20e28e868.tar.gz
freebsd-ports-gnome-145a7ab4240db2efcc2eac6ffb89a8c20e28e868.tar.zst
freebsd-ports-gnome-145a7ab4240db2efcc2eac6ffb89a8c20e28e868.zip
New port: security/py-pyblake2
pyblake2 is an extension module for Python implementing BLAKE2 hash function. WWW: https://github.com/dchest/pyblake2
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-pyblake2/Makefile22
-rw-r--r--security/py-pyblake2/distinfo3
-rw-r--r--security/py-pyblake2/files/patch-setup.py11
-rw-r--r--security/py-pyblake2/pkg-descr3
5 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e725dd40af3e..694683729290 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -948,6 +948,7 @@
SUBDIR += py-pyaes
SUBDIR += py-pyaff4
SUBDIR += py-pyaxo
+ SUBDIR += py-pyblake2
SUBDIR += py-pyclamd
SUBDIR += py-pycrypto
SUBDIR += py-pycryptodome
diff --git a/security/py-pyblake2/Makefile b/security/py-pyblake2/Makefile
new file mode 100644
index 000000000000..2855365cd920
--- /dev/null
+++ b/security/py-pyblake2/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= pyblake2
+PORTVERSION= 0.9.3
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= BLAKE2 hash function extension module
+
+LICENSE= CC0-1.0
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= python
+USE_PYTHON= distutils autoplist
+TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+do-test:
+ @(cd ${TEST_WRKSRC}; ${SETENV} ${TEST_ENV} ${PYTHON_CMD} test/test.py)
+
+.include <bsd.port.mk>
diff --git a/security/py-pyblake2/distinfo b/security/py-pyblake2/distinfo
new file mode 100644
index 000000000000..684fe0e49f49
--- /dev/null
+++ b/security/py-pyblake2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509626218
+SHA256 (pyblake2-0.9.3.tar.gz) = 626448e1fe1cc01d2197118954bec9f158378577e12686d5b01979f7f0fa2212
+SIZE (pyblake2-0.9.3.tar.gz) = 130641
diff --git a/security/py-pyblake2/files/patch-setup.py b/security/py-pyblake2/files/patch-setup.py
new file mode 100644
index 000000000000..ca0c8f412082
--- /dev/null
+++ b/security/py-pyblake2/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2014-04-13 10:53:47 UTC
++++ setup.py
+@@ -22,7 +22,7 @@ import platform
+
+ # Version of optimized implementation to use.
+
+-if platform.machine() == "x86_64":
++if platform.machine() == "x86_64" or platform.machine() == "amd64":
+ # Every x86_64 machine has at least SSE2.
+ opt_version = "BLAKE2_COMPRESS_SSE2"
+ else:
diff --git a/security/py-pyblake2/pkg-descr b/security/py-pyblake2/pkg-descr
new file mode 100644
index 000000000000..36031e1a0825
--- /dev/null
+++ b/security/py-pyblake2/pkg-descr
@@ -0,0 +1,3 @@
+pyblake2 is an extension module for Python implementing BLAKE2 hash function.
+
+WWW: https://github.com/dchest/pyblake2