aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2005-10-15 02:18:45 +0800
committersergei <sergei@FreeBSD.org>2005-10-15 02:18:45 +0800
commit15e519c43a156a9c844c1b464be28997a430dda4 (patch)
tree84e7626157338fb4935229d90def564f526b1742 /security
parent153447b678a6764f058d3857948507f3554c32f5 (diff)
downloadfreebsd-ports-gnome-15e519c43a156a9c844c1b464be28997a430dda4.tar.gz
freebsd-ports-gnome-15e519c43a156a9c844c1b464be28997a430dda4.tar.zst
freebsd-ports-gnome-15e519c43a156a9c844c1b464be28997a430dda4.zip
Add security/libpreludedb:
This library provides a framework for easy access to the Prelude database. WWW: http://www.prelude-ids.org/
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/libpreludedb/Makefile68
-rw-r--r--security/libpreludedb/distinfo4
-rw-r--r--security/libpreludedb/files/patch-Makefile.in11
-rw-r--r--security/libpreludedb/pkg-descr6
-rw-r--r--security/libpreludedb/pkg-plist59
6 files changed, 149 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e86c1aa718a5..9f14ad45dd64 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -201,6 +201,7 @@
SUBDIR += libotr
SUBDIR += libparanoia
SUBDIR += libprelude
+ SUBDIR += libpreludedb
SUBDIR += libsectok
SUBDIR += libssh2
SUBDIR += libtasn1
diff --git a/security/libpreludedb/Makefile b/security/libpreludedb/Makefile
new file mode 100644
index 000000000000..35797e4fdd5b
--- /dev/null
+++ b/security/libpreludedb/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: libpreludedb
+# Date created: 2005-10-14
+# Whom: Sergei Kolobov <sergei@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libpreludedb
+PORTVERSION= 0.9.0
+CATEGORIES= security
+MASTER_SITES= http://www.prelude-ids.org/download/releases/
+
+MAINTAINER= sergei@FreeBSD.org
+COMMENT= Framework library for access to Prelude NIDS database
+
+LIB_DEPENDS= prelude.2:${PORTSDIR}/security/libprelude
+
+USE_GPG= yes
+SIG_SUFFIX= .sig
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.if defined(WITH_PERL)
+USE_PERL5= yes
+CONFIGURE_ARGS+= --enable-perl
+PLIST_SUB+= WITH_PERL=""
+.else
+CONFIGURE_ARGS+= --disable-perl
+PLIST_SUB+= WITH_PERL="@comment "
+.endif
+
+.if defined(WITH_PYTHON)
+USE_PYTHON= yes
+CONFIGURE_ARGS+= --enable-python
+PLIST_SUB+= WITH_PYTHON=""
+.else
+CONFIGURE_ARGS+= --disable-python
+PLIST_SUB+= WITH_PYTHON="@comment "
+.endif
+
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+CONFIGURE_ARGS+= --enable-mysql
+PLIST_SUB+= WITH_MYSQL=""
+.else
+CONFIGURE_ARGS+= --disable-mysql
+PLIST_SUB+= WITH_MYSQL="@comment "
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PGSQL= yes
+CONFIGURE_ARGS+= --enable-pgsql
+PLIST_SUB+= WITH_PGSQL=""
+.else
+CONFIGURE_ARGS+= --disable-pgsql
+PLIST_SUB+= WITH_PGSQL="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/api/html/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/libpreludedb/distinfo b/security/libpreludedb/distinfo
new file mode 100644
index 000000000000..2f8e8636fa19
--- /dev/null
+++ b/security/libpreludedb/distinfo
@@ -0,0 +1,4 @@
+MD5 (libpreludedb-0.9.0.tar.gz) = ea644bd5487e020fdea539c6ad2242d4
+SIZE (libpreludedb-0.9.0.tar.gz) = 557495
+MD5 (libpreludedb-0.9.0.tar.gz.sig) = fd2e2c6f2db47e10c245128c6cdeb280
+SIZE (libpreludedb-0.9.0.tar.gz.sig) = 827
diff --git a/security/libpreludedb/files/patch-Makefile.in b/security/libpreludedb/files/patch-Makefile.in
new file mode 100644
index 000000000000..2f471375c2f3
--- /dev/null
+++ b/security/libpreludedb/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Oct 14 20:45:15 2005
++++ Makefile.in Fri Oct 14 20:45:27 2005
+@@ -185,7 +185,7 @@ ACLOCAL_AMFLAGS = -I m4 -I libmissing/m4
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+ EXTRA_DIST = LICENSE.README HACKING.README
+
+-SUBDIRS = m4 libmissing src plugins bindings docs
++SUBDIRS = m4 libmissing src plugins bindings
+
+ bin_SCRIPTS = $(top_builddir)/libpreludedb-config
+ distuninstallcheck_listfiles = find . -type f -print | grep -v 'perl' | grep -v '3pm'
diff --git a/security/libpreludedb/pkg-descr b/security/libpreludedb/pkg-descr
new file mode 100644
index 000000000000..2e09e580d8df
--- /dev/null
+++ b/security/libpreludedb/pkg-descr
@@ -0,0 +1,6 @@
+Prelude is a new innovative hybrid Intrusion Detection system designed
+to be very modular, distributed, rock solid and fast.
+
+This library provides a framework for easy access to the Prelude database.
+
+WWW: http://www.prelude-ids.org/
diff --git a/security/libpreludedb/pkg-plist b/security/libpreludedb/pkg-plist
new file mode 100644
index 000000000000..b834f01b4892
--- /dev/null
+++ b/security/libpreludedb/pkg-plist
@@ -0,0 +1,59 @@
+@comment $FreeBSD$
+bin/preludedb-admin
+bin/libpreludedb-config
+include/libpreludedb/preludedb-path-selection.h
+include/libpreludedb/preludedb-plugin-sql.h
+include/libpreludedb/preludedb-plugin-format.h
+include/libpreludedb/preludedb-sql-settings.h
+include/libpreludedb/preludedb-sql.h
+include/libpreludedb/preludedb-version.h
+include/libpreludedb/preludedb-error.h
+include/libpreludedb/preludedb.h
+lib/libpreludedb.so.0
+lib/libpreludedb.so
+lib/libpreludedb.a
+lib/libpreludedb/plugins/formats/classic.so
+%%WITH_MYSQL%%lib/libpreludedb/plugins/sql/mysql.so
+%%WITH_MYSQL%%@unexec rmdir %D/lib/libpreludedb/plugins/sql 2> /dev/null || true
+%%WITH_PGSQL%%lib/libpreludedb/plugins/sql/pgsql.so
+%%WITH_PGSQL%%@unexec rmdir %D/lib/libpreludedb/plugins/sql 2> /dev/null || true
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/PreludeDB.pm
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/PreludeDB/.packlist
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/PreludeDB/PreludeDB.bs
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/PreludeDB/PreludeDB.so
+%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/_preludedb.so
+%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/preludedb.py
+%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/preludedb.pyc
+share/aclocal/libpreludedb.m4
+%%DATADIR%%/classic/mysql.sql
+%%DATADIR%%/classic/mysql-update-14-1.sql
+%%DATADIR%%/classic/mysql-update-14-2.sql
+%%DATADIR%%/classic/mysql-update-14-3.sql
+%%DATADIR%%/classic/pgsql.sql
+%%DATADIR%%/classic/pgsql-update-14-1.sql
+%%DATADIR%%/classic/pgsql-update-14-2.sql
+%%DATADIR%%/classic/pgsql-update-14-3.sql
+%%PORTDOCS%%%%DOCSDIR%%/ch01.html
+%%PORTDOCS%%%%DOCSDIR%%/home.png
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/index.sgml
+%%PORTDOCS%%%%DOCSDIR%%/left.png
+%%PORTDOCS%%%%DOCSDIR%%/libpreludedb-preludedb-error.html
+%%PORTDOCS%%%%DOCSDIR%%/libpreludedb-preludedb-path-selection.html
+%%PORTDOCS%%%%DOCSDIR%%/libpreludedb-preludedb-plugin-format.html
+%%PORTDOCS%%%%DOCSDIR%%/libpreludedb-preludedb-plugin-sql.html
+%%PORTDOCS%%%%DOCSDIR%%/libpreludedb-preludedb-sql-settings.html
+%%PORTDOCS%%%%DOCSDIR%%/libpreludedb-preludedb-sql.html
+%%PORTDOCS%%%%DOCSDIR%%/libpreludedb-preludedb-version.html
+%%PORTDOCS%%%%DOCSDIR%%/libpreludedb-preludedb.html
+%%PORTDOCS%%%%DOCSDIR%%/right.png
+%%PORTDOCS%%%%DOCSDIR%%/libpreludedb.devhelp
+%%PORTDOCS%%%%DOCSDIR%%/style.css
+%%PORTDOCS%%%%DOCSDIR%%/up.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/classic
+@dirrm %%DATADIR%%
+@dirrm lib/libpreludedb/plugins/formats
+@dirrm lib/libpreludedb/plugins
+@dirrm lib/libpreludedb
+@dirrm include/libpreludedb