aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2012-06-17 18:08:30 +0800
committerdougb <dougb@FreeBSD.org>2012-06-17 18:08:30 +0800
commit234d44ded912f57558d345acb4a5d383b6f68d1b (patch)
treee91eeb637ca67d09d669b01af7c3d1b57af90a17 /security
parent7e74296759e20cb5b3fafa784ba47b8c1a0f144f (diff)
downloadfreebsd-ports-gnome-234d44ded912f57558d345acb4a5d383b6f68d1b.tar.gz
freebsd-ports-gnome-234d44ded912f57558d345acb4a5d383b6f68d1b.tar.zst
freebsd-ports-gnome-234d44ded912f57558d345acb4a5d383b6f68d1b.zip
The submitter points out that this service doesn't start because it relies
on the database to be up first, which given the previous REQUIRE line could only have happened by accident. So change the REQUIRE to LOGIN, which matches how we like ports scripts to run generally, and add postgresql mysql. While I'm here: 1. Add a $FreeBSD$ 2. Add KEYWORD: shutdown 3. Sort the structure to be more standard 4. Move the obviously non-optional flags to command_args Bump PORTREVISION to reflect these changes. Submitted by: Варнаков Кирилл <kiril@varnakov.net>
Diffstat (limited to 'security')
-rw-r--r--security/prelude-lml/Makefile2
-rw-r--r--security/prelude-lml/files/prelude-lml.sh.in16
2 files changed, 10 insertions, 8 deletions
diff --git a/security/prelude-lml/Makefile b/security/prelude-lml/Makefile
index bc68ae92c1f5..7c76ecb63fac 100644
--- a/security/prelude-lml/Makefile
+++ b/security/prelude-lml/Makefile
@@ -6,7 +6,7 @@
PORTNAME= prelude-lml
PORTVERSION= 0.9.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.prelude-technologies.com/download/releases/${PORTNAME}/
diff --git a/security/prelude-lml/files/prelude-lml.sh.in b/security/prelude-lml/files/prelude-lml.sh.in
index e0e5bf1f98fd..9da1f133c303 100644
--- a/security/prelude-lml/files/prelude-lml.sh.in
+++ b/security/prelude-lml/files/prelude-lml.sh.in
@@ -1,7 +1,10 @@
#!/bin/sh
+# $FreeBSD$
+#
# PROVIDE: prelude_lml
-# REQUIRE: NETWORKING SERVERS
+# REQUIRE: LOGIN postgresql mysql
+# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
# to enable this service:
@@ -9,19 +12,18 @@
# prelude_lml_enable (bool): Set to NO by default.
# Set it to YES to enable Prelude LML.
# prelude_lml_flags (flags): Set arguments to use with Prelude LML
-#
. /etc/rc.subr
name="prelude_lml"
rcvar=prelude_lml_enable
-command=%%PREFIX%%/bin/prelude-lml
-pidfile=/var/run/prelude-lml.pid
-
load_rc_config $name
-: ${prelude_lml_enable="NO"}
-: ${prelude_lml_flags="-d -P ${pidfile}"}
+: ${prelude_lml_enable:="NO"}
+
+command=%%PREFIX%%/bin/prelude-lml
+pidfile=/var/run/prelude-lml.pid
+command_args="-d -P $pidfile"
run_rc_command "$1"