aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-05-16 12:47:22 +0800
committermiwi <miwi@FreeBSD.org>2012-05-16 12:47:22 +0800
commit2de4ed4399ac6be0b822f5b06fdcb09f7956bf08 (patch)
treed8d2a9a0021af3a408978bb1938c7b35522ff9c7 /security
parent6c551117864b17bbec845445e5e0199b483c2473 (diff)
downloadfreebsd-ports-gnome-2de4ed4399ac6be0b822f5b06fdcb09f7956bf08.tar.gz
freebsd-ports-gnome-2de4ed4399ac6be0b822f5b06fdcb09f7956bf08.tar.zst
freebsd-ports-gnome-2de4ed4399ac6be0b822f5b06fdcb09f7956bf08.zip
Extension used for detecting XSS codes(tainted string)
WWW: http://pecl.php.net/package/taint PR: 165319 Submitted by: John Chen <johnpupu@gmail.com>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pecl-taint/Makefile26
-rw-r--r--security/pecl-taint/distinfo2
-rw-r--r--security/pecl-taint/pkg-descr3
4 files changed, 32 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 572736d23413..cb4da141760b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -649,6 +649,7 @@
SUBDIR += pecl-gnupg
SUBDIR += pecl-pam
SUBDIR += pecl-ssh2
+ SUBDIR += pecl-taint
SUBDIR += pecl-tcpwrap
SUBDIR += pft
SUBDIR += pgp
diff --git a/security/pecl-taint/Makefile b/security/pecl-taint/Makefile
new file mode 100644
index 000000000000..cfe53018e408
--- /dev/null
+++ b/security/pecl-taint/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: php-yaf
+# Date created: 13 May 2011
+# Whom: johnpupu <johnpupu@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= taint
+PORTVERSION= 0.5.2
+CATEGORIES= security
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= johnpupu@gmail.com
+COMMENT= Extension used for detecting XSS codes(tainted string)
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS= --with-php-config=${PREFIX}/bin/php-config
+
+USE_PHP= yes
+USE_PHPEXT= yes
+USE_PHPIZE= yes
+
+.include <bsd.port.mk>
diff --git a/security/pecl-taint/distinfo b/security/pecl-taint/distinfo
new file mode 100644
index 000000000000..aa21e0e446f5
--- /dev/null
+++ b/security/pecl-taint/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PECL/taint-0.5.2.tgz) = 78c429ef8ec50347fceb76e5a0495ff2a4c3fd3a37d45731b4aa65a4acd3f9a5
+SIZE (PECL/taint-0.5.2.tgz) = 14861
diff --git a/security/pecl-taint/pkg-descr b/security/pecl-taint/pkg-descr
new file mode 100644
index 000000000000..7ecfe80b5259
--- /dev/null
+++ b/security/pecl-taint/pkg-descr
@@ -0,0 +1,3 @@
+extension used for detecting XSS codes(tainted string)
+
+WWW: http://pecl.php.net/package/taint