aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2007-12-28 01:19:23 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2007-12-28 01:19:23 +0800
commit353ee14921f5ae903d17bc938ff78345156a6f21 (patch)
treefde34bf7c582c1da12a28166c5772830fd659a01 /security
parente691dd2d4753c3326fd367961f1692e37f6b69d5 (diff)
downloadfreebsd-ports-gnome-353ee14921f5ae903d17bc938ff78345156a6f21.tar.gz
freebsd-ports-gnome-353ee14921f5ae903d17bc938ff78345156a6f21.tar.zst
freebsd-ports-gnome-353ee14921f5ae903d17bc938ff78345156a6f21.zip
- Update to 0.48
- Remove pre-everything (no more false positives) - Remove patches (extra_patches and patch in files directory) PR: ports/118930 Submitted by: Philippe Audeoud <jadawin tuxaco.net> Approved by: Luiz Eduardo Roncato Cordeiro <cordeiro nic.br> (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/chkrootkit/Makefile24
-rw-r--r--security/chkrootkit/distinfo6
-rw-r--r--security/chkrootkit/files/600000-patch-chkproc.c21
3 files changed, 5 insertions, 46 deletions
diff --git a/security/chkrootkit/Makefile b/security/chkrootkit/Makefile
index 5ee6ac684e4b..aa17a8503509 100644
--- a/security/chkrootkit/Makefile
+++ b/security/chkrootkit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= chkrootkit
-PORTVERSION= 0.47
+PORTVERSION= 0.48
CATEGORIES= security
MASTER_SITES= ftp://ftp.pangeia.com.br/pub/seg/pac/ \
ftp://gd.tuwien.ac.at/infosys/security/chkrootkit/ \
@@ -30,26 +30,6 @@ PORTDOCS= ACKNOWLEDGMENTS COPYRIGHT README README.chklastlog README.chkwtmp
BINMODE= 0700
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 600000
-
-EXTRA_PATCHES= ${PATCHDIR}/600000-patch-chkproc.c
-
-pre-everything::
- @${ECHO_CMD} "######################################################################"
- @${ECHO_CMD} "#"
- @${ECHO_CMD} "# WARNING: chkproc process gives false positives values on"
- @${ECHO_CMD} "# FreeBSD >= 6.x, and, due this fact, the getpriority code"
- @${ECHO_CMD} "# added to identify LKMs was removed."
- @${ECHO_CMD} "# So, use with caution."
- @${ECHO_CMD} "#"
- @${ECHO_CMD} "# This error will be fixed in the next chkrootkit version."
- @${ECHO_CMD} "#"
- @${ECHO_CMD} "######################################################################"
-
-.endif
-
pre-patch:
${REINPLACE_CMD} -e "s/^CC/#CC/; s/^CFLAGS/#CFLAGS/" ${WRKSRC}/Makefile
${REINPLACE_CMD} -e \
@@ -78,4 +58,4 @@ do-install:
${INSTALL_DATA} ${PORTDOCS:C,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/chkrootkit/distinfo b/security/chkrootkit/distinfo
index 55809aeab050..7222401d5796 100644
--- a/security/chkrootkit/distinfo
+++ b/security/chkrootkit/distinfo
@@ -1,3 +1,3 @@
-MD5 (chkrootkit-0.47.tar.gz) = 4c6455d202cef35395a673386e4bf01a
-SHA256 (chkrootkit-0.47.tar.gz) = 5a5aeb597769cc2843648858b95fc7abd3485ba7edd1800d69e0125220c6669f
-SIZE (chkrootkit-0.47.tar.gz) = 37791
+MD5 (chkrootkit-0.48.tar.gz) = de8b8b5013e7faa2b66c0e33c59677e8
+SHA256 (chkrootkit-0.48.tar.gz) = b4b3d3540a7022aa7a81cae93f28c8475bc2660a21f88126725624c09769f1fb
+SIZE (chkrootkit-0.48.tar.gz) = 38323
diff --git a/security/chkrootkit/files/600000-patch-chkproc.c b/security/chkrootkit/files/600000-patch-chkproc.c
deleted file mode 100644
index 31d37609306b..000000000000
--- a/security/chkrootkit/files/600000-patch-chkproc.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- chkproc.c.orig Fri Nov 24 12:03:25 2006
-+++ chkproc.c Fri Nov 24 12:04:43 2006
-@@ -334,18 +334,6 @@
- }
- #endif
- }
-- else
-- {
-- errno = 0;
-- getpriority(PRIO_PROCESS, i);
-- if (!errno)
-- {
-- retdir++;
-- if (verbose)
-- printf ("PID %5d(%s): not in getpriority readdir output\n", i, buf);
-- }
-- }
--
- }
- if (retdir)
- printf("You have % 5d process hidden for readdir command\n", retdir);