aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-04-14 23:25:30 +0800
committerleeym <leeym@FreeBSD.org>2003-04-14 23:25:30 +0800
commit3ac59587613e3b534ede064d68c3d8abd8b6b172 (patch)
tree83b490e2eb8caa3a7f18660965e36494d6088ac1 /security
parent85e35ffed842481f2315b84a4fcfa871c7f2a33e (diff)
downloadfreebsd-ports-gnome-3ac59587613e3b534ede064d68c3d8abd8b6b172.tar.gz
freebsd-ports-gnome-3ac59587613e3b534ede064d68c3d8abd8b6b172.tar.zst
freebsd-ports-gnome-3ac59587613e3b534ede064d68c3d8abd8b6b172.zip
- Do not overwrite the existing config files when installing as a port or
as a package - Bump PORTREVISION Reported by: Forrest Aldrich <forrie@forrie.com> PR: 50915 Submitted by: Sergei Kolobov <sergei@kolobov.com>
Diffstat (limited to 'security')
-rw-r--r--security/logcheck/Makefile14
-rw-r--r--security/logcheck/pkg-plist8
2 files changed, 12 insertions, 10 deletions
diff --git a/security/logcheck/Makefile b/security/logcheck/Makefile
index 393e13c6aa01..29c5331041a4 100644
--- a/security/logcheck/Makefile
+++ b/security/logcheck/Makefile
@@ -7,7 +7,7 @@
PORTNAME= logcheck
PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ftp://sensimilia.eu.org/pub/software/sys/ \
http://www.ukc.mirror.ac.uk/sites/ftp.freebsd.org/pub/FreeBSD/ports/distfiles/ \
@@ -42,14 +42,16 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/logtail ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/systems/freebsd/logcheck.sh ${PREFIX}/etc
- ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/systems/freebsd && \
- ${INSTALL_DATA} ${CONFIG_FILES} ${EXAMPLESDIR} && \
- ${INSTALL_DATA} ${CONFIG_FILES} ${PREFIX}/etc
+ @${MKDIR} ${EXAMPLESDIR}
+.for file in ${CONFIG_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/systems/freebsd/${file} ${EXAMPLESDIR}
+ @${TEST} -f ${PREFIX}/etc/${file} || \
+ ${INSTALL_DATA} ${WRKSRC}/systems/freebsd/${file} ${PREFIX}/etc
+.endfor
${TEST} -d ${LOGCHECK_TMP} || ${MKDIR} -m 700 ${LOGCHECK_TMP}
${CHOWN} root:wheel ${LOGCHECK_TMP}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
diff --git a/security/logcheck/pkg-plist b/security/logcheck/pkg-plist
index 91f352dac5ed..7e4b64100ab6 100644
--- a/security/logcheck/pkg-plist
+++ b/security/logcheck/pkg-plist
@@ -1,13 +1,13 @@
bin/logtail
etc/logcheck.sh
-etc/logcheck.hacking
-etc/logcheck.ignore
-etc/logcheck.violations
-etc/logcheck.violations.ignore
%%EXAMPLESDIR%%/logcheck.hacking
+@exec test -f %D/etc/%f || cp %D/%f %D/etc
%%EXAMPLESDIR%%/logcheck.ignore
+@exec test -f %D/etc/%f || cp %D/%f %D/etc
%%EXAMPLESDIR%%/logcheck.violations.ignore
+@exec test -f %D/etc/%f || cp %D/%f %D/etc
%%EXAMPLESDIR%%/logcheck.violations
+@exec test -f %D/etc/%f || cp %D/%f %D/etc
@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%%%DOCSDIR%%/CREDITS
%%PORTDOCS%%%%DOCSDIR%%/INSTALL