aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2017-10-19 01:19:26 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:46:18 +0800
commit3b97fb28c66103f0071b8a4a0a9b3b736b5e8b26 (patch)
tree956228753c0e94b361d4457964f8220117258437 /security
parent0c4820b2b7e8b4bb7e7afaa887021ce9461bdfae (diff)
downloadfreebsd-ports-gnome-3b97fb28c66103f0071b8a4a0a9b3b736b5e8b26.tar.gz
freebsd-ports-gnome-3b97fb28c66103f0071b8a4a0a9b3b736b5e8b26.tar.zst
freebsd-ports-gnome-3b97fb28c66103f0071b8a4a0a9b3b736b5e8b26.zip
LibreSSL + LDNS: Fix random crashes.
This happens due to ldns-config --libs adding in too many libraries (overlinking), and -lcrypto again, which causes some strange conflict/corruption. By specifying the path to --with-ldns, configure only adds in -ldns rather than every library ldns itself needs. PR: 223000 Reported by: many
Diffstat (limited to 'security')
-rw-r--r--security/openssh-portable/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index f9f227d3e345..45b14a27a9a2 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openssh
DISTVERSION= 7.6p1
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= security ipv6
MASTER_SITES= OPENBSD/OpenSSH/portable
@@ -26,7 +26,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --with-md5-passwords \
ETCOLD= ${PREFIX}/etc
-BROKEN_SSL= openssl-devel libressl
BROKEN_SSL_REASON_openssl-devel= incomplete definition of type struct rsa_st
BROKEN_SSL_REASON_libressl= random crashes with 7.6 PR 223000
@@ -53,7 +52,7 @@ OPTIONS_SUB= yes
TCP_WRAPPERS_EXTRA_PATCHES=${FILESDIR}/extra-patch-tcpwrappers
-LDNS_CONFIGURE_WITH= ldns
+LDNS_CONFIGURE_WITH= ldns=${LOCALBASE}
LDNS_LIB_DEPENDS= libldns.so:dns/ldns
LDNS_EXTRA_PATCHES= ${FILESDIR}/extra-patch-ldns
LDNS_CFLAGS= -I${LOCALBASE}/include